1
VoLTE Testing after upgrade to 3.2.1

  1. dwlimf
    Froyo Jul 18, 2016

    dwlimf , Jul 18, 2016 :
    As we have seen in many other threads users of the Oneplus 3 are having issues with VoLTE after upgrading to 3.2.1

    Since I am on T-Mobile and most of the users with this issue seem to be on T-Mobile I can only speak about testing on T-Mobile network.

    The main problem is that the person you called (or called you) says that you are dropping out but you can hear them the whole time but they don’t always hear you.

    I had called OP level 2 and they confirmed this and asked me to downgrade until they resolved the issue. Generally I don’t like to downgrade so I have been doing some testing.

    I saw another thread about data speeds and improving it by changing your APN. So I was thinking that VoLTE would be on my data so I should try some settings to see if I can improve my problem.

    So I called an echo line 1-909-390-0003 you just talk and it echo’s back what you say. Also you can call yourself or any voice mail that is yours leave a message then listen for drops when you playback.

    So I noticed that my APN was set for T-Mobile US (epc.tmbile.com)

    Other choices were T-Mobile US LTE (fast.t-mobilecom) and T-Mobile US LTE IPv6 (fast.t-mobilecom)

    So I tried several test calls to the test number with each API.

    Based on the echo I seem to have had the best results with APN set to either T-Mobile US LTE (fast.t-mobilecom) or T-Mobile US LTE IPv6 (fast.t-mobilecom) and much worse results with T-Mobile US (epc.tmbile.com).

    Again to be clear this is all about and only for Voice calls.

    But still when I am on real calls constantly people are saying they cannot hear me. But it seems better with the APN set to T-Mobile US LTE (fast.t-mobilecom) or T-Mobile US LTE IPv6 (fast.t-mobilecom)

    I was wondering if others with this same problem want to try to change their APN to see if they get improvement with VoLTE calling.

    Also as a side note it seems that we should all be setting our APN for T-Mobile US LTE (fast.t-mobilecom) or T-Mobile US LTE IPv6 (fast.t-mobilecom). Seems if you by your phone from T-mobile this is what it would be set to and if you don’t buy it from T-Mobile they recommend that you make this change to any phone that you use that was not originally from T-Mobile.

    But in the end it seems that nothing improves the VoLTE calls quality to what I had on 3.1.2 so if this is not fixed soon I may have to just downgrade.

    But I wanted to put this out there to see what others experience with this same issue on T-Mobile (or other carrier if you have the same options/settings to play with).
     

    #1
    carniby likes this.
  2. G_Phillip_Ho_bsMd
    Cupcake Jul 19, 2016

    G_Phillip_Ho_bsMd , Jul 19, 2016 :
    Yup same issue, i just disable VoLTE and all is good. Hopes this gets fixed in the next update, also wifi calling would be great too.
     

    #2
  3. lkosova
    Ice Cream Sandwich Jul 19, 2016

    lkosova , Jul 19, 2016 :
    Same but just side loaded today and it seems better.... Will see how tommorow goes. All settings the same. I am on 3.2.1.

    Strangely epc on 3.1.2 worked as well as fast . Tmobile for me in a major city with great Tmobile service. I called Tmobile and they said also to change to fast . Tmobile. I barely ever use WiFi.
     

    #3
  4. carniby
    Donut Jul 19, 2016


    #4
  5. DasBeste
    Froyo Jul 19, 2016

    DasBeste , Jul 19, 2016 :
    After update 3.2.1 I also had to disable the VoLTE, regardless apn select is the only way to receive or make a call
     

    #5
  6. snafu_
    Gingerbread Jul 19, 2016

    snafu_ , Jul 19, 2016 :
    I was experiencing the same issue on 3.2.1. I live in a weak signal area for T-Mobile. I also tried the alternate APNs without much help. However after disabling VoLTE and staying on 3.2.1, all my connectivity problems went away. No more one way conversations or dropped calls,
     

    #6
  7. jasonarima
    Gingerbread Jul 22, 2016

    jasonarima , Jul 22, 2016 :
    I am using 3.2.1 and also use VoLTE on TMobiile network. But I haven't observed obvious call quality downgrade so far. May I know how serious of this no sound issue? Does it always happen or just happen randomly? The no sound period during the call is long or short?

    I found a solution which is suggest to sideload 3.2.1 ROM again.
    Some users feedback this no voice issue gone.
    May be you can try this.

    https://forums.oneplus.net/threads/i-found-a-solution-for-my-v3-2-1-microphone-issue.456022/
     
    Last edited: Jul 22, 2016

    #7
  8. prashant sahni
    Jelly Bean Jul 23, 2016


    #8
  9. Sidharth Krishnan
    Froyo Jul 23, 2016

    Sidharth Krishnan , Jul 23, 2016 :
    How is it , is the Jio sim Working in 1+3.should I need to install all the unwanted Jio apps to get unlimited data? Please answer
     

    #9
  10. Sukhpreet Gill
    Gingerbread Jul 24, 2016

    Sukhpreet Gill , Jul 24, 2016 :
    Yes it works great. You just need to download the top 4 apps and not the entire junk. Post you click on the unlimited data offer, it will redirect you to the Google Play store to download 4 of them. Once the app detects that you have downloaded the apps, you'll get a message that your phone has been recharged successfully with 0 INR FRC.
     

    #10
  11. jitheshkt
    Donut Jul 24, 2016

    jitheshkt , Jul 24, 2016 :
    hey are you rooted ? I just got the device yesterday. I am using Jio only. VoLTE was working fine with Jio's app. But today morning I have unlocked the boot loader and installed TWRP then rooted. Now I am getting only data. No VoLTE. Jio app is not detecting my sim card. Any clue on this ? any experience like that ? Could root is the culprit ? I am confused :(
     

    #11
  12. DoccJiggity
    Donut Jul 27, 2016

    DoccJiggity , Jul 27, 2016 :
    What I've noticed is, when the screen goes black after being on a call utilizing VoLTE, is when the audio complete stops. As soon as you bring the screen back up, the call continues, and audio is received on both ends. So, something with VoLTE and the screen going black stops the audio between the callers. I'm not sure whether or not it's OP or T-Mobile, so I just disable it and call over 3G.
     

    #12
  13. dobiegillis
    Ice Cream Sandwich Jul 27, 2016

    dobiegillis , Jul 27, 2016 :
    What happened to that thread? Link doesn't work.
     

    #13
  14. dwlimf
    Froyo Aug 2, 2016

    dwlimf , Aug 2, 2016 :
    I'm wondering when this will be fixed it worked in 3.1.2 so it would seem just compare the delta in the related code and issue a fix.
     

    #14
  15. dwlimf
    Froyo Aug 4, 2016

    dwlimf , Aug 4, 2016 :
    Unbelievable I have been dealing with people not being able to hear me for weeks now actually over a month.

    And I see countless post about VoLTE can't hear me, and even mic issues, bluetooth, and I have been working with OP tech support sending them logs.

    So going Crazy here and the fix for all these problems was so simple.

    Just go here http://downloads.oneplus.net/oneplus-3/oneplus_3_oxygenos_3.2.2/

    and follow the instruction to sideload and alakazam all your problems are gone.

    Yup seems the OTA update somehow corrupts something and sideloading the whole ROM solves the problem 100%

    I really hope this helps all of you with these issues.
     

    #15
  16. dobiegillis
    Ice Cream Sandwich Aug 4, 2016

    dobiegillis , Aug 4, 2016 :
    Great news! Sideloading is usually best. Did it wipe your data?
     

    #16
  17. dwlimf
    Froyo Aug 4, 2016

    dwlimf , Aug 4, 2016 :
    Nope did not lose a single thing.
     

    #17
  18. dobiegillis
    Ice Cream Sandwich Aug 4, 2016

    dobiegillis , Aug 4, 2016 :
    I'm totally doing it tonight. Was planning on downgrading to 3.1.2 but will try 3.2.2.
     

    #18
  19. dwlimf
    Froyo Aug 4, 2016


    #19
  20. dobiegillis
    Ice Cream Sandwich Aug 4, 2016

    dobiegillis , Aug 4, 2016 :
    I've done it before but not since my oneplus one, which I think I could sideload from the recovery menu on the device. I just downloaded Android studio on my laptop since I couldn't find a copy of adb...must have been on an old laptop or maybe my desktop. Thanks again.
     

    #20