1
Wakelocks and battery drain

  1. NeoPhoenix
    Eclair Apr 16, 2015

    NeoPhoenix , Apr 16, 2015 :
    Good morning,
    for two days now, my battery drains a lot. It lost 20% charge within 12 hours (normally it would last up to 8 days) and Google-Dienste (Google-Services) is responsible for around 50%.
    https://www.dropbox.com/s/2gsmf5gygrcad5f/Screenshot_2015-04-16-09-43-48.png?dl=0
    Hence I installed a "Wakelock Detector" - and found a problem. The phone is awake 100% of the time and did not sleep a single second. Unfortunately it could not provide any information about which apps caused wakelocks since it requires root access which I don't have. I don't know about GPS but location tracking is turned off (via widget). I could really need some help.
    Kind regards
     

    #1
    shcxatter2 likes this.
  2. Johan2
    Gingerbread Apr 16, 2015

    Johan2 , Apr 16, 2015 :
    Disabling Wake and Keep awake for Google services in Privacy guard solved it for me.
     

    #2
    Broozen likes this.
  3. morencia
    Froyo Apr 16, 2015

    morencia , Apr 16, 2015 :
    Exactly the same problem bro. I have a drain in plane mode of about 10% and months ago if I switch to plane mode with 60% y woke up at 60%. Now I wake 50% and Google services (googlequicksearc process) seems to be the cause. Any suggestion?
     

    #3
  4. Lecter
    Ice Cream Sandwich Apr 16, 2015


    #4
    Deactivated User likes this.
  5. Farazahmed7
    Ice Cream Sandwich Apr 16, 2015


    #5
  6. Alivethereality
    Jelly Bean Apr 16, 2015

    Alivethereality , Apr 16, 2015 :
    download gservicefix from google play and follow instructions
    once all done, go into settings-battery and click the trash icon to refresh the stats
     

    #6
    Broozen likes this.
  7. TakeMyMoney
    KitKat Apr 16, 2015

    TakeMyMoney , Apr 16, 2015 :
    What does this do exactly?

    Which functionality am I losing by applying this fix?
    Will it stop syncing? I need it to sync.
     

    #7
  8. shcxatter2
    Ice Cream Sandwich Apr 16, 2015

    shcxatter2 , Apr 16, 2015 :
    you have to go to, google settings > search and now> voice > "Ok google" detection and turn it off
     

    #8
    vcespon and Alivethereality like this.
  9. Alivethereality
    Jelly Bean Apr 16, 2015

    Alivethereality , Apr 16, 2015 :
    as far as i'm concerned its only a fix
    it doesn't loose functionality just as the privacy guard fix
    just the privacy guard didn't work for me so i downloaded that one
    at least people say it doesn't, but if you loose sync you can always just reinstall the google services
     

    #9
    TakeMyMoney likes this.
  10. Alivethereality
    Jelly Bean Apr 16, 2015

    Alivethereality , Apr 16, 2015 :
    that actually could be the thing
    never thought of that one before
     

    #10
    shcxatter2 likes this.
  11. shcxatter2
    Ice Cream Sandwich Apr 16, 2015

    shcxatter2 , Apr 16, 2015 :
    That's what is responsible for the phone being constantly awake ;)
     

    #11
  12. TakeMyMoney
    KitKat Apr 16, 2015

    TakeMyMoney , Apr 16, 2015 :
    Thanks. Will give it a try.
     

    #12
  13. Alivethereality
    Jelly Bean Apr 16, 2015

    Alivethereality , Apr 16, 2015 :
    well shit where were you before ?
    now i have exodus and have no such dirty problems
     

    #13
    shcxatter2 likes this.
  14. Alivethereality
    Jelly Bean Apr 16, 2015

    Alivethereality , Apr 16, 2015 :
    Try this one first :
     

    #14
  15. TakeMyMoney
    KitKat Apr 16, 2015

    TakeMyMoney , Apr 16, 2015 :
    I had to shut that one down after the previous update already so that is not the problem for me. I'll try the gfix.
     

    #15
    shcxatter2 likes this.
  16. NeoPhoenix
    Eclair Apr 16, 2015

    NeoPhoenix , Apr 16, 2015 :
    I uninstalled some apps and deactivated Google-App (that search thing). Google-Services does not appear anymore but Google- Play-Services and Android-System takes a lot of battery - dunno if that's normal. I didn't need the Google search bar but does Google-App has other functions besides that search bar which I might require?
    I also find it strange that the battery drain started just 2 days ago - the phone didn't have that kind of problem before. @shcxatter2 where to find google settings and privacy settings?
     
    Last edited: Apr 16, 2015

    #16
    shcxatter2 likes this.
  17. shcxatter2
    Ice Cream Sandwich Apr 16, 2015

    shcxatter2 , Apr 16, 2015 :
    Google settings is like an app in the app drawer, the privacy guard is in the phone's settings under privacy :D
     

    #17
  18. Niels_Andersen
    KitKat Apr 16, 2015

    Niels_Andersen , Apr 16, 2015 :
    Find every solution there is to prevent the battery drain in my combined battery drain issue thread on my signature.
     

    #18
    TakeMyMoney likes this.
  19. NeoPhoenix
    Eclair Apr 16, 2015

    NeoPhoenix , Apr 16, 2015 :
    Thanks, I found it. I couldn't deactivate the "Ok Google" detection, maybe because I deactivated that Google-App.
    @Niels_Andersen thanks. I tried #1 and #2 but the wakelocks are persisting. I really don't know what to do anymore.

    Edit: I uninstalled the Google Play-Services updates + Privacy guard fix. At least my phone can go to sleep now :) Haven't got long term results yet but it looks promising. Do I have to do something to prevent Google Play-Services from updating?
     
    Last edited: Apr 16, 2015

    #19
  20. weresloth
    Honeycomb Apr 16, 2015


    #20