1
[Waze/Android Auto] GPS signal turns off if Waze is in background

  1. LucasWS
    Eclair Aug 21, 2018

    LucasWS , Aug 21, 2018 :
    When Waze is active, everything works fine, as always, but if I change to another app and left it running in background, after around 30 secs the Location icon in status bar vanishes like it's turned off and GPS stops working for waze.

    That said, the real problem is that, this way, I can't use Waze in my car anymore, because it's when Android Auto is active, so the GPS signal vanishes - the same behaviour as when Waze is running in background, even using it in my car's display.

    This behaviour started like 2 days ago, out of the blue.

    Google Maps still working just fine.

    Battery optimization is turned off.

    Tried turning off that advanced doze in Oxygen's battery options, with no luck.

    Turned off Waze's battery saving option.

    Already tried Waze's older version, no luck.

    Cleaned cache's partition, and every involved apps cache's (AA, maps, waze...).

    It's just like some battery saving mode, but I've tried turning off everything related with no luck.

    Finally, if I turn on both Waze and Google Maps, when they are in the background, Maps will keep using Location, and Waze don't.

    Is this some kind of bug or it's Waze's server related, something like that?
     

    #1
    mejifair likes this.
  2. HuangTec
    Cupcake Aug 21, 2018


    #2
    LucasWS likes this.
  3. mejifair
    Froyo Aug 21, 2018


    #3
    LucasWS likes this.
  4. LucasWS
    Eclair Aug 21, 2018

    LucasWS , Aug 21, 2018 :
    I don't know man, this is really strange!
    Btw, if I use Waze thru Android Auto IN MY PHONE, with USB cable connected, but not enabled on the car's display, it works just fine. So it's clearly related to keeping it in background...
    I know several users are having trouble with waze's GPS signal, something server-sided afaik, maybe this have something to do with it, although pretty different... I really don't know, hope someone find a solution... I've tried everything so far...
     

    #4
  5. HuangTec
    Cupcake Aug 23, 2018

    HuangTec , Aug 23, 2018 :
    i found this on xda And Works for me


    FIX :
    Ohww yeah this seems to fix the problem. Go into settings - battery - battery optimisation - 3 dot menu upper right - advanced optimisation - choose advanced optimisation.
     

    #5
  6. VMMP
    Cupcake Aug 23, 2018


    #6
  7. LucasWS
    Eclair Aug 23, 2018

    LucasWS , Aug 23, 2018 :
    In my case, I solved the problem by unchecking the option below advanced optimization, keeping only advanced optimization on.
     

    #7
  8. HaroldNL
    Froyo Aug 25, 2018

    HaroldNL , Aug 25, 2018 :
    Today I read (on Tweakers) that Waze and OnePlus solved the problem, just do a reboot and it should work again.
     

    #8
  9. Toinou
    Gingerbread Sep 30, 2018

    Toinou , Sep 30, 2018 :
    Have you some problems with Waze actually ? In these times, when I use Waze and go to Deezer my screen become black and I need to replug my phone.. Sometimes, Waze stop working on the car and crash all Android Auto.. So I use Waze on the phone and deezer and the car...
     

    #9
  10. U1540834759080
    Donut Dec 14, 2018


    #10
  11. Clapico
    Froyo Oct 25, 2019


    #11