4
Wear OS keep disconnecting randomly via OnePlus 8 Pro

  1. Ilian Dimitrov , via OnePlus 8 Pro , May 29, 2020 :
    Hi everybody.
    I have an Oneplus 8 pro for two weeks.

    It's paired with Ticwatch pro.

    The watch randomly disconnected from the phone bluetooth.
    Restarting the watch don't help.

    It reconnect only after the phone is restarted.

    How to solve the problem?
     

    #1
  2. X1588799666585
    Cupcake May 31, 2020


    #2

  3. #3
  4. jayanyway
    US Brand Ambassador Jun 1, 2020


    #4
  5. jayanyway
    US Brand Ambassador Jun 1, 2020

    jayanyway , Jun 1, 2020 :
    I know you said random but how do you use your phone on a daily basis? Any setting changes during the day then you notice the disconnect?
     

    #5

  6. #6
  7. X1588799666585
    Cupcake Jun 1, 2020


    #7

  8. #8
  9. X1588799666585
    Cupcake Jun 1, 2020


    #9

  10. #10
  11. Ilian Dimitrov , via OnePlus 8 Pro , Jun 2, 2020 :
    Still the same problem. Even worst. The Bluetooth start to hang up the audio on the ear buds. And the same situation with the watch. On the phone the watch stay connected and on the watch it is disconnected at the same time.
    The same watch (Ticwatch pro) never had any issues with my old phone - Samsung Galaxy 7
     

    #11
  12. OnePlus 8Pro_newbie , via OnePlus 8 Pro , Jun 16, 2020 :
    I have the same problem with my Wear OS watches and I have three of them. I see in the forum that the issue is probably an Oxygen OS issue since at least the OnePlus 6! Please OnePlus, fix the issue asap! It's very embarrassing, when a custom skin breaks basic Android functionality.
    Meanwhile it looks that a workaround that I found in the internet works;
    - Go to Settings>apps>Wear OS>disable battery optimizations
    - Lock the Wear OS app in the Recents
    - Restart phone.
     
    Last edited: Jun 16, 2020

    #12

  13. #13
    rigaudu likes this.
  14. OnePlus 8Pro_newbie , via OnePlus 8 Pro , Jun 16, 2020 :
    This is strange, because it worked for me. But I'll monitor it the next days and see if it's stable.
     

    #14
  15. ronnyhawks
    Ice Cream Sandwich Jun 17, 2020


    #15
  16. Korowin
    Gingerbread Jun 17, 2020

    Korowin , via OnePlus 8 Pro , Jun 17, 2020 :
    Have you tried to clear cache?
    Turn off the phone, hold the power and volume down buttons until the screen turns on, choose wipe cache and data, choose wipe cache only - restart.
    Than try and play with the settings.
     

    #16

  17. #17
  18. gubro
    KitKat Jun 19, 2020


    #18
  19. OnePlus 8Pro_newbie , via OnePlus 8 Pro , Jun 19, 2020 :
    I experienced the problem once again yesterday, when my Fossil Sport started running out of battery and went automatically into Battery Saving Mode (which switches off Bluetooth from the watch side). With the workaround in place (Wear OS battery optimizations off from the Settings and the Wear OS app locked in Recents to prevent the system from killing it), I restarted the phone and connectivity resumed. The workaround seems to work reliably for me but still; I have been reading on Reddit that the problem has existed since 2018 at least, and since then it is a carbon copy of how I have experienced it too: the watch appears connected on the Wear OS app, and the watch receives notifications, but there is the persistent icon of connectivity loss on the watch screen and apps do not work.
     

    #19
  20. OnePlus 8Pro_newbie , via OnePlus 8 Pro , Jun 20, 2020 :
    In the end it looks like the workaround works only partially. Yesterday, when I left home and my watch left WiFi, it got disconnected again. I had to restart the phone and then connection with the watch resumed. If this issue is not resolved soon, my tenure with OnePlus will be very brief indeed and I'll go back to Sony phones. These things don't happen with phones that keep their Android versions stock.
     
    Last edited: Jun 20, 2020

    #20