0
WearOS not playing nicely with OxygenOS

  1. Joeg6217
    Froyo Nov 14, 2018

    Joeg6217 , Nov 14, 2018 :
    Recently got the OnePlus 6T and it's been great. However, my WearOS watch is showing not connected (cloud symbol with line throughout shown in attached picture).

    Any idea how to resolve this?
    1542212490016.jpg
     

    #1
  2. LouCap
    Honeycomb Nov 14, 2018

    LouCap , Nov 14, 2018 :

    I currently have two different Wear OS watches paired with my 6T. The trick is to unpair the watch and do the reset. You can have multiple watches paired with a phone, but not multiple phones paired with a watch.
     

    #2
  3. ERock62
    Gingerbread Nov 14, 2018

    ERock62 , Nov 14, 2018 :
    I reset my watch when I paired with my 6T for the first time. Zero issues. Did the same with my wife's watch on her 6T.
     

    #3
  4. Wahoux
    Lollipop Nov 14, 2018

    Wahoux , Nov 14, 2018 :
    the could just mean that your watch isn't connected to a wifi. So not an issue from oxygen
     

    #4
    Blindedcoon likes this.
  5. Joeg6217
    Froyo Nov 14, 2018

    Joeg6217 , Nov 14, 2018 :
    Thanks for the quick response. Had already factory reset the watch but have just done it again. So far the icon has gone which is good but it came back last time. Hopefully it won't this time.
     

    #5
  6. Z1541678746306
    Cupcake Nov 14, 2018


    #6
  7. Neddard
    Lollipop Nov 14, 2018

    Neddard , Nov 14, 2018 :
    Hijacking threads isn't nice.
     

    #7
  8. JelleZon
    Lollipop Nov 14, 2018

    JelleZon , Nov 14, 2018 :
    I experienced the same problem

    my watch is just disconnected after a few hours.
    the wear os app is locked in the recents menu and battery optimization is turned off.

    random ... pie is strikt
    it just kicks the app out of the ram after a while and I have to reopen it.

    by the way: the cloud is a symbol for no internet connection. the watch is still connected with the phone, but can't transfer information.
    try to turn on flymode and Bluetooth on, watch still connected but no internet and shows the cloud.
     

    #8
  9. egorian
    Gingerbread Nov 15, 2018


    #9
  10. ibuu123
    Donut Nov 15, 2018


    #10
  11. Joeg6217
    Froyo Nov 15, 2018

    Joeg6217 , Nov 15, 2018 :
    OK, problem is back.

    Phone shows connected...
    1542293195495.jpg

    ...but watch shows disconnected...

    1542293224422.jpg
     
    Last edited: Nov 15, 2018

    #11
  12. LouCap
    Honeycomb Nov 15, 2018

    LouCap , Nov 15, 2018 :
    I'm going to have to try and connect my Huawei watch to my 6T tonight. so far I've been able to connect a Motorola smartwatch and a Casio with no issues. I'll see what happens with the Huawei and give you an update to see if I have a similar issue.
     

    #12
    Joeg6217 likes this.
  13. Matsdevries99
    Eclair Nov 15, 2018


    #13
    LouCap likes this.
  14. LouCap
    Honeycomb Nov 15, 2018

    LouCap , Nov 15, 2018 :
    oh yeah, absolutely. if you don't do it through the app it's just not going to work.
     

    #14
  15. Joeg6217
    Froyo Nov 15, 2018

  16. Joeg6217
    Froyo Nov 21, 2018


    #16
  17. ANONYMOOSE_82
    Ice Cream Sandwich Nov 21, 2018

    ANONYMOOSE_82 , Nov 21, 2018 :
    I was having the issues so I did some looking around and noticed the below, in images, after allowing it to run in the background I am no longer having issues.


    1542806076454.jpg

    1542806076496.jpg

    1542806076518.jpg

    1542806076539.jpg
     

    #17
  18. Rodri2018
    Cupcake Dec 3, 2018

    Rodri2018 , Dec 3, 2018 :
    I have a OnePlus 6t and a huawei watch. The watch always stays connected to the phone as it receives notifications. However, the watch constantly shows the cloud icon at the top and it says disconnected when I go to the Bluetooth screen. Internet based apps (like playstore, spotify and others) on the watch do not work when I'm not connect to a wifi. When I am on WiFi on my phone then the watch connects to WiFi and works fine so the issue is only when I'm not on WiFi.
    I've already turned off the battery optimization in the settings for the wear OS app and given all permissions but it still doesn't work.

    This problem happens a few hours after I reset the watch. After the reset and pairing the connections works just fine, after a while the cloud simbol return to appear in the watch meaning it doesn't have internet connection. I have the 4G data enable all the time and this problem never happened on my previous smartphone.
     
    Last edited: Dec 3, 2018

    #18
  19. MrMysakovich
    Ice Cream Sandwich Dec 3, 2018


    #19
  20. piersandro
    Gingerbread Jan 5, 2019

    piersandro , Jan 5, 2019 :
    Same here. OP6 woth Fossil Q Explorist and OP5 with Mobvoi Ticwatch E.
    Tried factory reset for phones and watches but the problem returned.
     

    #20