0
Weird Microphone Issue - Software or Hardware?

  1. EliTeAP
    KitKat Jul 26, 2015

    EliTeAP , Jul 26, 2015 :
    So, I dropped my OnePlus One in a little puddle of water one day in my bathroom and it sunk in for a few seconds before I could get it out. It did get into the microphone/usb port a bit but it did dry out after a while.

    Everything after that was still working as it should, touch screen, microphone vice versa.

    The touch screen stopped working but with a few updates and patches everything works smoothly.

    Now the microphone... apparently people are claiming that they can't hear me on earpiece mode but on speaker they can hear me much more clearly.

    YES. I've googled it and applied the Low Mic Vol fix from the user's xda thread - tazzkiller.

    This fixed it a tiny bit but now doesn't take effect on earpiece mode anymore.

    When I record with Sound Recorder it's perfect, so it makes me think that it's software but if it's worked before why would it be software?

    If anyone has any alternative solutions please let me know below :)

    Thanks a lot!

    EDIT (SOLUTION): This solution is only for people using AK kernel or any type of kernel for CM12.1 but you're using it on CM12S (which I stupidly did).

    I flashed another Franco's Kernel and my microphone seemed to work again. There was a setting on AK kernel which made the noise cancellation ridiculously high so I changed the kernel suitable for my CM version and it seems to work!

    I am now on Boeffla's kernel and experimenting with different ones!
     
    Last edited: Jul 28, 2015

    #1
  2. anzi2001
    Jelly Bean Jul 26, 2015

    anzi2001 , Jul 26, 2015 :
    Hmmm...and were you on the same version of android before and after you dropped it into water?
     

    #2
  3. thenicologix
    Gingerbread Jul 26, 2015

    thenicologix , Jul 26, 2015 :
    Hey man, I have the same problem since over a month. During a call the other person can only hear me if I activate the speaker. I contacted the support and they told me to flash Oxygen. The problem is I'm not very confident in doing that and my OPO wont show up in my computers device manager while being in fastboot. I have to wait until July 29th and theyll help me to do that. If youll find another solution please tell me!
     

    #3
    AsadP likes this.
  4. EliTeAP
    KitKat Jul 26, 2015

    EliTeAP , Jul 26, 2015 :
    I think I was on CM11S at the time (05Q) and now I'm on CM12S with AK Kernel
     

    #4
    anzi2001 likes this.
  5. anzi2001
    Jelly Bean Jul 26, 2015

    anzi2001 , Jul 26, 2015 :
    If you updated it may be software :) i dont know tho try some different kernel or something :)
     

    #5
  6. jizang
    Lollipop Jul 26, 2015

    jizang , Jul 26, 2015 :
    quickly put it in RICE ... then with the rice make some curry ...mmm curry and rice ;);)
     

    #6
    AsadP likes this.
  7. TlathamXmahtalT
    KitKat Jul 26, 2015

    TlathamXmahtalT , Jul 26, 2015 :
    Probably hardware if it just started happening after that. The speakerphone setting switches microphones since the speakers are on the bottom.
     

    #7
  8. EliTeAP
    KitKat Jul 28, 2015


    #8