4
'What OnePlus calls SUPPORT'

  1. Daan Vervakce
    Donut Apr 17, 2017

    Daan Vervakce , Apr 17, 2017 :
    First and foremost, I like my OnePlus X… It’s a great device for its price and it serves me well. This statement is not to ‘harm’ OnePlus as a brand but to get a fix for my phone and as a warning this is gonna be a long statement.

    Wifi Problems(fixed) and hard brick:


    Let’s start with the beginning. My phone had WIFI connection problems (these issues were fixed with an RMA). Before I contacted OnePlus, it tried to fix it myself by doing a reflash of OxygenOS but for some reason that bricked my phone. I contacted OnePlus for a remote session to fix the hard bricked phone and they agreed. Like all remote sessions a support assistant reflashed everything and my phone worked again. Now comes the bad part.

    Partitions changed and root problems:


    I always try to flash the latest Android version with the latest security patch(via custom roms). For that you need a custom recovery (TWRP in this example). I followed the standard procedure by using a root guide for OnePlus X. I successfully unlocked the bootloader and flashed TWRP. I booted into TWRP and I noticed something weird: It showed my internal storage as 0mb, my sdcard as 0mb and usbOTG as 0mb. I thought I was using an outdated version so I flashed the latest TWRP. But the problem was still there. I tried to do a Nandroid backup but then this error appeared ‘Failed to mount storage’. Also other errors like ‘failed to mount data, cache, internalsd’ appeared. When booting into Oxygen OS TWRP was removed and replaced with OOS recovery for some reason. In options->storage only 9/16gb was available and I was unable to format my sd card. Error ‘command ’11 volume partition disk: 179:64 public’ failed with ‘400 11 command failed’. I tried the remount option in twrp, searched all over Google, XDA, … but I couldn’t find an explanation for the problem. I also asked some OnePlus X developers in various Telegram groups and many befriended users tried to help me but they had never seen something like this. At this point I decided to contact OnePlus again.

    Ignorance and avoiding questions:


    First of all I contacted live support (since that is the easiest way to get a ticket created). Live support agreed to plan a remote session to ‘again’ reflash the OS(I didn’t want to send my phone (yet)). In the meanwhile I was in contact with someone from OnePlus support to explain the problem in detail(which I did, I even added the thoughts of a befriended developer to make it very clear). The person from OnePlus support also suggested a remote session to reflash the OS and also to hard reset my device to see what the real problems were. He also told me that ‘we discouraged you to keep on rooting your device because rooting the device can damage the full functionality of the device’ which is clearly not true. Rooting can’t really damage the hardware of a phone. And if you do it right, no problems should occur. They even ‘promote’ it on their social media(I remember a post about Dirty Unicorns) and their forums have special ‘custom software’ pages. I discovered that the remote session wouldn’t fix anything so I was asking polite to fix my partitions. They only replied with the remote session details and didn’t answer my question about fixing the partitions. The remote session passed and the problems were still there. I was getting a bit annoyed about the whole situation and decided to send an e-mail on the same subject: to fix the partitions. They again avoided the question and instead send me a Wikihow guide on how to format an sd-card…


    I’m not sure if they avoiding my questions or if I’m dealing with low level support people? Anyway, I want a clear answer from OnePlus and also if possible a solution.
     

    #1
  2. orionaselite
    Gingerbread Apr 17, 2017


    #2
  3. Varun.yadav
    Cupcake Apr 17, 2017


    #3
  4. jizang
    Lollipop Apr 17, 2017

    jizang , Apr 17, 2017 :
    bunch a script monkeys OP CS ... guess they the only solution though
     

    #4
  5. Daan Vervakce
    Donut Apr 17, 2017


    #5
  6. ZerNico
    Cupcake Apr 17, 2017


    #6
    Daan Vervakce likes this.
  7. SoniaB
    Head Moderator, Community Hero 2020 Head Moderator Apr 17, 2017

    SoniaB , Apr 17, 2017 :
    @Daan Vervakce did you back up your partitions prior to rooting as per the guide here: https://forums.oneplus.net/threads/...om-recovery-root-take-efs-backup-more.401713/

     

    #7
  8. Daan Vervakce
    Donut Apr 17, 2017


    #8
  9. SoniaB
    Head Moderator, Community Hero 2020 Head Moderator Apr 17, 2017

    SoniaB , Apr 17, 2017 :
    Okay - I thought you had rooted your device as per your start post

    So thought to ask if you had taken back ups prior to rooting.
     

    #9
  10. Daan Vervakce
    Donut Apr 17, 2017

    Daan Vervakce , Apr 17, 2017 :
    I wanted to take An OOS backup in twrp but that didn't work. As I said in my statement:)
     

    #10
    SoniaB likes this.
  11. SoniaB
    Head Moderator, Community Hero 2020 Head Moderator Apr 17, 2017

    SoniaB , Apr 17, 2017 :
    Yeah but TWRP does not back up all the partitions which is why the guide link I quoted above has specific steps to do so.
    Had you had those back ups then you would have been able to restore.

    Can you PM me your support ticket number and I will escalate this to CS and see if there is a way for them to fix your device. I cannot guarantee they can fix it, but will certainly see if there is more that can be done. If the partitions got screwed after the RMA remote session with CS then they should be looking at fixing this for you.
     

    #11
  12. Daan Vervakce
    Donut Apr 17, 2017

    Daan Vervakce , Apr 17, 2017 :
    Will contact you tomorrow
     

    #12
    SoniaB likes this.
  13. landerpiessens
    Eclair Apr 18, 2017


    #13