2
WhatsApp not receiving messages until I manually launch it?

  1. eranm5
    Jelly Bean Jan 24, 2015

    eranm5 , Jan 24, 2015 :
    Hello,

    Lately my WhatsApp background service just goes to sleep and not receiving new messages until I manually turn it on.

    It has no limitations in the privacy guard and it is not blocked by Clean Master.

    I already tried reinstalling it.

    Please help me!
     

    #1
  2. eranm5
    Jelly Bean Jan 24, 2015


    #2
  3. DaxNagtegaal
    Marshmallow Jan 24, 2015


    #3
  4. eranm5
    Jelly Bean Jan 24, 2015

    eranm5 , Jan 24, 2015 :
    I used to have it but I uninstalled it.
     

    #4
  5. Thimo
    Jelly Bean Jan 24, 2015

    Thimo , Jan 24, 2015 :
    Is your background data enabled?
    Check: Settings > Data Usage > Options (Menu button)
     

    #5
  6. DaxNagtegaal
    Marshmallow Jan 24, 2015


    #6
  7. eranm5
    Jelly Bean Jan 24, 2015

    eranm5 , Jan 24, 2015 :
    Yes, but I am also using WiFi.
     

    #7
  8. Thimo
    Jelly Bean Jan 24, 2015

    Thimo , Jan 24, 2015 :
    Ah, okay. That's odd. I'm sure you already tried it, but did you try rebooting?
     

    #8
  9. eranm5
    Jelly Bean Jan 24, 2015

    eranm5 , Jan 24, 2015 :
    So should I reinstall it and cancel the WhatsApp hibernation?
     

    #9
  10. Thimo
    Jelly Bean Jan 24, 2015

    Thimo , Jan 24, 2015 :
    You might want to try that!
     

    #10
  11. eranm5
    Jelly Bean Jan 24, 2015

    eranm5 , Jan 24, 2015 :
    Of course.
     

    #11
    Thimo likes this.
  12. DaxNagtegaal
    Marshmallow Jan 24, 2015

    DaxNagtegaal , Jan 24, 2015 :
    Maybe? I'm not sure.. But can't hurt to try
     

    #12
  13. eranm5
    Jelly Bean Jan 24, 2015

    eranm5 , Jan 24, 2015 :
    I reinstalled Greenify, activated the Xposed module, greenified and degreenified WhatsApp, deactivated the Xposed module and rebooted. Lets see if it works
     

    #13
  14. DaxNagtegaal
    Marshmallow Jan 24, 2015

    DaxNagtegaal , Jan 24, 2015 :
    Good luck
     

    #14
    eranm5 likes this.
  15. wilmarsaly
    Jelly Bean Jan 24, 2015

    wilmarsaly , Jan 24, 2015 :
    I have that problem to, WhatsApp doesn't support art and custom ROM, may that is the problem.
     

    #15
  16. yupasana55
    Ice Cream Sandwich Jan 24, 2015

    yupasana55 , Jan 24, 2015 :
    No.. You just need to enable background data and after that all works well :)
     

    #16
    ayy1892 likes this.
  17. GeertBerkers
    Lollipop Jan 24, 2015

    GeertBerkers , Jan 24, 2015 :
    Whats your WiFi setting?

    Settings -WiFi - Advanced - Keep WiFi on during sleep
    Put it to always!
     

    #17
  18. eranm5
    Jelly Bean Jan 24, 2015

    eranm5 , Jan 24, 2015 :
    Nope. Still not receiving. It only started a few days ago.
     

    #18
  19. ashutoshmn
    Ice Cream Sandwich Jan 24, 2015

    ashutoshmn , Jan 24, 2015 :
    maybe you have accidentally turned off the notifications for whatsapp but it is still receiving messages, could be possible, if so clear the permissions.
     

    #19
  20. eranm5
    Jelly Bean Jan 24, 2015

    eranm5 , Jan 24, 2015 :
    How do I do that?
     

    #20