2
WhatsApp not receiving messages until I manually launch it?

  1. ashutoshmn Ice Cream Sandwich Jan 24, 2015

    ashutoshmn, Jan 24, 2015 :
    go to settings->apps
    in downloaded apps, find whatsapp and tap on it.
    Now check the box saying receive noifications.
     

    #21
  2. Thimo Jelly Bean Jan 24, 2015

    Thimo, Jan 24, 2015 :
    Mhmmhmhmhm...

    Did you also check if your notifications in whatsapp are on?

    Oh ye, can you see it connecting when you OPEN the app? Or are the messages already loaded?
     

    #22
  3. xGho0sT Eclair Jan 24, 2015


    #23
  4. eranm5 Jelly Bean Jan 25, 2015

    eranm5, Jan 25, 2015 :
    Only when I open the app. It starts connecting and shows the messages about 5 seconds later.
     

    #24
  5. ayy1892 Honeycomb Jan 25, 2015

    ayy1892, Jan 25, 2015 :
    go to applications>running apps and see whether whatsapp is running or not...if it's running then you should be able to receive messages.
     

    #25
  6. eranm5 Jelly Bean Jan 25, 2015

    eranm5, Jan 25, 2015 :
    It is on, but I still don't receive notifications.
     

    #26
  7. ashutoshmn Ice Cream Sandwich Jan 25, 2015


    #27
  8. vsbrt Cupcake Jan 25, 2015

    vsbrt, Jan 25, 2015 :
    go to settings>app and see the uptime. if it is lass than 1 minute, then that app is being auto killed by the android system itself. this issue happens often on my moto g also. the best solution for this problem is, open whatsapp and minimize it and never clear it from the overview.
     

    #28
  9. eranm5 Jelly Bean Jan 25, 2015

    eranm5, Jan 25, 2015 :
    The WhatsApp service is running for 17 hours now, but It still doesn't receive new messages until I turn it on.
     

    #29
    A1529776939131 likes this.
  10. sid777 Donut Jan 25, 2015


    #30
  11. fgrhuhrg Ice Cream Sandwich Jan 25, 2015

    fgrhuhrg, Jan 25, 2015 :
    im having the same problems, but i thought it was just my WiFi. clearly not, i really need a solution
     

    #31
  12. theSprintman Honeycomb Jan 25, 2015

    theSprintman, Jan 25, 2015 :
    I have the same issue, I receive notifications but NO sound (ringtone). I use the latest nightly of CM12.
     

    #32
  13. shaadfaizel Eclair Jan 25, 2015

    shaadfaizel, Jan 25, 2015 :
    dont worry about it..It will be alright within nxt update.....!
    Did u install any app for saving battery or memory(clean master or battery saver...etc)??
     

    #33
  14. shaadfaizel Eclair Jan 25, 2015

    shaadfaizel, Jan 25, 2015 :
    Go to whatsapp settings...
    Notification settings
    Tick~Play sounds while receiving messages
     

    #34
  15. Hanson Lee Lollipop Community Expert Jan 25, 2015

    Hanson Lee, Jan 25, 2015 :
    Same problem with CyanHacker.

    It's not the problem of notifications, it's the receiving messages part that's the problem.
     

    #35
    eranm5 likes this.
  16. MCMXCIVR Ice Cream Sandwich Jan 25, 2015

    MCMXCIVR, Jan 25, 2015 :
    I've had this problem with more apps. On the Jiayu G4 running MIUI with almost all of my apps and with the One using the mail.com app.
     

    #36
  17. Hanson Lee Lollipop Community Expert Jan 25, 2015


    #37
  18. theSprintman Honeycomb Jan 25, 2015

    theSprintman, Jan 25, 2015 :
    I already did that. It plays no sound on incoming messages, it only vibrates.
     

    #38
  19. firewire2035 KitKat Jan 25, 2015

    firewire2035, Jan 25, 2015 :
    wasapp settings
    privacy guard settings
    settings > accounts > wasapp
    greenify, batteryguru, etc.
     

    #39
  20. Thimo Jelly Bean Jan 25, 2015

    Thimo, Jan 25, 2015 :
    What version are you running by the way? And did it occur on older versions?
     

    #40