2
WhatsApp not receiving messages until I manually launch it?

  1. eranm5
    Jelly Bean Jan 25, 2015

    eranm5 , Jan 25, 2015 :
    I removed Greenify and Clean Master a few days ago. That is when the problem started. I already reinstalled Greenify, greenified and degrineefied WhatsApp and uninstalled it.

    It might be a problem with the WhatsApp Web update. I'm running 2.11.505
     

    #41
  2. Thimo
    Jelly Bean Jan 25, 2015

    Thimo , Jan 25, 2015 :
    Did you do anything with Clean Master and Whatsapp? Else I'd recommend you to downgrade and test.
     

    #42
    eranm5 likes this.
  3. singhpra
    Donut Jan 25, 2015

    singhpra , Jan 25, 2015 :
    i always faced problem on Whatsapp, when i manually switch on mobile data, whatsapp is not sending and receiving messages, but works fine on wifi. I faced this issue right from stock CM11s to cm12. Please let me know the solution? is it modem problem??
     

    #43
    dharmeshkapasi likes this.
  4. 3663
    Honeycomb Jan 25, 2015

    3663 , Jan 25, 2015 :
    TBH I'm having this problem on whatsapp at the moment too, not on the One, on my other phone.
    Need to open it for it to refresh messages, not all of the time but sometimes.
    Thinks its a problem with the latest whatsapp vers.
     

    #44
  5. firewire2035
    KitKat Jan 25, 2015

    firewire2035 , Jan 25, 2015 :
    @eranm5. i forgot to add, wipe cache, factory etc.

    i think greenify messed up my kernel a while a ago, ala R38, so I just wipe and clean install.
     

    #45
  6. eranm5
    Jelly Bean Jan 25, 2015

    eranm5 , Jan 25, 2015 :
    Yes.

    Only the kernel? I can easely reflash it!
     

    #46
  7. Thimo
    Jelly Bean Jan 25, 2015

    Thimo , Jan 25, 2015 :
    I think it's the best thing to "revert" your actions with Clean Master, reinstall whatsapp, and see if it works again..

    This is one of the weirdest issues I've ever seen though lol
     

    #47
  8. eranm5
    Jelly Bean Jan 25, 2015

    eranm5 , Jan 25, 2015 :
    I reflashed the stock kernel, lets see if it helps. I hope so
     

    #48
  9. Thimo
    Jelly Bean Jan 26, 2015

    Thimo , Jan 26, 2015 :
    Did it help?
     

    #49
  10. eranm5
    Jelly Bean Jan 26, 2015

    eranm5 , Jan 26, 2015 :
    I don't know, it works but one time I opened WhatsApp and it showed some old messages.
     

    #50
  11. eranm5
    Jelly Bean Jan 27, 2015

    eranm5 , Jan 27, 2015 :
    It's still happening. I'm desperate. Customer support just give me stupid solutions like turning on notifications from the app.
     

    #51
  12. Thimo
    Jelly Bean Jan 27, 2015

    Thimo , Jan 27, 2015 :
    What the flying poo.. You might wanna try and contact Whatsapp support :x
     

    #52
    eranm5 likes this.
  13. Thimo
    Jelly Bean Jan 27, 2015

    Thimo , Jan 27, 2015 :
    Or else factory reset :s
     

    #53
    eranm5 likes this.
  14. Venky61
    Jelly Bean Jan 28, 2015


    #54
  15. Jonsnow6099
    Jelly Bean Jan 28, 2015


    #55
  16. leemartin
    Lollipop Jan 28, 2015


    #56
  17. Venky61
    Jelly Bean Jan 28, 2015


    #57
  18. paulusnostradamos
    Cupcake Jan 28, 2015

    paulusnostradamos , Jan 28, 2015 :
    I have the same problem from time to time. But only with my wifi at home, not when wifi is turned off. Already happened with my old phone. Probably a problem with the wifi sleep option (didn´t solve it on my old phone though).
    BTW I dont use greenify or any battery apps
     

    #58
  19. kell
    Gingerbread Jun 20, 2016

    kell , Jun 20, 2016 :
    Ughh i really hate android marshmallow with oxygen OS
    None of my notifications arrive until i turn on my screen...
     

    #59
  20. hachem2881
    Cupcake Jun 20, 2016

    hachem2881 , Jun 20, 2016 :
    Its has nothing to do with notification settings or low power modes, its whatsapp itself. I'm on the Nexus 6P and it started happening randomly. Are you on Beta by any chance
     

    #60