2
WhatsApp not receiving messages until I manually launch it?

  1. supalco
    Cupcake Jul 20, 2016

    supalco , Jul 20, 2016 :
    Disable power saving mode on your device and it will fix the problem.
    I had same problem with whatsapp in my Samsung Device....
     

    #61
  2. rajaspardeshi
    Ice Cream Sandwich Jul 20, 2016

    rajaspardeshi , Jul 20, 2016 :
    This used to happen when I restored WhatsApp backup from Ti Backup. So ive stopped backing it up via Ti, I just reinstall it and let the app restore the previous chat backups, and the problem seems to have vanished.
     

    #62
  3. 9019513824
    Cupcake Aug 6, 2016

    9019513824 , Aug 6, 2016 :
    Hi.
    Go to settings-Data usage-
    Wats app- uncheck restrict data usage.
    Hope this will work.
     

    #63
  4. speedy.saad
    Cupcake Aug 13, 2016

    speedy.saad , Aug 13, 2016 :
    https://www.whatsapp.com/faq/en/android/20887936

    Make sure Restrict background data is turned off
    Make sure Restrict background data settings on your device is not enabled for WhatsApp and Google Services.

    1. Open device Settings.
    2. Go to Data usage.
    3. Scroll down and open WhatsApp data usage.
    4. Scroll down and make sure Restrict background data option is unchecked.
    5. Repeat the above steps for Google Services.
    6. Additionally, make sure Restrict background data is unchecked in Data usage > Menu Button.

     

    #64
  5. mr.simple430
    Cupcake Mar 28, 2017

    mr.simple430 , Mar 28, 2017 :
    3. Notification is not working such as whatsapp, tapatalk,,,
    - All installed apps were optimized by C5 SmartManager at the begining.
    - Disable optimize for each app via C5 SM - RAM - AutoRun
     

    #65
  6. fossum_13
    Cupcake Jul 25, 2017

    fossum_13 , Jul 25, 2017 :
    For me a restart may have helped, but I also changed some settings in "Configure Wi-Fi":
    • Turned off "Smart Wi-Fi switcher"
    • Turned off "Scanning always available"
    • Set "Keep Wi-Fi on during sleep" to always
     

    #66
  7. G_Abhishek_Uppal_gdsp
    Cupcake Jul 25, 2017

    G_Abhishek_Uppal_gdsp , Jul 25, 2017 :
    I was also facing this same issue, but now got solution.

    • Go to settings and select Battery
    • Battery optimisation
    • Find whatsapp and select "Dont optimise"

    This will solve your problem
     

    #67
    opflarkit likes this.
  8. Mk102490
    Cupcake Dec 30, 2018

    Mk102490 , Dec 30, 2018 :
    Well. I have OnePlus 5 and now I am on OOS 9.0.0 (Android Pie 9.0) and this thing is still there. There is no solution till now for this. Only solution available is lock WhatsApp in recents view that's it. (All other thing already tried many times)
     

    #68
  9. x7007
    Cupcake Jan 23, 2019

    x7007 , Jan 23, 2019 :
    So nothing works? that's impossible .... something must work. with android 8.1 there was not a single issue. there must be a mix of couple settings.

    Do you give ALL PERMISSION for whatsapp ? does it needs location ? because not all are enabled for me .. I don't think it needs to...
     

    #69
  10. X1549086518922
    Cupcake Feb 2, 2019


    #70
  11. X1566888752815
    Cupcake Aug 27, 2019

    X1566888752815 , Aug 27, 2019 :
    I had a Samsung S8 and did not experience this problem. Now I have upgraded to Huawei Mate P20 and struggling a lot with this problem and can't get it fixed. I have googled a lot but to no avail.
     

    #71