0
Third Party Software WhatsApp not receiving messages until I manually launch it

?

WhatsApp not receiving messages until I manually launch it

  1. This is a whatsapp issue

    22.2%
  2. This is a OnePlus issue

    77.8%
  1. NiKuchroo
    Cupcake Dec 15, 2017

    NiKuchroo , Dec 15, 2017 :
    So this same thread exists in the OnePlus 1 section but I'm facing the issue in the OnePlus 5.
    But there is not OP5 specific comment so creating this thread
    I have two of them and both have the issue. I have set 'don't optimize' in battery setting for the app. Allow notifications is set under notifications under the app. Is this problem specific to the OP5? Is there a fix/workaround?
     

    #1
  2. Nick12341
    Gingerbread Dec 15, 2017

    Nick12341 , Dec 15, 2017 :
    Happens when the app is forcefully hibernated by the hibernaor app (for me). If you're suing the app try to set it to excluded apps. otherwise, I still do receive messages via WhatsApp on normal occasions.
     

    #2
  3. GopalB.
    Nougat Dec 15, 2017

    GopalB. , Dec 15, 2017 :
    Ok...
    Do this...
    Settings > battery > battery optimization > whatsapp > do not optimize
     

    #3
    G_Tamer_Elsayed_Vyjb likes this.
  4. GopalB.
    Nougat Dec 15, 2017

    GopalB. , Dec 15, 2017 :
    Do this as well...
    Settings > data usage > mobile data usage > whatsapp > enable background data (this should be enabled by default by the way)
     

    #4
  5. Gav_W86
    Starting Point Expert Community Expert Dec 15, 2017

    Gav_W86 , Dec 15, 2017 :
    Sounds like you have something aggressively optimising the background use of the app, either built in or an app.
     

    #5
  6. NiKuchroo
    Cupcake Dec 17, 2017

    NiKuchroo , Dec 17, 2017 :
    Already done both... Still the issue persists
     

    #6
  7. NiKuchroo
    Cupcake Dec 17, 2017

    NiKuchroo , Dec 17, 2017 :
    You are taking about another 3rd party app? I have nothing such installed to manage power.
     

    #7
  8. G_Robin_Tan_TUyl
    Donut Dec 17, 2017


    #8
  9. Impredatle
    Cupcake Dec 17, 2017

    Impredatle , Dec 17, 2017 :
    Got the same problem, everything done as said above. But sometimes it only refreshes when I launch the app. Sometimes I'll get the messages, but no sound (sound is on of course)
     

    #9
  10. NiKuchroo
    Cupcake Dec 17, 2017

    NiKuchroo , Dec 17, 2017 :
    I have not installed anything to manage my background process.
     

    #10
  11. NiKuchroo
    Cupcake Dec 17, 2017


    #11
  12. Tobiyas
    Cupcake Dec 17, 2017


    #12
  13. Gav_W86
    Starting Point Expert Community Expert Dec 17, 2017

    Gav_W86 , Dec 17, 2017 :
    what about the built in optimisation & doze features?
     

    #13
  14. NiKuchroo
    Cupcake Dec 19, 2017

    NiKuchroo , Dec 19, 2017 :
    as mentioned above, I have disabled, battery optimization for WhatsApp. where is this doze setting?
     

    #14
  15. nilsie12
    Cupcake Jan 2, 2018

    nilsie12 , Jan 2, 2018 :
    I have the same problem. Highly annoying, any time I haven't opened whatsapp for ~15 minutes or so, I stop receiving notifications untill I open the app.

    I also disabled battery optimization for Whatsapp, and no data restrictions in place. Never had any trouble on my iPhone....

    Also, if I leave Whatsapp Web open, I have no trouble receiving notifications. So it has to be the phone killing the service / blocking the GCM or whatever
     

    #15
  16. G_Gilles_Claeys_HESi
    Cupcake Feb 21, 2018

    G_Gilles_Claeys_HESi , Feb 21, 2018 :
    Same problem here. Also tried all the above: disabling battery optimization, enabling background data,... Really annoying as I get messages with a huge delay. Still nobody with a solution?
     

    #16
  17. aykut39
    Honeycomb Feb 21, 2018

    aykut39 , Feb 21, 2018 :
    It is a connection problem caused by dns or proxy settings of your network provider..

    it happens when I am on company wifi sometimes...

    try resetting your apn and wifi settings
     

    #17
  18. ascent
    Honeycomb Mar 12, 2018


    #18
  19. G_Gilles_Claeys_HESi
    Cupcake Mar 12, 2018

    G_Gilles_Claeys_HESi , Mar 12, 2018 :
    I don't think so, it also happened when I was on 4G or on my home WiFi network. The issue seems to be resolved somehow since a couple of weeks. Need to monitor it more actively to be 100% though.
     

    #19