0
Whatsapp Push-Notifications delayed

  1. Nudelholz
    Gingerbread Mar 3, 2015

    Nudelholz , Mar 3, 2015 :
    Hi, I'm experiencing a problem with the Push-Notifications on my Oneplus One (64GB).

    CM11S-XNPH0Q5, Stock, not modified. Already Factory resetted.

    When I'm at home in the Wifi Network of my Technicolor TC7200 modem, my One loses the Connection to the Google Cloud Messaging Service (GCM) after staying longer than 10 Minutes in Standby. This results in delayed Push-Notifications. It's most annoying for Whatsapp but Email, Skype and other apps are also affected. When I open Whatsapp, multiple messages show up at once. The messages were sent to me multiple minutes before but didn't reach my phone until I manually opened the app.

    It does look like this in Push-Notification-Fixer:

    http://imgur.com/a/QzSMu (Album with 3 Images).

    It works fine in basically every other Wifi Network and over 3G mobile internet. My previous Nexus 5, my sisters Nexus 4 and my Moms Moto G (1st gen) have no Problems in the same network. My network hasn't changed since I switched from the Nexus 5 to the Oneplus One.

    Does anybody experience similar issues?

    Thanks for your help.
     

    #1
  2. DanCtoo
    Honeycomb Mar 4, 2015

    DanCtoo , Mar 4, 2015 :
    Yes, i had this too. After removing battery doctor and google apps the problem was fixed. Don't ask me how :)
     

    #2
  3. Nudelholz
    Gingerbread Mar 4, 2015


    #3
  4. leemartin
    Lollipop Mar 4, 2015

    leemartin , Mar 4, 2015 :
    Qualcomm battery guru?
     

    #4
  5. DanCtoo
    Honeycomb Mar 7, 2015


    #5
  6. lokesh3440
    Honeycomb Mar 7, 2015

    lokesh3440 , Mar 7, 2015 :
    I don't have any of aforesaid mentioned apps installed still I can't get push notifications. I can see all my messages once I will open whatsapp
     

    #6
  7. eranm5
    Jelly Bean Mar 7, 2015

    eranm5 , Mar 7, 2015 :
    I had it before I installed BatteryGuru. It's not fixed yet. I will factory reset after CM12 comes to the OPO.
     

    #7
  8. rishabh1983
    Cupcake Mar 10, 2015

    rishabh1983 , Mar 10, 2015 :
    Yup. .. I am facing the same issue! ! Were u able to get a solution? ?
     

    #8
  9. Nudelholz
    Gingerbread Mar 10, 2015

    Nudelholz , Mar 10, 2015 :
    Sadly not. I've deactivated "Keep WLAN on during Standby" to make the phone switch to mobile network after 5-10 Minutes in Standby. Push-Notifications work flawlessly over 3G Network, they only make problems while in WiFi. Still, some Notifications are delayed but it makes the problem more bearable. I really hope for a fix in CM12S.
     

    #9
  10. jokk3l
    Ice Cream Sandwich Mar 10, 2015

    jokk3l , Mar 10, 2015 :
    Does this issue occur in other WiFis, too?
    Or only in your WiFi at home?

    Any Battery saving or Task killing apps installed?

    I get those issues reproducable when greenifying Whatsapp and my mail client. (paid version of Greenify will keep gcm messages running, even if the apps are hibernated -> experimental feature. But I own only the free version).
     

    #10
  11. sc0f13ld
    Froyo Mar 11, 2015

    sc0f13ld , Mar 11, 2015 :
    Same issue here, but so far only noticed over GSM, will test WiFi tonight.

    No Battery tool or app/task killer or even Greenify installed.

    Clueless and VERY annoyed... :(
     

    #11
  12. sc0f13ld
    Froyo Mar 12, 2015

    sc0f13ld , Mar 12, 2015 :
    Ok, I resolved this by no longer restricting background data over 3G... *doh*
     

    #12
    North84 likes this.
  13. jokk3l
    Ice Cream Sandwich Mar 12, 2015

    jokk3l , Mar 12, 2015 :
    :D
     

    #13
  14. fgrhuhrg
    Ice Cream Sandwich Apr 7, 2015


    #14
  15. North84
    Eclair Jun 29, 2015

    North84 , Jun 29, 2015 :
    Where can I find this setting? I already set the setting WiFi always on. Don't know where to find the one you mentioned... :eek:
     

    #15
  16. sc0f13ld
    Froyo Jul 14, 2015

    sc0f13ld , Jul 14, 2015 :
    In case you are still looking: Settings > Data Usage > Scroll down to APP USAGE > Select the App > toggle switch RESTRICT APP BACKGROUND DATA

    I had Google Play Services restricted, which disabled push notifications (not just WhatsApp, GMAIL also for example) while on 3G. WiFi was never an issue, since the restriction only applies to mobile networks (i.e. 2G/3G etc.)
     

    #16
    North84 likes this.
  17. North84
    Eclair Jul 22, 2015


    #17