0
Why is my op 6T rooted after update android 11? via OnePlus 6T

  1. Ahfek
    Donut Oct 3, 2021

    Attached Files:


    #1
  2. Dresa91
    User of the Year 2016; Most Active User 2020 Oct 3, 2021

    Best Answer

    #10
    Artemus and Praty_28 like this.
  3. Dresa91
    User of the Year 2016; Most Active User 2020 Oct 3, 2021

    Dresa91 , Oct 3, 2021 :
    Please install this app https://play.google.com/store/apps/details?id=com.joeykrim.rootcheck and check if your device is rooted.
    Please clear cache in recovery and clear cache and data of the Banking app and restart your device
     

    #2
    Artemus and DarshanMeniya like this.
  4. Ahfek
    Donut Oct 3, 2021


    #3
  5. Dresa91
    User of the Year 2016; Most Active User 2020 Oct 3, 2021


    #4
  6. Ahfek
    Donut Oct 3, 2021


    #5
  7. Dresa91
    User of the Year 2016; Most Active User 2020 Oct 3, 2021

    Dresa91 , Oct 3, 2021 :
    Can you please give a factory reset a try?
     

    #6
  8. Ahfek
    Donut Oct 3, 2021

    Ahfek , via OnePlus 6T , Oct 3, 2021 :
    I just did 3 hours ago. And went to the same problem. That's why i went through the community. Thank you btw for helping me this far . Appreciated it <3
     

    #7
  9. Dresa91
    User of the Year 2016; Most Active User 2020 Oct 3, 2021

    Dresa91 , Oct 3, 2021 :
    Okay, what about rolling back to OxygenOS 10?
     

    #8
  10. Ahfek
    Donut Oct 3, 2021

    Ahfek , via OnePlus 6T , Oct 3, 2021 :
    Can you link a tutorial how to rollback? I dont mind using android 10
     

    #9
  11. Ahfek
    Donut Oct 3, 2021


    #11
    Praty_28 and Dresa91 like this.
  12. Dresa91
    User of the Year 2016; Most Active User 2020 Oct 3, 2021

    Dresa91 , Oct 3, 2021 :
    okay:)
     

    #12
    Praty_28 likes this.
  13. Praty_28
    KitKat Oct 3, 2021


    #13
  14. Ahfek
    Donut Oct 3, 2021


    #14
    Praty_28 likes this.
  15. Praty_28
    KitKat Oct 3, 2021

    Praty_28 , Oct 3, 2021 :
    This is very strange, your safetynet seems alright only thing that the bank apps might be checking could be your app list. This happens when an app has a similar name to a root app. Do you recollect installing anything new recently?
     

    #15
  16. Ahfek
    Donut Oct 3, 2021

    Ahfek , via OnePlus 6T , Oct 3, 2021 :
    I mean I've been using the same apps for more than 3 months until I've updated android 11 the issues arises. The thing is it only happened to only 1 of the bank apps and 1 of the e commerce apps where i cant access my wallet. I thought it might get resolved after 1 security update but doesnt seem like it anytime soon. :(
     

    #16
    Praty_28 likes this.
  17. Praty_28
    KitKat Oct 3, 2021

    Praty_28 , Oct 3, 2021 :
    Really strange, everything seems alright on your device and you already factory reset too right? Seems like downgrading is the only option left to try. I have no idea what's causing this :confused:
     

    #17
  18. camohan
    Moderator Moderator Oct 3, 2021

    camohan , Oct 3, 2021 :
    Hi there, you should also check if the developer's option is enabled in your device.

    Go to settings, system and see if you find developers option over there. If no you have not enabled it, if you find it tap on it and toggle off the option.

    Also, check if you have any app like supersu, etc. Sometimes that also triggers the check.

    I would recommend leaving a feedback to the developers by going to community app, profile page, my feedback, click on third party apps, regular apps and provide complete description.

    Meanwhile you can either use the web work of the bank or roll back the device to earlier version.

    Cheers.
     

    #18
  19. Q1634178177196
    Cupcake Oct 14, 2021

    Q1634178177196 , Oct 14, 2021 :
    Hi, I've had the same problem for months. At first I updated to Android 11 manually in August and the problem cropped up. Bank Islam, Big Pay, Shopee Pay, Yoodo are all unusable. So I thought maybe I should wait for the official ota update and thus rolled back to Android 10. Got the ota a couple weeks ago and it's the same now. All those apps ☝🏻 aren't working again. Disabling developer option does nothing. Maybank MAE, Touch&Go, Boost, Grab are all working fine though. It's annoying. Rolling back to Android 10 means having to set the phone all over again which I'm reluctant to do, AGAIN. So I'm just waiting if an update will fix this but not holding my breath. The phone is definitely not rooted but some apps detect it as rooted which is weird
     

    #19