9

Wi-Fi Calling dropping on OnePlus7 Pro (T-Mobile)

  1. mxc0bbn Donut May 22, 2019

    mxc0bbn, May 22, 2019 :
    I have the unlocked version of the OP7 Pro (12GB/256GB). I am using it on T-mobile and have Wi-Fi Calling enabled.

    Initially when in the Wi-Fi range Wi-Fi Calling works just fine, but when I leave the range of the network and come back to it, the phone never re-establishes Wi-Fi Calling even though it is connected to the same network. It is set to 'prefer Wi-Fi'. I have tried:
    • Enabling/Disabling Airplane mode (While in airplane mode, connecting to Wi-Fi network does not enable Wi-Fi Calling).
    • Enabling/Disabling Wi-Fi Calling (Settings > Wi-Fi & Internet > Sim & Network > SIM 1 > Enhanced Communications > Wi-Fi Calling)
    • Enabling/Disabling Wi-Fi

    None of these work. The only thing that works to re-establish Wi-Fi Calling is to restart the phone. At that point it does work again.

    All updates have been downloaded. I am on OxygenOS v9.5.3.GM21AA. Any suggestions?

    on edit: submitted bug report. Feel free to upvote or link your own report to this one.
    https://forums.oneplus.com/threads/...-range-of-wifi-network-and-returning.1038204/
     
    Last edited: May 23, 2019

    #1
  2. JoseReyes69 Gingerbread May 22, 2019

    JoseReyes69, May 22, 2019 :
    Mine does that periodically when I move around the house as I have triple band router. It does come back without having to restart. Usually happens when it switches bands.

    Edit: After getting home phone would not turn on wifi calling after connecting to wifi. Had to restart phone to get it to turn on wifi calling as mentioned earlier.
     
    Last edited: May 23, 2019

    #2
    spdsk8race1 and noah hatton like this.
  3. mxc0bbn Donut May 23, 2019

    mxc0bbn, May 23, 2019 :
    Thanks for duplicating the issue Jose. At least now I know it has nothing to do with my specific home networking setup...

    Anyone from OnePlus want to run this to ground?
     

    #3
  4. LouCap Honeycomb May 23, 2019

    LouCap, May 23, 2019 :
    Isn't there a setting to prefer either wifi or cellular network for calls? Maybe check and see which you have selected and change it to the opposite? Just a thought.
     

    #4
    spdsk8race1 likes this.
  5. mxc0bbn Donut May 23, 2019

    mxc0bbn, May 23, 2019 :
    LouCap. Good point. I didn't include that in my original post (Will edit after this reply). Yes, I have the option set to 'Prefer Wi-Fi'.

    I have now also disabled 'Wi-Fi prefered' and re-enabled it, but still no dice. No Wi-Fi Calling when leaving the network and coming back into it.
     

    #5
    spdsk8race1 likes this.
  6. noah hatton Eclair Jun 1, 2019

    noah hatton, Jun 1, 2019 :
    I am having the exact same problem with my oneplus 7 pro on t-mobile, when I leave my wifi service area and return, the wifi calling doesn't automatically reconnect, I have to restart my phone, and even my router at times.
     

    #6
    spdsk8race1 likes this.
  7. Steven_Petrillo Froyo Jun 1, 2019


    #7
  8. sbasu101 Cupcake Jun 4, 2019

    sbasu101, Jun 4, 2019 :
    I am having almost the same issue. Device shows "T-Mobile Wi-Fi Calling" but I don't hear the other party when placing or receiving the call. The only fix seems to be restarting the device. After this, when you disconnect from a given network and re-connect later, the problem resurfaces.
     

    #8
  9. spdsk8race1 Honeycomb Jun 4, 2019

    spdsk8race1, Jun 4, 2019 :
    on T-Mobile devices it's show a ER04 DNS Error on WiFi calling. same issues on T-Mobile variant, once you restart works fine, but leave and come back, error message
     

    #9
    sbasu101 and noah hatton like this.
  10. sbasu101 Cupcake Jun 4, 2019

    sbasu101, Jun 4, 2019 :
    Where are you seeing that error message? Also, if you run *#*#4636#*#* what does your diagnostic screen show? Mine shows "LTE" for Voice Network Type and "IWLAN" for Data Network Type. This is with the cellular radio on, and the status bar showing "T-Mobile Wi-Fi Calling."

    Where it gets funny is if I turn on Airplane Mode (cellular radio off) and enable Wi-Fi, the status bar will show "T-Mobile Wi-Fi Calling" but the diagnostic screen will show the voice network type as "Unknown" and the voice service as "In Service." If I place a phone call it works just fine.
     

    #10
  11. spdsk8race1 Honeycomb Jun 4, 2019

    spdsk8race1, Jun 4, 2019 :
    in settings under WiFi calling
    1559681989530.jpg
     

    #11
    noah hatton likes this.
  12. F_Aaron_Smith_nuDE Cupcake Jun 10, 2019

    F_Aaron_Smith_nuDE, Jun 10, 2019 :
    I also have this issue. Discovered it last night. I've had the OP 7 Pro over 2 weeks and just noticed that I'm losing it after being connected. Have toggled on/off WiFi and WiFi calling settings. Only thing that works is to reboot phone. This must be a bug, so I'm adding my experience so OnePlus can investigate and fix.
     

    #12
    mxc0bbn and spdsk8race1 like this.
  13. Syaoran Froyo Jun 10, 2019


    #13
  14. H1542153384332 Gingerbread Jun 10, 2019

    H1542153384332, Jun 10, 2019 :
    I use cellular preferred and it will switch to WIFI when the phone can make a connection. The phone came with WiFi preferred and I changed it right away. I don't see a reason why to use WiFi calling.
     

    #14
    spdsk8race1 likes this.
  15. Syaoran Froyo Jun 12, 2019

    Syaoran, Jun 12, 2019 :
    WiFi Calling is useful in places where you don't have service, on an airplane, inside of a nuclear bunker, and so on.
     

    #15
  16. H1542153384332 Gingerbread Jun 12, 2019


    #16
    spdsk8race1 likes this.
  17. Fayazk3 Cupcake Jun 19, 2019

    Fayazk3, Jun 19, 2019 :
    I also have this issue in the uk when i visit oil rigs where there is no mobile reception and only reky on wifi calling
     

    #17
  18. G1547337499646 Cupcake Jun 27, 2019

    G1547337499646, Jun 27, 2019 :
    Same issue.

    I also have tried:
    • Enabling/Disabling Airplane mode (While in airplane mode, connecting to Wi-Fi network does not enable Wi-Fi Calling).
    • Enabling/Disabling Wi-Fi Calling (Settings > Wi-Fi & Internet > Sim & Network > SIM 1 > Enhanced Communications > Wi-Fi Calling)
    • Enabling/Disabling Wi-Fi

    None of these work. The only thing that works to re-establish Wi-Fi Calling is to restart the phone. At that point it does work again.

    All updates have been downloaded. I am on OxygenOS 9.5.8.GM31CB.
     

    #18
  19. Vector Jelly Bean Jun 27, 2019

    Vector, Jun 27, 2019 :
    Same issues here. Also does it on the regular OP7 (not pro) that I imported. So the issue happens on both the OnePlus 7 Pro and non-pro. I don't have this issue on my OP6, OP5T, OR OP3.
     

    #19
  20. spdsk8race1 Honeycomb Jun 27, 2019

    spdsk8race1, Jun 27, 2019 :
    you're using a T-Mobile variant that you flashed to the international variant?
     

    #20