9

Wi-Fi Calling dropping on OnePlus7 Pro (T-Mobile)

  1. hellfire55 Cupcake Jul 18, 2019

    hellfire55, Jul 18, 2019 :
    Problem is still present on 9.5.10. My Carrier is Vodafone Germany, but the problem is the same...
     

    #61
  2. Steven_Petrillo Froyo Jul 18, 2019

    Steven_Petrillo, Jul 18, 2019 :
    I have to say that 9.5.10 might be a bit better than previous versions. I actually took the approach to check my WiFi coverage with my home mesh APs, as well as ensuring that VoWiFi options are configured optimally on my OP7P.

    I am on a call for an hour now, that started out on VoWiFi. I just had one flip to VoLTE and then back to VoWiFi without dropping the call. This never happened prior to 9.5.10. I would lose the call completely. Going to keep monitoring this but fingers crossed!?!?
     

    #62
  3. topstan Eclair Jul 18, 2019

    topstan, Jul 18, 2019 :
    I am beginning to think this is at the root an android Pie problem.

    Google "wifi calling android pie" and you will see lots of problem reports including carriers other than T-Mobile and on phones other than OnePlus.

    My own experience (which may differ from yours) is that the OnePlus 7 Pro/T-Mobile combination provides flawless wifi calling... with one big proviso: You must cold start your phone, establish wifi calling AND THEN NEVER LEAVE RANGE OF YOUR ROUTER. Under those conditions, I never lose wifi calling. But as soon as I leave range of the router and therefor have no network signal (since I live in a dead spot) and no wifi, when I return to the router the wifi comes back but usually not the wifi calling.

    Since wifi calling is a feature of Pie on all phones and carriers (that support it), it stands to reason that the errant code is in Pie itself rather than the code Oxygen OS adds on. I expect Google needs to fix this. Unfortunately, we are not Google's direct customer, so I hope OnePlus and/or T-Mobile will work with Google to getting this fixed. Pixel users have reported problems too.
     

    #63
  4. topstan Eclair Jul 18, 2019

    topstan, Jul 18, 2019 :
    The loss of VoLTE is a slightly different problem than what I am reporting but it may have the same root cause, which is failure to properly restore the calling state when signal is temporarily lost. In my case, I totally lose wifi calling as soon as I get out of the range of my router in to a dead spot (where my home is). When I return, the wifi calling comes back maybe 10% or the time. If you have a related problem, your joy may be short lived.
     

    #64
  5. Steven_Petrillo Froyo Jul 18, 2019

    Steven_Petrillo, Jul 18, 2019 :
    My joy was just like yours....before 9.5.10. While I am only basing my results on one call it was a 90 minute call that never got lost, even with a flip to VoLTE and then back to VoWiFi.

    I am hoping(fingers crossed) that the combination of 9.5.10/phone config changes and WiFi signal analysis/config changes is helping me. We shall see!
     

    #65
  6. ZRXINLA Donut Jul 20, 2019

    Last edited: Jul 20, 2019

    #66
  7. DeathMoJo Gingerbread Jul 20, 2019

    DeathMoJo, Jul 20, 2019 :
    I started to think could it be a 5ghz/2.4ghz issue as well? 2.4ghz has better range and I have noticed less switching and dropping on it. My house is small so being on 5ghz, I get a solid signal throughout but still have issues with it staying on vowifi.
     

    #67
  8. Steven_Petrillo Froyo Jul 20, 2019

    Steven_Petrillo, Jul 20, 2019 :
    I still think OP needs to tweak the radios but I am beginning to agree with you. I made significant changes to my WiFi mesh, so that I extended the range to outside my home. I can get good signal all the way down my driveway now and I will begin working on the backyard soon.

    As I mentioned above 9.5.10 seems to be helping the situation. I am able to take calls that start on WiFi, and might flip to LTE in mid call, and not lose the call. I could not do that 10 days ago with any assuredness.
     

    #68
  9. jdgesmlls Donut Jul 21, 2019

    jdgesmlls, Jul 21, 2019 :
    This could be a result of 9.5.10, but I changed the 'Private DNS' setting to 'Automatic' and it seems to engage VoWiFi more consistently now.


    1563680177254.jpg
    I have 6 total APs around my house (mix of 2.4/5.0), so this issue is common for me as I am always switching between WiFi connections.

    Please give this a try and report if VoWiFi is more consistent.
     

    #69
  10. Steven_Petrillo Froyo Jul 21, 2019

    Steven_Petrillo, Jul 21, 2019 :
    Was the default to Off? I checked mine and it is Automatic but I cannot remember if that was default or I changed it.
     

    #70
  11. ajenks Cupcake Aug 11, 2019

    ajenks, Aug 11, 2019 :
    Has anyone got an update on this issue. We have One Plus 7pros, we're on T-Mobile, and my wife and I are both having the same issues with our WiFi calling
     

    #71
  12. ZRXINLA Donut Aug 11, 2019

    ZRXINLA, Aug 11, 2019 :
    Still the same. issue not fixed.
     

    #72
    ajenks likes this.
  13. topstan Eclair Aug 12, 2019 at 12:58 AM

    topstan, Aug 12, 2019 at 12:58 AM :
    I'm wondering if you have tried OS 9.5.11. I'm not sure if it is in wide distribution yet. Since I got it my wifi calling problems have pretty much gone away. You can get it with the Oxygen Updater.
     

    #73
  14. ZRXINLA Donut Aug 12, 2019 at 1:46 AM

    ZRXINLA, Aug 12, 2019 at 1:46 AM :
    I have it since it almost came out. Still disconnects and connects. Garbage.
     

    #74