0
Network/Connectivity Wi-Fi dropping on mesh system

  1. gsaramet
    Cupcake Aug 28, 2021

    gsaramet , Aug 28, 2021 :
    Oneplus 6T here.


    Mesh Wi-Fi worked perfectly on Android 9.
    After upgrading to Android 10, it started to loose connection, and it kept on doing that no matter how I tried to cope with it. Rule was sooner or later I would get a "!" near the wifi symbol and I would have to disconnect the wifi for a longish time (30 secs or so) before reconnecting.
    Now, I upgraded to Android 11 - and it's much worse. I loose connection much faster, and I get no "!" warning. However, now I can simply disconnect wifi and reconnect immediately - I don't have to wait about 30 seconds.
    Mesh is a 6 pods Deco M5.
    It's my third Oneplus unit, and likely the last - having to reconnect it every 10 minutes or so it's not what I expect from a phone.
     

    #1
  2. Raza_Dawar
    Gingerbread Aug 28, 2021


    #2
  3. Shailender Sharma
    Nougat Aug 28, 2021


    #3
  4. Shailender Sharma
    Nougat Aug 28, 2021

    Shailender Sharma , Aug 28, 2021 :
    Try to Reset WiFi, Mobile & Bluetooth -
    Settings - System - Reset Options - Reset WiFi, Mobile & Bluetooth.
    It might help.
     

    #4
  5. gsaramet
    Cupcake Aug 29, 2021

    gsaramet , Aug 29, 2021 :
    Thank you, I did try that, it does not help.
     

    #5
  6. Shailender Sharma
    Nougat Aug 29, 2021


    #6
  7. nerdkabir
    The Lab² - Oclean X Pro Elite Reviewer Aug 29, 2021


    #7
  8. gsaramet
    Cupcake Aug 29, 2021

    gsaramet , Aug 29, 2021 :
    Thank you all guys for your suggestions. Unfortunately, none works. It drops the wifi when roaming between pods - and it does not report it.
     

    #8
  9. Y1593275941988
    Cupcake Dec 2, 2021

    Y1593275941988 , Dec 2, 2021 :
    I had a similar “Wi-Fi disconnect” problem after upgrading my OnePlus 6 to Android 11 / OxygenOS 11.1.1.1.

    The problem was related to a TP-Link Deco Mesh (WireLess Wi-Fi stations). This mesh worked fine with the previous OxygenOS.

    The resolution was to disable "Fast Roaming" using the Deco Mesh app and I hope this is applicable to you too.
     

    #9