Widgets stop updating

  1. Seeyah
    Cupcake Jul 22, 2016

    Seeyah , Jul 22, 2016 :
    Hi everyone,

    After a couple of hours, my widgets stop updating (not crashing, just not updating). I have to restart the launcher to fix it and after a couple of hours, the same problem occurs.

    I am on the latest version and have already tried Nova Launcher, Apex Launcher and Action Launcher. With every launcher, it's the same problem.

    Widgets are Gtask, gmail, google calendar, Accuweather and Proximus. Every widget keeps unupdated.

    Anyone has a fix for this?


  2. Mr. BG
    Community Hero 2020 Jul 22, 2016

    Mr. BG , Jul 22, 2016 :
    Did you update to the latest Google apps, and clear system cache afterwards?

  3. Seeyah
    Cupcake Jul 22, 2016

  4. Seeyah
    Cupcake Aug 12, 2016

    Seeyah , Aug 12, 2016 :
    Installed latest update with wipe via TWRP, still not fixed. nobody else having this problem?

  5. Tiongkia
    Froyo Aug 27, 2016

    Tiongkia , Aug 27, 2016 :
    I have this widget not updating issue in many roms and phones. Stock oss, Sultan cm13, zf2 stock rom, cm13 nighty. Both stock launcher and nova launcher.

    I also don't know how to fix it. I just restart launcher. But its not often

  6. Seeyah
    Cupcake Aug 28, 2016

  7. El_Capitan
    Cupcake Oct 5, 2016

    El_Capitan , Oct 5, 2016 :
    So here is what fixed it for me I had enabled the dark theme in Settings -> Customization
    I switched back to the light theme and enabled the dark theme again. Since then all widgets worked properly. Don't know if it will work the other Way around (from light to dark and back again).

    Hope this will fix it for you :)

  8. Seeyah
    Cupcake Oct 5, 2016

    Seeyah , Oct 5, 2016 :
    well i updated to 3.1.3 and now it seems working, thx for the replies

  9. Hughie
    Cupcake Jan 5, 2017

    Hughie , Jan 5, 2017 :
    Hi all, my OP3 hasn't been working properly since 7.0 nougat update. All my widget's stop working if I switch my phone off, I have to delete my widget's and reinstall every time to get them to work.. Any help/Advice would be much appreciated...

    G_Kamran_Ali_aBpq likes this.
  10. G_Kamran_Ali_aBpq
    Cupcake Jan 6, 2017

    Hughie likes this.
  11. Hughie
    Cupcake Jan 7, 2017

    Hughie , Jan 7, 2017 :
    1, Go into settings 2, click on battery 3, go to the top right and click on Aggressive doze & app hibernation and select Widgets/apps you don't want optimised.

    this fixed the issue with my widgets..

    viktamvr likes this.