0
Wifi 5gHz band is not detecting by OnePlus 6 via OnePlus 6 Mirror Black

  1. Pulak Majumder , via OnePlus 6 Mirror Black , Jul 16, 2020 :
    I am unable to detect any 5g wifi band i also tried it by changing channel also but it could not detect. on the other hand the 5g band is detected by by my laptop and also Xiaomi Redmi note 8 and other phone can detect the 5g band and can use the network also.
    How to solve this problem???

    1. My two band names are different.
    2. I reset the the wifi settings..
     

    #1
  2. The1Lion
    Marshmallow Jul 16, 2020


    #2
    Pulak Majumder and Tobikage like this.

  3. #3
  4. Caomhin
    Community Hero 2020 Jul 16, 2020

    Caomhin , via OnePlus 6T , Jul 16, 2020 :
    Reset your WiFi adapter, see if that helps.

    Settings, System, Reset Options, Reset WiFi Mobile Bluetooth.

    If your router is capable of 2.4ghz and 5ghz make sure the SSID Name for each is different, you can edit the SSID Name on the Router Admin page.

    Also check your router broadcast channels for interference, change them to other channels if you find a nearby router broadcasting on the same channel as yours.

    Use a WiFi analyzer to check.

    I use this one from the Playstore to check for nearby routers using the same channel as me, and I switch my channel on the router to suit.

    https://play.google.com/store/apps/details?id=com.vrem.wifianalyzer

    Also a suggestion here for 8 Series but some of the suggestions may crossover to 6 series and others.

    https://forums.oneplus.com/threads/my-findings-of-the-5-ghz-wifi-connection-issue.1221263/
     

    #4
  5. Pulak Majumder , via OnePlus 6 Mirror Black , Jul 16, 2020 :
    1. I tried wifi analyzer app in this phone but it can't detect the signal of 5GHz how it will analyse this???
    It doesn't show any Signal of 5GHz but on the other hand when i use the app on other phone it can analyze.
    2. actually i tried the steps that you gave on the other link but it doesn't gave me any result.
     

    #5
    Caomhin likes this.
  6. Caomhin
    Community Hero 2020 Jul 16, 2020

    Caomhin , via OnePlus 6T , Jul 16, 2020 :
    Had a similar issue myself a while back a couple of times, in one instance my neighbours WiFi was crossing mine on the same channel, so I went into the Router settings and changed the 5ghz channel.

    Another time I found that if 2.4ghz WiFi is set to above Channel 11 on the router that 5ghz could not be found at all. The 2.4ghz was at 12.

    So I changed the 2.4ghz channel to below 11 and after couple of mins the phone could pick up the 5ghz no problem.

    So use your other phone to scan for channel overlap with neighbours, and also change 2.4Ghz channel to bellow channel 11 but away from any neighbours using the same channel.
     

    #6
  7. Pulak Majumder , via OnePlus 6 Mirror Black , Jul 17, 2020 :
    My 2.4 GHz band chanel are below 10 which is actually 8 and my 5 GHz band is 48. But even now it's not detecting the 5 GHz band.
    And around me there are only one wifi of my neighbor but it's network rarely reach to me. So i think there is very little possibilities to overlap with my chanel.
     

    #7
    Caomhin likes this.
  8. Caomhin
    Community Hero 2020 Jul 17, 2020

    Caomhin , via OnePlus 6T , Jul 17, 2020 :
    The only other thing I could suggest, would be to back up your phone data, then do a Full factory Erase All Data reset. And see if that can help.

    And/Or contact OnePlus support directly to see if they have more information on your issue. Scroll down the page for contact and online chat details.

    https://www.oneplus.com/support
     

    #8
    The1Lion likes this.
  9. Danikuliner
    Cupcake Jan 24, 2021

    Danikuliner , Jan 24, 2021 :
    I had the same issue with my own 6t and just fixed it.
    It appears that the oneplus 6t cannot detect all the wifi 5GHZ channels...
    So try to go to the router settings by typing 192.168.1.1 in any browser, and change the wifi 5GHZ channels from auto to a channel lower than 100... this worked for me.
    Cheers
     

    #9
    Pulak Majumder likes this.
  10. W1602166155038
    Cupcake Feb 4, 2021

    W1602166155038 , Feb 4, 2021 :
    PS. I AM REPOSTING THIS SOLUTION TO SEVERAL THREADS Hello Everyone it is 4th of February 2021. I have an ONE PLUS 6 i started having an issue with my 5ghz wifi after the upgrade to android 10 almost 2 years ago . Anyhows it would drop the wifi randomly or dissconnect me from it and when i turned it on the 5ghz network it would take over a minute untill it connects. I have finally found A BIG solution to this problem it's the Security in your Modem. On my modem it was on security WPA-WPA2PSL-AUTO. Now i changed it to ONLY WPA2-PSK Or depending on your device which one works better if u have the option of WPA PSK either one of these u can choose them but dont go for WPA-WPA2PSL-AUTO. It's a security-Bug issue that popped up on many android 10 devices after the update. So once i changed it to either one of those instead of WPA-WPA2PSL-AUTO ' my issue went away. I've been struggling with this problem since the android 10 update came to my ONE PLUS 6 . So there you have it FINALLY A FIX TO OUR PROBLEM i'm pretty sure this will work for the newer ONE PLUS 8s as well.
     

    #11