1
Wifi 5ghz connection issue via OnePlus 9 Pro

  1. Ewing33855
    Froyo Apr 19, 2021

    Ewing33855 , via OnePlus 9 Pro , Apr 19, 2021 :
    For some reason, I can't connect to my routers 5ghz network but 2.4 works fine. I've been connected to 5ghtz since I've gotten my 9 pro but it stopped working this morning and I can't seem to reconnect. I've tried resetting my network settings on my phone, resetting my phone, resetting my router, re-adding the ssid. It keeps on saying "obtaining IP address". It's a newer wifi 6 router. Any ideas?
     
    Last edited: Apr 19, 2021

    #1
    yash00012 likes this.
  2. Tokolozi
    Most Original Avatar Apr 19, 2021

    Tokolozi , Apr 19, 2021 :
    Try resetting the router itself, or maybe changing it's channel if possible to see if that makes a difference.

    On your phone, try disabling the randomized mac option in the wifi settings as wel.
     

    #2
    Caoimhín and Bobbie63 like this.
  3. Ewing33855
    Froyo Apr 19, 2021

    Ewing33855 , via OnePlus 9 Pro , Apr 19, 2021 :
    Thanks. I tried undoing the randomized max address. That didn't work. I forgot my router's admin pw so maybe I'll hard reset the router later and start fresh.
     

    #3
    Tokolozi likes this.
  4. Tokolozi
    Most Original Avatar Apr 19, 2021

    Tokolozi , Apr 19, 2021 :
    It could be that the channel was left on auto on the router side. Maybe after some time it switched to a channel not so good for the phone.

    That or it's DHCP server messed up.
     

    #4
    Caoimhín likes this.
  5. Ewing33855
    Froyo Apr 19, 2021

    Ewing33855 , via OnePlus 9 Pro , Apr 19, 2021 :
    What do you suggest then? Sorry, networking knowledge is lacking on my end.
     

    #5
    Tokolozi likes this.
  6. Tokolozi
    Most Original Avatar Apr 19, 2021

    Tokolozi , Apr 19, 2021 :
    A reset on the router side should probably fix both of the issues.

    To prevent the channel switching, manually select one yourself. As an example, channel 40 works perfectly for me. You can always use an app like Wifiman to check which channel isn't the most congested in your area.
     

    #6
    Caoimhín likes this.
  7. Ewing33855
    Froyo Apr 19, 2021

    Ewing33855 , via OnePlus 9 Pro , Apr 19, 2021 :
    Restarted the router twice previously with no luck. You think changing the channel would work? I'd have to reset the admin pw, which would reset my ssid and settings but I can live with it.
     

    #7
    Tokolozi likes this.
  8. Tokolozi
    Most Original Avatar Apr 19, 2021

    Tokolozi , Apr 19, 2021 :
    Honestly, no idea if it'll work for sure. Only troubleshooting step I could think of that might make a difference.

    As long as you just rename it with the last SSID and password, your other devices won't be effected.

    You can always try to see if you have the same issue on another network/guest network (maybe make a hotspot with another phone) to rule out the routers?
     

    #8
  9. Ewing33855
    Froyo Apr 19, 2021

    Ewing33855 , via OnePlus 9 Pro , Apr 19, 2021 :
    All my other devices that's connected to the 5ghz have no issue and haven't been disconnected. Ipads, my work laptop, streaming boxes. So weird.
     

    #9
    Tokolozi likes this.
  10. Caoimhín
    OnePlus 9 Series Expert Community Expert Apr 19, 2021

    Caoimhín , via OnePlus 6T , Apr 19, 2021 :
    If it happened all of a sudden it sounds like an App installation or App update. Can you check if anything was installed or updated just before it stopped working?

    Do you have any VPN apps installed or DNS apps that use DNS from other providers. Even some Antivirus apps may have firewall options if you have one installed.
     

    #10
    Tokolozi likes this.
  11. Ewing33855
    Froyo Apr 19, 2021

    Ewing33855 , via OnePlus 9 Pro , Apr 19, 2021 :
    No vpn and no antivirus. Didn't update any apps recently as I've disabled auto updates.
     

    #11
    Caoimhín likes this.
  12. Caoimhín
    OnePlus 9 Series Expert Community Expert Apr 19, 2021

    Caoimhín , via OnePlus 6T , Apr 19, 2021 :
    One thing to try, came across this myself a long while back. Had to change my 2.4ghz channel to below 11 on the router.

    If your 2. 4ghz channel is higher than 11, set 2.4Ghz to a Channel below 11. Give it about 1 to 2 minutes after you change the channel. Restart the phone and check if 5 ghz will now connect.
     

    #12
    Ewing33855 and Tokolozi like this.
  13. Caoimhín
    OnePlus 9 Series Expert Community Expert Apr 19, 2021

    Caoimhín , via OnePlus 6T , Apr 19, 2021 :
    Let us know if this worked for you. Thanks
     

    #13
  14. Swejuggalo
    OnePlus 9 Series Expert Community Expert Apr 19, 2021

    Swejuggalo , via OnePlus 9 Pro Stellar Black , Apr 19, 2021 :
    A kind of weird test but I've seen it happen and actually work... Use the feature to re-add the 5GHz via the WiFi share option from a other device that works.

    1618860561818.jpg

    1618860561889.jpg
     

    #14
    Caoimhín likes this.
  15. Ewing33855
    Froyo Apr 19, 2021

    Ewing33855 , via OnePlus 9 Pro , Apr 19, 2021 :
    No luck.
    edit: messed around with multiple channels for the 5ghz and now it works. thanks guys.
     
    Last edited: Apr 20, 2021

    #15
    Caoimhín likes this.
  16. yash00012
    Honeycomb Apr 20, 2021


    #16
  17. Swejuggalo
    OnePlus 9 Series Expert Community Expert Apr 20, 2021

    Swejuggalo , via OnePlus 9 Pro Stellar Black , Apr 20, 2021 :
    Great. If you want to you could always report it, describe the solution and then replicate your issue when they ask for further logs.

    View attachment 1590642
    Your region of the device and any possible regional options of the router are matching?
     

    #17
    Caoimhín and Ewing33855 like this.
  18. Caoimhín
    OnePlus 9 Series Expert Community Expert Apr 20, 2021

    Caoimhín , via OnePlus 6T , Apr 20, 2021 :
    Glad to hear it 👍
     

    #18