1
WiFi calling doesn't always turn on

  1. barnabyj
    Honeycomb Jun 11, 2019

    barnabyj , Jun 11, 2019 :
    so, I've noticed that WiFi calling doesn't always come back on when having a WiFi connection, going on mobile, then going back to WiFi. I have to reboot, then it will switch on. anyone else seeing this?
     

    #1
    bpwest80 likes this.
  2. calvin35
    Donut Jun 11, 2019

    calvin35 , Jun 11, 2019 :
    I have the T-Mobile version and have been using WiFi calling since day one and have not had this problem.
     

    #2
  3. bpwest80
    KitKat Jun 11, 2019

    bpwest80 , Jun 11, 2019 :
    I have the unlocked model and WiFi calling doesn't always show up top in the status bar when I have WiFi turned on, even though it should.
     

    #3
  4. barnabyj
    Honeycomb Jun 11, 2019

    barnabyj , Jun 11, 2019 :
    I'm running the unlocked global version with T-Mobile as my carrier. forgot to mention that originally.
     

    #4
  5. bpwest80
    KitKat Jun 11, 2019


    #5
  6. barnabyj
    Honeycomb Jun 11, 2019

    barnabyj , Jun 11, 2019 :
    I get that a lot, then if I reboot, WiFi calling comes back on. it's not as automatic as it should be for sure
     

    #6
  7. bpwest80
    KitKat Jun 11, 2019

    bpwest80 , Jun 11, 2019 :
    Nope. My 6T didn't do this.
     

    #7
  8. barnabyj
    Honeycomb Jun 11, 2019

    barnabyj , Jun 11, 2019 :
    neither did mine, either on T-Mobile firmware, or when I converted it to global.
     

    #8
  9. bpwest80
    KitKat Jun 11, 2019

    bpwest80 , Jun 11, 2019 :
    It's a bug with Oxygen os. Hopefully someone reported it. I don't have time to right now.
     

    #9
  10. Bodin Praphanthongchai
    Cupcake Jun 11, 2019

    Bodin Praphanthongchai , Jun 11, 2019 :
    I have T-Mobile unlocked and converted to international facing this issue too. You can fix this by setting in Wi-Fi preferences and turn off Intelligently select the best Wi-Fi. No more restart to get VoWifi or get only VoLTE while connected to wifi network. I hope this would help to solve the issue.
    1560232030305.jpg

    1560232030346.jpg
     

    #10
    ByrdSan likes this.
  11. barnabyj
    Honeycomb Jun 11, 2019


    #11
  12. barnabyj
    Honeycomb Jun 11, 2019

    barnabyj , Jun 11, 2019 :
    so far it seems that changing that option does make a difference. will give it a couple of days to be sure. thanks!!
     

    #12
  13. ByrdSan
    Eclair Jun 12, 2019

    ByrdSan , Jun 12, 2019 :
    I think turning off the option to intelligently select the best WiFi maybe done the trick. I'm about to leave my WiFi in a few. I'm really hoping VoWiFi works correctly once I reconnect later.
     

    #13
  14. barnabyj
    Honeycomb Jun 12, 2019


    #14
  15. bpwest80
    KitKat Jun 12, 2019

    bpwest80 , Jun 12, 2019 :
    Turning that off seemed to fix mine too. I guess it's a bug with Oxygen OS. Kinda what I figured.
     

    #15
  16. bpwest80
    KitKat Jun 14, 2019

    bpwest80 , Jun 14, 2019 :
    That no longer works for me. It worked for a couple days but not anymore.
     

    #16
  17. topstan
    Eclair Jun 21, 2019

    topstan , Jun 21, 2019 :
    I am on another thread on this problem, but turning off "intelligently select best WiFi" didn't work for me either. It seemed to work for a day or so and then the problem occurred again. I also worked with OnePlus tech support. They got me to do a hard reset. That was a pain of course as it's like starting again with a new phone. It also solved the problem for a few days, but then it came back again. At this point, I have tried about everything I can think of that I can do as a user. I hope OnePlus is working on a fix because I'm missing calls.
     

    #17
  18. Brown bear
    Cupcake Feb 29, 2020

    Brown bear , Feb 29, 2020 :
    When you have decent wifi coverage, then turn OFF the VoLTE from the settings (just keep only WIFI Calling ON). That will solve your problem. If you go outdoors, then turn on the VoLTE. Call drops may occur if you don't have good wifi coverage (since VoLTE has turned off in this case). Thanks
     
    Last edited: Feb 29, 2020

    #18