7
OxygenOS Wifi connection bug with ChromeCast or GoPro since OxygenOs 10

  1. cybertoto
    Cupcake Aug 21, 2020

    cybertoto , Aug 21, 2020 :
    I am contacting you to report a bug on OxygenOS since version 10.

    I have a OnePlus6, OxyGenOs version 10.3.5

    Since OxyGenOs went from version 9 to 10, I have a connection problem with my GoPro and my ChromeCast (2 different apps). The message that appears is the same on both apps: "Something came up. The application cancelled the request to choose a device."

    I have already contacted your support by chat 4 times about this, and here is what we have already done together to try to solve the problem:

    - we uninstalled and then reinstalled the Google Home (Chromecast) and GoPro apps.
    - we did a wipe cache on my phone
    - we reset my phone's network configuration
    - and finally, we even reset my phone to factory defaults.

    But the problem still persists.

    On the other hand, I tested with my old OnePlus3T (which is in version 9.0.6 of OxygenOs), the connections with my ChromeCast and my GoPro work very well !

    I also tested with a friend's Samsung (under Android 10, but not with OxygenOs), the connections work very well too !

    So there is a bug under OxyGenOs and I hope it will be fixed quickly.
     

    #1
  2. tomsitter
    Cupcake Aug 23, 2020

    tomsitter , Aug 23, 2020 :
    Same problem. Just upgraded my OP6 to 10.3.5 and now cannot cast to my smart TV, Chromecast, or Google Home minis. Very frustrating
     

    #2
    Z1609238035078 and Bafu111 like this.
  3. Bafu111
    Cupcake Aug 24, 2020

    Bafu111 , Aug 24, 2020 :
    I'm getting this issue too recently updated.

    I can no longer use my phone with my GoPro and it's killing me.

    Please look into it OnePlus!!



    OnePlus 5T
    Oxygen OS 10.0.0
    Build A510_43_200601
     

    #3
  4. Caomhin
    Community Hero 2020 Aug 25, 2020

    Caomhin , via OnePlus 6T , Aug 25, 2020 :
    Reset your WiFi adapter, see if that helps.

    Settings, System, Reset Options, Reset WiFi Mobile Bluetooth.

    Also disable Sleep Standby in
    Settings > Battery>Battery Optimisation >3 dot menu>Advanced Optimisation

    See if that helps as well.

    How To Fix Common Wi-Fi Problems In Android

    https://www.techjunkie.com/fix-wi-fi-problem-android/

    Also a suggestion here for 8 Series but some of the suggestions may crossover to 6 series and others.

    https://forums.oneplus.com/threads/my-findings-of-the-5-ghz-wifi-connection-issue.1221263/

    This is from Sony TV support, but is also relevant to most TVs

    https://www.sony.com.sg/electronics/support/articles/00114152
     

    #4
  5. suketk
    Cupcake Sep 22, 2020

    suketk , Sep 22, 2020 :
    This is affecting me on my 5T across several apps, including Google Home and GoPro. This is fundamentally a OnePlus issue that the team needs to resolve - almost everyone experiencing this exact error message across the internet is using a OnePlus phone.
     

    #5
  6. Caomhin
    Community Hero 2020 Sep 22, 2020

    Caomhin , via OnePlus 6T , Sep 22, 2020 :
    You're wrong. It's happening on many devices by many manufacturers, quick search will show you this, and even gives suggestions to resolve the issues.

    https://www.google.com/search?q=con...nt=ms-unknown&sourceid=chrome-mobile&ie=UTF-8
     

    #6
  7. Pappagallo
    Cupcake Oct 4, 2020

    Pappagallo , Oct 4, 2020 :
    Searching for connection problems is too generic. Searching for the error message supplied by the topic starter gives a different view.
    I have the same issue on my OP6 that did not exist before the upgrade, but connecting with a Samsung Galaxy S8 using Android 10 is NOT a problem. So, this is not an Android 10 issue but a OnePlus issue.
     

    #7
  8. GregorioDavila
    Cupcake Oct 16, 2020

    GregorioDavila , Oct 16, 2020 :
    SOLUTION
    I had the same issue connecting my gopro hero 8 Black with my one plus 6 for moths untill I saw a solution on a gopro forum.
    To connect successfully to your gopro you have to manually connect it trough your phone's wifi setting.
    Look for your gopro name and use the password from you gopro. You can find this password in the connection setting under the "camera info" (at least it is for my gopro hero 8 black)
    It's a little annoying that this has to be done repeatedly as the error popup returns every time I reuse the app, but I can at least view all my gopro media trough my phone again.
     
    Last edited: Oct 16, 2020

    #8
  9. Pappagallo
    Cupcake Oct 19, 2020

    Pappagallo , Oct 19, 2020 :
    This is not a solution but a workaround that you have to apply manually everytime you want to connect to your Gopro.
    A real solution is still needed.
     

    #9
  10. V1603424582071
    Cupcake Oct 23, 2020

    V1603424582071 , Oct 23, 2020 :
    I had this same issue, it was terrible. But the new OnePlus OxygenOS 10 update that came out tonight fixed it for me.
     

    #10
  11. suketk
    Cupcake Oct 28, 2020

    suketk , Oct 28, 2020 :
    Exactly, this specific issue plagues only OnePlus users. Also, the suggested workarounds are just that - workarounds.

    What update did you get? I haven't gotten any other than the original 10.0 one.
     

    #11
  12. smathur1291
    Cupcake Dec 22, 2020

    smathur1291 , Dec 22, 2020 :
    Can you let me know what update version you got?
     

    #12
  13. smathur1291
    Cupcake Dec 22, 2020

    smathur1291 , Dec 22, 2020 :
    The issue is still there. It is now affecting connecting to go pro, amazefit smartwatch basically anything using wifi direct. Even file transfer apps like Share It are not working. Can anyone suggest a solution for this?
     

    #13
  14. smathur1291
    Cupcake Dec 22, 2020

    smathur1291 , Dec 22, 2020 :
    what update version you got?
     

    #14
  15. Brendant182
    Cupcake Dec 26, 2020

    Brendant182 , Dec 26, 2020 :
    Hi I ran into this issue today when connecting to a gopro.

    I was able to resolve this issue by going into the saved network wireless network and changing the privacy settings. When it was set to "use randomized mac" it did not work at all, but as soon as I changed to "use device mac" it now connects first time everytime.

    Please give it a go and let me know if it works, and this will need to be done to any network/ device you are connecting to directly.
     

    #15
    Caomhin likes this.
  16. Z1609238035078
    Cupcake Dec 29, 2020

    Z1609238035078 , Dec 29, 2020 :

    HAVING THE EXACT SAME PROBLEM. it's so infuriating. Everything worked perfectly fine before update. I wish they fix this asap otherwise I will need to change to a device that does work. Been using one plus phones for years but won't be buying another of this doesn't get fixed
     

    #16
  17. Caomhin
    Community Hero 2020 Dec 29, 2020

    Caomhin , via OnePlus 6T , Dec 29, 2020 :
    You can revert to a previous version for 6 Series phones if you wish. It will however involve wiping the phone so you will need to back it up.
    ROLL-BACK FROM CURRENT ANDROID 10 Stable TO EARLIER STOCK ANDROID 9 OR 10
    All Downgrades to earlier builds involve wiping the phone.
    So you will need to backup your phone data.
    Thanks to @ironass for putting this together and maintainig the thread.
    This Link will guide you through the Downgrade process.
    https://forums.oneplus.com/threads/roll-back-to-stock-android-9-or-10.1215079/
     

    #17
    ironass likes this.
  18. kurbar
    Cupcake Jan 1, 2021

    kurbar , Jan 1, 2021 :
    I'm experiencing the same issue on my Oneplus 6 when trying to set up an Xbox Series X console. When the Xbox app tries to connect to the console over Wifi, the error "Someting came up..." pops up and it fails to connect. I tried by connecting to the console directly via Network, it connects but eventually still fails with the same error (since the Xbox app disconnects and tries to reconnect). I tried forgetting all existing networks, didn't work. Tried the "use device mac" workaround, didn't work either. Eventually tried factory reset as well. Didn't work, still same error.

    I'm running OxygenOS 10.3.7. Any other ideas before resorting to a downgrade to Android 9?
     

    #18
  19. Hemangb2
    Honeycomb Jan 1, 2021


    #19
  20. Caomhin
    Community Hero 2020 Jan 1, 2021

    Caomhin , via OnePlus 6T , Jan 1, 2021 :
    In the Cast app, make sure Enable Wireless Display is selected
    This is how mine is set.
    1609515360663.jpg
     

    #20
    Hemangb2 likes this.