0
WiFi Connectivity Issue

  1. alizaidi313
    Froyo Apr 9, 2015

    alizaidi313 , Apr 9, 2015 :
    My WiFi has been acting weird lately. For example, if I go somewhere (where I have already been connected previously) the WiFi doesn't connect. I go into settings and click connect but it doesn't do anything.

    What I end up having to do is reboot my phone and then it connects. It's not too much of a big deal but it is quite annoying. Any suggestions?
     

    #1
  2. idbl_fanatic1
    Ice Cream Sandwich Apr 9, 2015

    idbl_fanatic1 , Apr 9, 2015 :
    It's an android thing, not an OPO, I have had this happen on every android I have owned all the way back to the G1
     

    #2
  3. dan a
    Cupcake Apr 16, 2015

    dan a , Apr 16, 2015 :
    I have this same issue. It did not happen when I first got the phone. Seems to have happened a couple updates ago. I was hoping CM12s would resolve it, but it doesn't.
     

    #3
  4. alperri
    Cupcake Apr 16, 2015

    alperri , Apr 16, 2015 :
    I'm having an issue with connecting to mobile data. Like, my phone only gets service in areas where it'll connect to the wifi..
     

    #4
  5. MannyCalavera
    Eclair Apr 16, 2015

    MannyCalavera , Apr 16, 2015 :
    Seems like a software issue, nothing hardware related.
     

    #5
    alizaidi313 likes this.
  6. bakerbarber
    Jelly Bean Apr 16, 2015

    bakerbarber , Apr 16, 2015 :
    Make sure you uncheck the option to avoid poor connections under advanced WiFi settings.

    My WiFi is flaky since the latest official CM update, but I can't pin point what's causing it. My Nexus 7 is doing the same thing, but at home. Shows connected, yet is really laggy until I shut off WiFi and re-enable it.
     

    #6
  7. dan a
    Cupcake Apr 16, 2015

    dan a , Apr 16, 2015 :
    That option is already unchecked for me and it happens even if I have very excellent wifi strength. It will not reconnect once I'm out of range and come back in to range, such as when I leave home and come back, unless I reboot. Then it connects fine and works fine.
     

    #7
  8. dan a
    Cupcake Apr 17, 2015

    dan a , Apr 17, 2015 :
    Are there any options out there? I've seen a fair amount of people complain about this on the boards, but the only solution I've seen is to use the Franco kernel, but my understanding is that I need to root. Unfortunately I can't root because I need to run Good for Enterprise.
     

    #8