9
[Submitted] WIFI connects and disconnects after updating android 11

  1. srinath1987
    Cupcake May 9, 2021


    #21
  2. G_LDN
    Cupcake May 10, 2021

    G_LDN , May 10, 2021 :
    This is an incredibly serious issue that renders my phone completely unusable and I've not heard anything from OnePlus, what is going on? This is a joke.

    Also to the other people, forgetting WiFi networks is not "a fix".
     

    #22
  3. kotoxie
    Cupcake May 13, 2021

    kotoxie , May 13, 2021 :
    Same issue
    Can't use wifi at all
    Latest Android 11 build
    Workaround does *not* fix the issue
     

    #23
  4. riteshjalan123
    Cupcake May 13, 2021

    riteshjalan123 , May 13, 2021 :
    I also faced the same issue as I have both 2.4Ghz and 5Ghz. After googling I found that turning off Intelligently select best wifi solved this problem.
    It can be done from here
    Settings-> wifi and network-> wifi-> wifi preferences-> Intelligently select the best wifi
     

    #24
  5. ankitdutt87
    Cupcake May 15, 2021

    ankitdutt87 , May 15, 2021 :
    I am also facing this issue. How to resolve this as unable to work like this on the op7 phone
     

    #25
  6. W1593241066493
    Cupcake May 15, 2021

    W1593241066493 , May 15, 2021 :
    Same issue since I have updated to Oxygen 11. Can't believe OP users are dealing with such a noticeable issue, and there is no fix provided by the company.
     

    #26
  7. NullPointers
    Cupcake May 17, 2021

    NullPointers , May 17, 2021 :
    I have the problem on my phone and this option was already turned off. Didn't fix the issue for me
     

    #27
  8. A1574973084612
    Cupcake May 20, 2021

    A1574973084612 , via OnePlus 7T , May 20, 2021 :
    I have same wifi disconnect/reconnect issue. Forgetting either of the 2 router networks , 2.4GHz or 5GHz, stabilizes the network left active. If both are connectable, wifi connection interrupts frequently.
     

    #28
  9. KaranSeth02
    Froyo May 23, 2021

    KaranSeth02 , May 23, 2021 :
    facing the same problem. Trying a new change:
    1. Forget 1 SSID
    2. Turn off Automatically select the best wifi

    Let's see if that works
     

    #29
  10. bvtd092
    Froyo May 23, 2021


    #30
  11. U1619194536399
    Cupcake May 23, 2021

    U1619194536399 , May 23, 2021 :
    Try turning off 'intelligently select the best wifi' under Wifi preferences.

    Also try forgetting your second wifi connection at home if you have one.
     

    #31
  12. bvtd092
    Froyo May 24, 2021

    bvtd092 , May 24, 2021 :
    Good news. Today I received the update 11.0.1.1. After installing the update the wifi problem is completely solved.
    The long wait for a solution has been rewarded!
     

    #32
  13. hindle92
    Cupcake May 27, 2021

    hindle92 , May 27, 2021 :
    Just updated to oxygen11 and I'm getting this, doesn't stay connected for 2mins
     

    #33
  14. T1542855787230
    Cupcake Aug 25, 2021

    T1542855787230 , Aug 25, 2021 :
    Same thing happened to me on my 6T. Went to the Verizon store, no help, Got Verizon on the phone, got a OnePlus tech to join in. Tried new SIM, resets, a factory reset, no luck. Went back to the Verizon store. Lady looks at it for 10 minutes. Tries putting the SIM card in the second SIM slot. Finally works fine! It's been so stupid.
     

    #34
    freddeno likes this.
  15. freddeno
    Gingerbread Sep 8, 2021

    freddeno , Sep 8, 2021 :
    Thank you, that seemed to have solved my wifi issues on my oneplus 6 after updating to oxygen os 11..I just switched my SIM card to slot nr 2 and now wifi doesnt disconnect anymore..
     

    #35
  16. freddeno
    Gingerbread Sep 8, 2021


    #36
  17. L1633434049153
    Cupcake Oct 5, 2021

    L1633434049153 , Oct 5, 2021 :
    I found a workaround for me. I found out that the phone stays connected to WIFIs without an internet connection, when you accept the popup "stay connected even without internet".
    So i disconnected the WAN cable from my router so the WIFI has no Internet and accpeted the popup.
    After that i attaced the cable again and the wifi stays connected on the phone even with internet in the network.
     

    #37