0
Network/Connectivity WiFi consistently connected but with ! next to it

  1. shivigarg
    Cupcake Oct 17, 2020 at 2:51 PM

    shivigarg , Oct 17, 2020 at 2:51 PM :
    When I connect to my home Wi-Fi network, things work great for a short period of time. But after a little bit (maybe 30 minutes) the Internet connection will completely drop off. It still shows me as connected to the network but with no Internet (Wi-Fi symbol with an ! next to it). I then disable WiFi and immediately re-enable WiFi, and it re-connects with the internet working again. Then again, after 30 minutes or so, the problem happens again (connected, but no internet and ! after WiFi symbol).

    I've check my other devices on the same network and everything is fine with the network itself. My wife is on the same home network with a OnePlus 6T and has no problems at all. After Googling and checking this forum, I've tried many suggestions including reboot, reset network settings, factory reset, setting connection to unmetered, using device MAC, etc. but nothing has worked.

    Any help would be greatly appreciated! It has been very frustrating having to keep disabling and re-enabling WiFi about 20 times per day.
     

    #1
  2. Swejuggalo
    Lollipop Oct 17, 2020 at 3:30 PM

    Swejuggalo , via OnePlus 8 Pro Ultramarine Blue , Oct 17, 2020 at 3:30 PM :
    Any specific type of network? Router model, capable of WPA3, separated ssid for 2.4 and 5Ghz or the same ssid, single router or mesh/access points... Does a new router firmware exist?


    View attachment 1458248
    The community will ofcourse try to help but you may want to report directly to Oneplus too via the feedback tool.

    On my specific router people have reported issues when they used WPA2 encryption. Since I have used WPA3 since long time back I never noticed any issues. I suggested that change and that seemed to help for them too.
    Some routers also support dual modes like WPA/WPA2 mode or WPA2/WPA3 mode. Either of them may help too.
    A Google WiFi mesh that supported WPA3 also became stable via that change. It lacked a WPA2/WPA3 mode though.

    On my own case my main network is only WPA3. I have a restricted WPA2/WPA3 network for guests and older devices that lack WPA3.
     

    #2
  3. shivigarg
    Cupcake Oct 18, 2020 at 3:06 PM

    shivigarg , Oct 18, 2020 at 3:06 PM :
    My provider is RCN and I'm using a combo router/modem that is provided by the ISP.

    Model is Arris DG3450A
    Not capable of WPA3. Current Mode is WPA2-PSK (AES). I will try switching it to WPAWPA2-PSK (TKIP/AES).
    Mode is for 802.11 a/n/ac
    I have enabled WMM.
    I have both 2.4 and 5Ghz. They have different SSID (different network names). I have tried both networks and my phone has problems with both 2.4 and 5Ghz.
    Single Router (no mesh or access points).
    I'm on the latest router firmware.

    Any other suggestions would be helpful.
     

    #3
  4. Swejuggalo
    Lollipop Oct 18, 2020 at 3:24 PM

    Swejuggalo , via OnePlus 8 Pro Ultramarine Blue , Oct 18, 2020 at 3:24 PM :
    You could also try manually selecting different channels.
    I use WMM too.

    I've seen plenty of WiFi and network issues on several SD865 devices. So this could have roots all the way back to Qualcomm and the drivers.

    Regardless you might want to collect logs via the feedback tool and describe the issue too.
     

    #4
  5. shivigarg
    Cupcake Oct 18, 2020 at 3:32 PM

    shivigarg , Oct 18, 2020 at 3:32 PM :
    I tried switching to WPAWPA2-PSK (TKIP/AES). It didn't solve the problem.

    I switched the 5GHz Channel from Automatic to Manual. Let's see if this works.

    Question: How do I collect logs? Or do you mean the "recording" feature in the Feedback tool?
     

    #5
  6. Swejuggalo
    Lollipop Oct 18, 2020 at 6:06 PM

    Swejuggalo , via OnePlus 8 Pro Ultramarine Blue , Oct 18, 2020 at 6:06 PM :
    Yes. Report the bug by selecting the proper cathergory. In the case of network/wifi issues it normally offers some recording option.
     

    #6
  7. Swejuggalo
    Lollipop Oct 18, 2020 at 6:08 PM


    #7
  8. shivigarg
    Cupcake Oct 18, 2020 at 6:29 PM

    shivigarg , Oct 18, 2020 at 6:29 PM :
    So I think I figured out the solution.

    I changed the wifi channel on my router from "Automatic" to "manual." Then, I set the channel to a number above 100. Once I did this, I no longer have the WiFi issue. It's remain connected, and it's been over an hour so far. Fingers crossed, but it looks like this will be the solution.

    Thank you for your help!
     

    #8
    Swejuggalo likes this.
  9. Swejuggalo
    Lollipop Oct 18, 2020 at 7:27 PM

    Swejuggalo , via OnePlus 8 Pro Ultramarine Blue , Oct 18, 2020 at 7:27 PM :
    Automatic is often a trouble maker. Manual option can be a solution to more than just phones.

    1603045479199.jpg
    https://play.google.com/store/apps/details?id=com.vrem.wifianalyzer

    Checking the environment and select a decent range can often act better than auto.
     

    #9
  10. pavanbittu7
    Cupcake Oct 19, 2020 at 5:38 AM


    #10
  11. Swejuggalo
    Lollipop Oct 19, 2020 at 10:19 AM

    Swejuggalo , via OnePlus 8 Pro Ultramarine Blue , Oct 19, 2020 at 10:19 AM :
    On 11 or 10? I can stay connected to WiFi while sharing Hotspot.
    But on 10 I could deside how the Hotspot should work. So there I could select if it was supposed to share WiFi or Mobile data.
    The sharing of WiFi via the Hotspot seems like a fairly limited use though. When do we need to share WiFi via the Hotspot? What makes it different from connecting directly to the WiFi or use a guest account?
     

    #11