1

Wifi Disconnect after being inactive

  1. elanglois Lollipop Jun 17, 2019

    elanglois, Jun 17, 2019 :
    I didn't say but it was a problem with the router. I said turn off the feature on the router to see if that is the issue. it may still be a OnePlus issue, but we need to know where the issue lies. if you turn it off on the router and it fixes the issue, then it means that the phone has a problem with that feature
     

    #21
  2. acacio.capela Cupcake Jun 17, 2019

    acacio.capela, Jun 17, 2019 :
    This function is always disabled in my router. I have my main router and 2 spare routers(other brand) in my house, tested on all of them, same problem.
    The only thing that changed is the time it took for the phone to stop receiving notifications, sometimes is 5 minutes, sometimes is 1 hour. But in the end my phone stop receiving notification.
     

    #22
  3. elanglois Lollipop Jun 17, 2019

    elanglois, Jun 17, 2019 :
    Well, if its disabled, then that isn't the issue
     

    #23
  4. acacio.capela Cupcake Jun 19, 2019

    acacio.capela, Jun 19, 2019 :
    Ok I finally fixed it, have no idea if it was just one of these configurations or all of them combined

    Disable Advanced Battery Optimization: Deep and Sleep

    Disable Adaptive Battery

    Disable optimize battery for the apps(maybe this isnt needed since I am getting notifications on time from apps that have this enabled)

    Run this command via ADB or Android Emulador(this is disable every boot so you have to run again):
    dumpsys deviceidle disable

    This is tricky, you may need to root phone for it.
    You have to edit the build.prop this is located inside the system folder
    Find this 2 lines
    ro.vendor.qti.sys.fw.bservice_limit=5 - > I changed it to 120
    ro.vendor.qti.sys.fw.bservice_age=5000 -> I changed to 10000


    Lock your apps you want to receive notifications(maybe you don't need this)
    But go to overview mode, click the 3 dots above the app and choose Lock

    I locked my google play service too, just in case
    Go to dial, and dial *#*#426#*#* this will open the GCM service(google play service) this is the guy that handles notifications.
    After it is open, go to overview, 3 dots and lock it.

    Now I have notifications in time, and my webwhatsapp or airdroid never lose the connection because the phone went to sleep mode.

    For battery, I must say I did not noticed it got worst in FACT I think it got better, since now I can play(ragnarok eternal) for more time than I was playing before.
     

    #24