3
[Submitted] wifi does not connect after unlocking the phone

  1. G_Wolodymyr_Welukui_KhxM
    Froyo May 12, 2018

    G_Wolodymyr_Welukui_KhxM , May 12, 2018 :
    wifi is not connected after unlocking the phone. In order for the phone to turn on wifi again, it must be rebooted. When you enter the wifi settings menu, the phone hangs for a few seconds. Cleaning the cache, resetting the settings and flashing it does not solve this problem. This problem began a few days ago.
     

    #1
  2. pgrey
    Honeycomb May 13, 2018

    pgrey , May 13, 2018 :
    Same problem, same (stable) build, also started a few days ago.
    Seems to closely co-incide with the newest Launcher update, or very close to it.

    I am constantly rebooting my phone right now; while I suppose I could just prevent it from sleeping, ever, it doesn't seem like a very "sustainable" model, even if I simply permission an app to send a few bytes every minute or so.
    This is the "Release branch" right, shouldn't this type of (pretty) basic stability be there?
     

    #2
  3. djreaper
    Cupcake May 13, 2018

    Last edited: May 13, 2018

    #3
  4. G_mircea_ibAs
    Eclair May 13, 2018


    #4
  5. evgen2
    Cupcake May 13, 2018

    evgen2 , May 13, 2018 :
    I also have this problem with wifi.
    I reset my WiFi settings
    I cleared my system cache
    Does not help
    wifi is not getting connect when the phone wakes up (op5t)
     
    Last edited: May 13, 2018

    #5
  6. GhostInTheWall
    Froyo May 14, 2018

    GhostInTheWall , May 14, 2018 :
    Same for me.
    Started by resetting wifi settings, lasted for few minutes
    Tried clearing cache, no help
    Reset wifi settings, no help
    Did full factory reset, lasted for 3 or 4 hours.
     

    #6
  7. Некромент
    Cupcake May 14, 2018


    #7
  8. Artem S
    Cupcake May 16, 2018

    Artem S , May 16, 2018 :
    I have the same problem. I can't start the wifi module after i unlock my device from sleep mode. (3t)
     

    #8
  9. pgrey
    Honeycomb May 16, 2018

    pgrey , May 16, 2018 :
    Try turning on "Scanning Always Available" under your WiFi settings.
    This allows my phone to connect, about 90% of the time, in about 15-20 seconds (I have a pretty solid, commercial AP setup, backed by a SMB router). While before it was taking about 1-3 seconds, at least this way I can still connect, fairly consistently.
    This does increase my idle battery drain, unfortunately, although not as much as WiFi "always on" does.

    I was pinged by the customer-facing bug team, since, and have submitted full log dumps of the repro to them, and was told the Dev team is "looking at it". From my years of experience doing and managing s/w dev, this can mean a lot of things, but at least someone from OP reached out to me, to see if I could capture these.
    This is where I got the "always scanning" idea from, which was handy, because "always on" WiFi isn't tenable, in terms of battery, IMO. I had tried "Smart Switch" previously, to no avail, but always scanning seems to be a "decent compromise", for now.

    What I wonder, is how many are seeing this, if it's more isolated, or widespread and just not "noticed" (until their cell plan maxes out), or the users don't even know what a message board is. I'm pretty sure OP has a good idea of the incident rate, although I doubt they'll say much.
    If it's fixed, quickly and accurately, it probably doesn't matter.
     

    #9
  10. Tsimbaluga
    Cupcake May 18, 2018


    #10
  11. iPliSkiN
    Cupcake May 27, 2018


    #11
  12. pgrey
    Honeycomb May 29, 2018

    pgrey , May 29, 2018 :
    This is fixed, for me, in 8.1.2, the patch that came out a couple of days ago.
     

    #12
  13. mjh74
    Gingerbread May 29, 2018

    mjh74 , May 29, 2018 :
    Exactly the same issue but only after a factory reset. Google play services was always top battery usage despite following suggestions from many threads in the forums. I bit the bullet and performed a factory reset and since then, when waking the phone up, wifi either takes minute/s to connect or doesn't connect at all. When going to wifi settings, the options screen is very laggy and the enable wifi slider is ignored. The only way to get it back is to reboot.
     

    #13