6
wifi hotspot 5ghz not working

  1. emreoez Gingerbread Dec 6, 2018

    emreoez, Dec 6, 2018 :
    Anyone else having issues with 5Ghz Hotspot Tethering? Its not visible on Laptop/Phones/etc.
    2,4Ghz working just fine.
     

    #1
  2. DvDarkman Froyo Dec 7, 2018

    DvDarkman, Dec 7, 2018 :
    just tested and worked fine. I'm on the TMobile variant though, so it may be a more recent bug if you're on the a recent update.
     

    #2
  3. vijay_lalwani Honeycomb Dec 7, 2018


    #3
  4. K1545297079872 Cupcake Dec 20, 2018

    K1545297079872, Dec 20, 2018 :
    Yes I have exactly the same issue using the Hotspot on a brand new 6T (so I don't think I should be having to reset any settings given I've only just setup the phone)!

    2.4GHz works great, 5GHz setting results in the access point simply not showing up on any laptop/device.

    I'm going to perhaps try this later today, although this relates to Hotspot not working at all, so I'm not sure if this will solve the issue:
    https://forums.oneplus.com/threads/hotspot-not-working.769592/

    ps: I'm running OOS 9.0.7 Build A6013_41_181127
    pps: Bug submitted -> https://forums.oneplus.com/threads/wifi-hotspot-does-not-function-on-5ghz-band.968372/
     
    Last edited: Dec 20, 2018

    #4
    patite28 likes this.
  5. Goggeboy Honeycomb Dec 20, 2018


    #5
    K1545297079872 and patite28 like this.
  6. patite28 Cupcake Dec 21, 2018


    #6
    DrVikTroll and K1545297079872 like this.
  7. samprocat Ice Cream Sandwich Dec 21, 2018


    #7
  8. L1545646604191 Cupcake Dec 24, 2018

    L1545646604191, Dec 24, 2018 :
    Any updates ?
     

    #8
  9. K1545297079872 Cupcake Jan 13, 2019

    K1545297079872, Jan 13, 2019 :
    Sorry I didn't end up testing the potential fix that I linked to, but what I can report is that the update my OnePlus 6T received last night (A6013_41_181226) has resolved this issue for me! Hotspot now works on 5GHz for me without any issues.
     

    #9
    patite28 likes this.
  10. V1546101764004 Cupcake Jan 13, 2019


    #10
  11. IstKong Donut Feb 4, 2019

    IstKong, Feb 4, 2019 :
    Exactly the same issue here.
    In 2.4GHz, no problem.
    In 5GHz, I should reboot the phone to have a connection and/or switch on/off the tether mode, and it is not reliable.

    Of course, I am using a 2017 MacBook Pro which fully supports 5GHz Wi-Fi (works perfectly fine with my home router)

    Really annoying.

    I am running the latest update 9.0.11 on OnePlus 6T A6013
    Please fix this.
     
    Last edited: Feb 4, 2019

    #11
  12. valtteri1010 Cupcake Feb 4, 2019


    #12
  13. IstKong Donut Feb 7, 2019

    IstKong, Feb 7, 2019 :
    I hope that they really can fix this with an update and that it is not a Hardware interference...
     

    #13
  14. E1550007641673 Cupcake Feb 12, 2019

    E1550007641673, Feb 12, 2019 :
    DISCLAIMER: this information is provided as is and I don't guarantee it will work and/or won't destroy your phone and/or data. You're responsible for your actions. Please remember to always do your own research before running commands posted by random people on the internet.

    This reddit post helped. I've adapted it a bit and added links to the relevant resources. If you know how to use adb jump to step 8.
    1. Enable developer mode on phone. https://developer.android.com/studio/debug/dev-options#enable
    2. Connect phone to laptop.
    3. Download and unzip the Android platform tools. https://developer.android.com/studio/releases/platform-tools
    4. Open a Command prompt or Terminal and navigate to the unzipped platform-tools folder.
    5. Type adb devices and press enter.
      You should see:
      List of devices attached
      * daemon not running; starting now at tcp:5037
      * daemon started successfully
      12ab496 unauthorized
    6. Your phone should get a popup. Hit okay.
    7. To confirm, type again adb devices and press enter.
      You should see:
      List of devices attached
      * daemon not running; starting now at tcp:5037
      * daemon started successfully
      12ab496 device
    8. Type adb shell and press enter. You should see OnePlus6:/ $
    9. Type settings put global tether_dun_required 0 and press enter.
    10. Restart your phone and run your 5GHz hotspot.
    If you try this, please run settings get global tether_dun_required before step 9 and post the result here. I forgot to do it and don't know what the default value was in case I ever want to restore it.

    With 2.4GHz thethering I was getting only 40Mbps on laptop. After enabling 5GHz I get 140Mbps, same speed as the phone itself.
     

    #14
  15. swanzer Donut Feb 12, 2019

    swanzer, Feb 12, 2019 :
    I had dreadful trouble out of the phone and ended up turning off the 5g broadcast at home. Phone losing WiFi all the time and ridiculous stuff like that.
     

    #15
  16. patite28 Cupcake Feb 20, 2019

    patite28, Feb 20, 2019 :
    FYI, I didn't do anything and it is fixed now, using 5GHz as I type this. Good luck y'all!
     

    #16
  17. anupritaisno1 KitKat Feb 20, 2019

    anupritaisno1, Feb 20, 2019 :
    The default value: https://android.googlesource.com/platform/frameworks/base/ /master/telephony/java/android/telephony/TelephonyManager.java#6886

    I would guess that if 0 fixes it then the default value is 1 on the oneplus 6

    Oneplus might have modified the code
    The code I linked to sets the default value to 2
     
    Last edited: Feb 20, 2019

    #17
  18. Mindrel Cupcake Feb 23, 2019

    Mindrel, Feb 23, 2019 :
    Same problem here. I received my OnePlus 6T yesterday and I could never connect in 5ghz. I tested with 3 differents devices. I tested the "settings global put..." adb method and it did not change anything. I hope it will be solved because I had a Moto G5s with which I had no problem in 5Ghz (a phone that had cost me 3 times cheaper ...).
     

    #18
  19. pcoventry Honeycomb Apr 9, 2019

    pcoventry, Apr 9, 2019 :
    I can't believe this, and Android Auto is still not fixed. It really is putting 2 fingers up to OP's customers.
     

    #19
  20. Clementb2018 Cupcake Apr 9, 2019

    Clementb2018, Apr 9, 2019 :
    I have the same problem. I tried a lot of things, but nothing works.
    Interesting fact: If I remove the sim card, I can see the 5GHz hotspot on my other devices. I have oxygen OS OpenBeta, do you think that if I come back on the classic channel, it can solve the problem?
     

    #20