1
Wifi hotspot not working with laptop [Oneplus 3] [Android Oreo]

  1. beedaa
    Eclair Dec 14, 2017

    beedaa , Dec 14, 2017 :
    Oneplus 3, Android Oreo.

    Greetings Oneplus community!

    I would like to ask for assistance regarding my Oneplus 3's wifi hotspot feature. Basically, when I try to connect any laptops/computers (yes I have tried about 2 others), they will connect to the hotspot (4G) as per normal, but will have a SUPER SLOW internet. I checked the laptop's task manager and I only get 1-50 kbps. An example, is that I try to search something on Google, and it will take 10 minutes to load. Though this problem happens randomly, like it happens 60% of the time.

    I tried the following to somehow narrow down the issue:
    1. Factory reset my OP3.
    2. Used other laptops/computers to connect to the hotspot and same results (connection successfully established, but almost no internet.
    3. Tried my laptop to connect to my wife's iPhone hotspot, and it works flawlessly.

    With these troubleshooting, I assume that the problem is with my OP3's hotspot, but I couldn't find a fix for it. Requesting your help to somehow guide me how to fix it or any advice is very much appreciated. Thanks in advance!
     

    #1
    Y1527642948543 likes this.
  2. beedaa
    Eclair Dec 15, 2017


    #2
  3. VaibhavBhargava
    Lollipop Dec 15, 2017

    VaibhavBhargava , Dec 15, 2017 :
    I have only been able to test it out for one device.
     

    #3
  4. beedaa
    Eclair Dec 15, 2017

    beedaa , Dec 15, 2017 :
    what do you mean?
     

    #4
  5. VaibhavBhargava
    Lollipop Dec 15, 2017


    #5
  6. Bobbie63
    Marshmallow Dec 15, 2017

    Bobbie63 , Dec 15, 2017 :
    Tbh no, I've seen a few people having some issues with the hotspot, but I can't recall a solution. I presume the speed for mobile data on the phone is normal?

    Edit: and is the same happening when you run you device in safe mode?
     

    #6
  7. beedaa
    Eclair Dec 15, 2017

    beedaa , Dec 15, 2017 :
    Yes. Mobile data is perfectly normal. Even smartphones connected to my hotspot are working properly, its only the laptop that's having an issue. Weird.
     

    #7
  8. Bobbie63
    Marshmallow Dec 15, 2017

    Bobbie63 , Dec 15, 2017 :
    Wow, that's indeed weird, have you tried what happens if you run your phone in safe mode?
     

    #8
  9. beedaa
    Eclair Dec 15, 2017

    beedaa , Dec 15, 2017 :
    I haven't tried it in safe mode. But do you think it is necessary? Given the fact that 1, I factory reset my phone, and 2, hotspotting should be a normal feature... Im going crazy... haha
     

    #9
  10. Bobbie63
    Marshmallow Dec 15, 2017

    Bobbie63 , Dec 15, 2017 :
    I don't think it would make a difference tbh but might be worth a try. I myself don't use hotspot so never tried. Did it work before?

    Have you also tried, if possible, 5gHz band?

    Also you might want to give feedback to Oneplus through the feedback form in the first page of the dedicated thread.
     

    #10
  11. beedaa
    Eclair Dec 15, 2017

    beedaa , Dec 15, 2017 :
    I understand. I can try but my laptops are quite old so they won't connect unfortunately. Alright I will try the feedback form.
     

    #11
  12. Bobbie63
    Marshmallow Dec 15, 2017

    Bobbie63 , Dec 15, 2017 :
    Yes, it appears to be the phone, although it's very strange it's just a laptop giving issues. I think it's up to OP to give you an answer, I really wouldn't know for now.

    Sorry.
     

    #12
  13. G_Travis_Terrell_KRDg
    Donut Dec 26, 2017

    G_Travis_Terrell_KRDg , Dec 26, 2017 :
    I have this exact problem. Since updating to Oreo, my wifi hotspot is unusable. I've tried it on multiple laptops, all of which connect at 500kbps or less. Oddly, it seems that bittorrent speeds are close to normal on laptops connected to the hotspot.

    I've experienced this issue with all releases of Oreo thus far, from the original beta, to the official release, to the newer beta build. All have the same issue. I thought it was a carrier issue, but then reverted to Nougat and found that it worked properly.

    Have you found a solution to this problem, yet? Also, who is your carrier? Since I haven't seen widespread reports of this problem, I wonder if it is some combination of Carrier+OxygenOS Oreo? I'm on T-Mobile, FWIW.
     

    #13
    beedaa likes this.
  14. Easyrider77
    Eclair Jan 19, 2018

    Easyrider77 , Jan 19, 2018 :
    I got the one plus 3 about 2-3 weeks ago, and just now noticed my hotpot speeds as well. I use normal data it seems ok, but hotspot when I connect the speeds plummet.
    You say you've used nougat and things are fine, so I am in the process of downloading nougat and trying it out. If I have the same result, and hotspot then works I'll know it's an OS issue/software issue and will chime in as a second.

    I've read earlier on 1+ had this issue, aka: 2016 with the 3t, and they has a zip apparently that I'm guessing from reading had either a flashable modem file or a config for said modem, or both...that fixed the issue for some people.

    It mainly seems to be related to tmobile customers as far as I can tell.

    Update:
    Ok a day later and numerous tests, I can confirm this is indeed an OS issue not a hardware issue. I have tried 2 variants of oreo, beta 29 Oxygen os 5.0, and Beta 30 Oxygen os 5.0.1, and I got the same results on both.
    As for the OS itself, nothing wrong no errors, no issues, except for.....hotspot. (I have not tested wifi so this is a hotspot only test). After running both these versions of Oreo, I reverted back to nougat via a special zip provided by 1+ which lets you go from oreo to nougat, and am currently on Oxygen os beta 24 (op3_o2_open_24_0920 to be exact) and hotspot works fine now without slow down. I'm attaching a a photo.

    [​IMG]

    The top two of that list are Nougat oxygen OS

    The bottom 2 of that pic are Oreo Oxygen os.

    As I said I've tried 2 different versions of oreo and both give the exact same results. I also have used freedom OS and had the same issue with slow hotspot. The odd part though is, freedom OS nougat also gives me slow hotspot, while nougat oxygen OS works fine, which I don't quite get.

    I haven't narrowed down if it's an apn difference or just an os thing, but I did try and apn fix of setting the apn name to like epc.tmobile or somthing like that, which did not work on oreo.

    The only thing different I DID try was different OS versions.

    Just installed 4.5.1 nougat oxygen OS and even though it's nougat, it seems hotspot slows down again to a crawl.

    So I'm wondering what oneplus did from beta 24 nougat, to 4.5.1 nougat, and above, and what changed. Modem? APN? both? seems very odd, but I've narrowed it down so far that beta 24 nougat hotspot works fine, if I update to 4.5.1 nougat or above, hotspot ends up pretty un-usable. What takes 30mins to download, now takes 4 hours or better to download.

    While I don't expect much from the 1+ tech team, as they have a proven track record of pawning things off to other situations, or using a standard answer such as "our team is looking into the situation" etc...etc... and seem to always pass the buck such as maybe "oh it's got to be a carrier issue" all while not fixing anything, some times for months and even as much as a year later.
    This exact same issue cropped it's ugly head in 2016 as I said above, and seems to still be a problem child now in 2018.

    The fact it works fine in beta 24 nougat, and when I switch to 4.1.5 stable and above, there seems to be issues again tells me this is not on the user side, but the phone side, via OS or setting somewhere, possibly a file that got changed somewhere along the way, aka: modem maybe.
    I'm not a programmer nor will I claim to be, but I am a bit knowledgeable on how to track things down a bit, and I have done just that.

    So to the one plus team, I challenge you to please fix this issue once and for all. I will donate my time and/or phone as a test if need be while giving log files that are needed. This is not an issue that has just copped up recently, it's at least or almost been 2 yrs now, and still no fix. How long does a team need to actually "look" into an issue without getting a resolve. Maybe start with beta 24 nougat and or android 7.1.1 based custom roms, and go from there? just an idea I'm throwing out there

    Last update:
    On further testing I decided to take out as many as possible hurdles I could think of, so eliminating the fact of bad carrier today I went to a spot where I knew I had good lte and a strong signal. So I went to test and go some results back. My findings I eliminated the carrier as I had good speeds and a strong signal so this is in no way a carrier issue 100% positive on this now.
    What I found out is, that when I was on beta 24 oxygen os nougat, speeds and hotspot where fine.
    ANY kind of upgrade, be it custom roms, stable stock, beta stock (aside from the beta 24 one and 7.1.1 android custom roms) ANYTHING I updated to and tried resulted in at least 1/2 the speeds as I was getting before, and this was NOT just hotspot, this regular cell service LTE/LTE+ I got.
    I am posting more pics to prove my point and show it's NOT a hardware issue, it's more a software/OS issue.

    [​IMG] [​IMG] [​IMG] [​IMG] [​IMG]

    As you see in the pics, the faster speeds are all on nougat beta 24 or custom roms based on 7.1.1 android, anything else is oreo or nougat 7.1.2, so it's ANY type of upgrade to the os I do that affects the speeds drastically. The pic with my laptop you can obviously tell, but those are hotspot results from the laptop. The other pics are from the speedtest app installed on the phone, and a screenshot of the results, which is normal lte cell sevice, and not hotspot. The one laptop shot with high speeds you will notice I get the same results as on the phone, that is the nougat oxygen os beta 24 and custom roms based on android 7.1.1 android like the beta 24 oxygen os is.

    If this were a hardware issue, then the speeds would still not be good or as high even on beta 24 nougat or 7.1.1 based custom roms, so this is indeed a software issue of some sort.
    I hope oneplus can dig deep into this and find a fix.

    I can and have replicated this each and every time without fail. It's the exact same result each and every time.
     
    Last edited: Jan 20, 2018

    #14
    beedaa and rgupta.er like this.
  15. beedaa
    Eclair Jan 22, 2018

    beedaa , Jan 22, 2018 :
    You're a lucky guy because you get 500kbps. Mine ranges from 16 - 24 kbps :(:(. Anyhow yes I found rather a temporary fix, because it goes back to that crappy slow speed. I have 2 fixes:

    1. What I do is that I just restart my phone until my laptop is able to have internet. (This resets the mobile connection of your phone to the cell tower)

    2. I go to the phone information (type *#*#4636#*#* into your dialer) and proceed in changing your default connection. Mine by default is TD-SCDMA/CDMA/UMTS and I'll change it to LTE ONLY. If it still doesn't work, I will just return it back to default and repeat the process until I get internet on my laptop.

    My carrier is Vodafone Australia and this is the first time that this happened to me. To be honest, I don't know what could be the cause of the issue, but I have a big feeling that it might be the OS.
     

    #15
  16. beedaa
    Eclair Jan 22, 2018

    beedaa , Jan 22, 2018 :
    Thank you Easyrider for going way and beyond to somehow locate the issue. Please look at my reply to "G_Travis_Terrell_KRDg". So far those are my experiences and have not really gone as far as you, so I cannot really have a decisive conclusion of the problem but I hope these can help:

    1. This issue really happens randomly.
    2. Restarting your phone sometimes fixes the problem.
    3. Changing your mobile connection type also sometimes fixes the problem.
    4. "Wi-fi tethering and hotspot" feature of our phones (I think) doesn't have a problem. Because I have changed the mobile connection while hotspot was "on" and my laptops connected. Got internet on my laptops after that.

    My main question now is that why does it happen randomly? If there was really a problem in OS or perhaps hardware, then we shouldn't be receiving any connection to the laptops in the first place. I am now leaning to the fact that it might be a fault in the way the carrier connects to our phones. Maybe there is something wrong in the VPN settings or whatnot.
     

    #16
  17. Easyrider77
    Eclair Jan 22, 2018

    Easyrider77 , Jan 22, 2018 :
    As you see I've done extensive research and testing.
    -No this is not random, it happens the same way all the time not wavering, as I can replicate this exact thing reach and every time.
    -It's not hardware. If it were I would not be able to have fast connection no matter what is I used.
    -this isn't a "no internet" issue, it's a drastic slow issue, both on the laptop and the phone. There is no issue with 7.1.1 Android. The fact I have used stock oxygen as well as a custom rom and have the same results in both says it cannot be hardware but software somewhere.
    -I have adjusted numerous settings such as multiple different apn settings, adjusting the connection via *#*#4636#*#* and set lte only which results in no service at all, and multiple others of that list and still does not fix the issue.
    - I have reset my phone numerous times flashing ROMs and I always do a fresh new install, so a reboot is not the issue either.

    The short of it all is it's one common denominator and only one the os, that's the only thing that changes in each and every scenario.

    I suspect like a build.prop line changed, maybe a modem.bin file got changed, I'm not sure, all I know is I've spent at least one day maybe a day and a half doing multiple flashes testing, adjusting many many settings, and I the same results every time, without fail.....I'd bet my life on it, 100% of the time I can get the exact same results.......anything above 7.1.1 android, gives slow speeds. Pick a version be it 7
    1.2 android on "any" rom or, any Oreo 8.0 or 8.1 rom, no matter if it's stock oxygen or one of the numerous custom ROMs, I get the same results of slow speeds. Internet does not quit, it is just slow.
    If you wish to take out the hotspot and use cell/4g/lte only that will warrent slow speeds as well, the pics you see with the dial looking speed thing is cell only, not hotspot, so it's a global issues in all feilds with internet speeds with anything past 7.1.1. As I said the one and only common denominator is a newer os, so that rules out hardware and carrier, given everything is just fine on 7.1.1.
     

    #17
    beedaa likes this.
  18. beedaa
    Eclair Jan 22, 2018

    beedaa , Jan 22, 2018 :
    This is a great find that you have done and I have absolutely no qualms with the research that you have made and I believe it (the research is actually beneficial for Oneplus team to see). But I think the issue that you are having is different from the one I have. Please correct me if I'm wrong, but the slow speeds that you are having are actually way better than the one that I am experiencing. I am getting 16 - 24 kbps, while you still get 1 mbps which is still tolerable in terms of simple internet usage. Please see the following if it also applies to you:

    1. Is the internet speed of your phone the same with your laptop? Wanted to ask this because my phone can reach up to 20mbps, but when my laptop connects to the hotspot, it only gets 16-24 kbps and my phone remains that same with 20mbps. The laptop DOES have internet, but as you said, it looks like it doesn't because of the super slow speed. Please confirm.

    2. You said that it happens all the time even if you restart, re-install system, re-install using another rom etc. I am curious because I'm on stock OREO, and if I do what I did from my last post, like restarting my phone and changing the connection, it will definitely work.

    I'm thinking that maybe your issue is different and you might want to create a new thread.
     

    #18
  19. Easyrider77
    Eclair Jan 22, 2018

    Easyrider77 , Jan 22, 2018 :

    1: Well when on anything above 7.1.1 I reach approximately 7Mbps - 15Mbps maybe even hit occasionally 20-24Mbps, but avg is about 5Mbps - 8Mbps. This is the exact same on every OS above 7.1.1. On the laptop side, which is of coarse hotspot I range anywhere from 1-3Mbps sometimes occasionally reaching upwards of 8-10Mbps, but that's rare, the avg is still between 1-3Mbps. So it's always slower on the laptop side, always has been even on a good signal. My guess is because of the throughput it has to go thru, cell is more direct, where as using hotspot it has to hop and filter more which can and normally does result in slower speeds. I can deal with 7-15Mbps, that's acceptable, and may vary per location of coarse, but 1-3Mbps? that's not EVEN worth using, that is less that 1Mbps download, because the download will never be equal 1 to 1 ratio with the speed test results, so you'll always tend to get slower downloads than your actual speed test results. Speed tests are more a gauge to go off of in terms of speed. You are correct in a way about the 1Mbps being tolerable for simple internet usage, but considering this is my "only" internet I have, so I use it for games, videos, downloads etc......I don't consider that acceptable, especially since I am paying for a service that has not limited me or throttled me in any way in over a year, not even using upwards of 60GB of data in a month did they throttle me. Can they?, yes they can, have they? no, not even once.
    This combined with the fact my carrier does not slow me down or throttle me, yet the os does is not acceptible either, because this is the ONLY phone I've had this particular issue with, and given that it works fine using one OS version, and not fine on another OS version, is a phone issue. I've had a nexus 5, nexus 5x, and this Oneplus 3 in the last 2 and a half years now, and on tmobile I have never had one single issue with hotspot or cell service except on this oneplus phone. In fact I broke out my 5x last night which has Oreo on it, and did not suffer from slow speeds, I got the normal 7-15Mbps avg, and sometimes hitting 20-24Mbps also, yet when I switch back to the oneplus 3, it suffers with the slow speeds still....(yes I flashed oreo again, and 7.1.2 nougat as well :) )

    With that 7.1.1 speeds of 7-15Mbps I download at approximatetly around 1-2Kbps (not lower case k) that results in about maybe if I recall right like 15 mins, maybe 30 mins download of a 1-2GB rom file.
    Now take that same connections with a new OS 7.1.2 or Oreo, and getting a speed test of 1-3Mbps, that results in a download now of that same file, as around 3-4hrs and like 415kbps or something like that, it's really slow....drastic time and speed difference.....at least half speeds I get on 7.1.1 and sometimes even worse. It's not an exact science, but I do know I rounded the results to about 1/2 speeds slow downs if not worse.

    2: Yes I can confirm this always happens no matter what. Some I guess do not suffer from this, but some do, it's a real hit and miss with the 1+ phones I guess. I have read and sifted thru many threads and forums, and this doesn't affct only the 3, but the 3t, 5, and 5t as well. While not all have it, it seems that there is a general same issue for those that do have this issue, and some have done more research, albeit probably not as in depth as I've done, but some have said that they switch back to nougat from oreo, and they are fine with the speeds again. I definitely see a trend and a lot of oreo problems with this, but for some (not all) they have it in nougat too.
    Rebooting or stopping mobile data and restarting, or antyhing similar, such as rebooting the phone to connect to a closer tower etc......for me this does not fix anything. I've even spent time on the phone with T-mobile 2-3 times, talking with a tier 2 tech, and they cleared my data and refreshed the ip on thier side and told me to reboot and see if it fixed anything, and there was not a single difference in speed.

    On my last edit I had done more extensive testing to rule out anything at all possible with carrier and or hardware, buy going to a known location that has strong signal and good cell service. In fact I hit a 95Mbps speed the other day in that same spot (I about fainted when I saw it, didn't think it was real) but this was on 7.1.1.

    A rep from oneplus emailed me and we discussed what steps I took, and also gave him all the info and tests results I got as well as pictures showing the difference, etc...etc....., we talked across 3 different email, so they indeed know the issue. Haven't come to a resolve yet, and I offered them my phone and to test any modem.bin, rom etc...that I could possibly test for them, or maybe a setting change they might know of that i could try.
    After the 3rd email, they thanked me for the info and the very in depth testing I did, and I've never heard back from them at all.
    Basically I did the leg work, all they now need to do is get devs or tech team on the issue and get a fix out, especially since this same issue has hit 1+5 phones as well (not all, but it's still there for some). The fact I am offering my services and have done the testing and leg work, and that this has plagued the 1+3 since 2016, is a bit frustrating that all I got was a thank you for your time and efforts, and that's it. What did I expect? I dunno, I guess I thought maybe since this was an issue in 2016 and we're in 2018 (2 yrs later) and all I got was thanks, it just seems like they are going around the subject and/or problem at hand instead of going at it head first, or at least if it's something they can't find or fix, at least be honest and up front and admit it.
    This is not some bash on 1+ but it is a honest respectful request on my part as a consumer who paid money for said product. I guess I have old fashioned values.

    Just out of curiosity I did some quick testing to see if anything had changed, and nope it's all still the same. Here are the pics of the results, laptop, and screenshot on the phone. Notice no hotspot on the phone side in the testing. This is normal and acceptable to me at these speeds. As you see I get 14Mbps on this laptop test, but the above shots where you see 1-3Mbps is the same hotspot result on oreo. Also notice my download time on the oxygen OS download, this I can accept too and am fine with, but 4 hrs for this same file at 1-3Mbps? that's a deal breaker for sure, I might as well cancel my hotspot service if I got those sort of speeds.
    I pay $75 a mo for unlimited talk+text+data and another $25 for unlimited hotspot (no throttle either) but at the 1-3Mbps speeds, it's not worth the $25 extra a month.

    [​IMG] [​IMG] [​IMG]
     
    Last edited: Jan 22, 2018

    #19
  20. Easyrider77
    Eclair Jan 26, 2018

    Easyrider77 , Jan 26, 2018 :
    Ok update on my slow hotspot issue.

    It seems it is only hotspot now. I can't tell you what changed but I am now getting normal good speeds, 20-50Mbps, but here is the kicker of ALL this that I had researched.

    Today I decided since my data speeds on my cell side are back and good again, (unknown to me as to why) but they are back to normal and have been for a day or so.
    So I decided to test hotspot again and see if it was back to normal, and to my disappointed surprise, they were not, still 1-3Mbps.

    So, I decided to call T-mobile and see again if they maybe had some kind of restriction on my account, and they of coarse said no, and it was all good, so I reported that I was getting slow hotspot. I told the tier 2 tech about my findings and wasn't 100% sure it was carrier or hardware.

    After I hung up the phone with the tech, I decided to test a few things so I went to a tmobile store and tested the hotspot, and had tech 1 do a speed test while hooked to my hotspot via his phone, so tech 1 on his samsung s8 did a speed test and he to got slow speeds like I was getting. I also had them swap out the sim card even though I didn't think it was that, I just wanted to eliminate all possible things that it "could" be. Once tech 2 swapped out the sim he tested it on his Iphone 8, and had the same slow issues.

    I then proceeded to call tmobile tech support again and got a teir 2 tech again, and told him everything that I had done, he agreed I had done everything but right at the last he mentioned that he had seen some cases were if it were not a "branded" t-mobile phone IE: a phone bought from a t-mobile store, that people had issues with the speeds, namely hotspot.

    So I headed to another tmobile store on my way home and had the tech in that store try a tmobile branded phone, which was his, since the dummy phones didn't have or use sim cards in them they are just for sample purposes. Once he inserted "my" sim into his tmbile branded phone, I connected to his phones hotspot, and bingo! it worked like a charm, on both my nexus 5x and my oneplus 3. This was my sim so it waas my account and service in phone. I got good speeds. So I put the sim card back in my phone oneplus 3, and tested hotspot again with my nexus 5, and speeds dropped again to crappy speeds.

    Update and finally found the issue:
    I modified this post to reflect my findings.

    So today I decided to go to a tmobile store again and test things, only this time I used my sim as well as one of the demo phone sims. For this test I used my 1+3 and my Nexus 5x.

    I placed my sim in the 1+3, turned on hotspot, and connected wifi via the 5x phone and got bad slow speeds. I then placed the demo phone sim in the 1+3 and connected wifi via the 5x, and again I got slow speed.

    Now I reversed this and used the 5x this time as a hotspot.

    I placed the demo sim into the 5x, connected wifi via the 1+3, and bingo, great speeds.
    I placed my sim into the 5x, connected wifi via the 1+3, and bingo again, I got good speeds.

    So what does this test tell me/us? It tells me that everything on the 1+3 works flawlessly, except for hotspot, which is utter crap. For whatever reason, that I cannot comprehend at all, the 1+3 just is not getting good hotspot, and even as a techy and power user I still have no clue why or what would cause the 1+3 to have "JUST" bad hotspot. I don't know if it's a band issue, a hardware issue, maybe both or what, perhaps someone else could shed some light on thing. My tech experience tells me it's something hardware in the phone itself, and just has issues, and this is also what plagues the 1+3t as well.

    Being as everything works just fine on my 5x, I am gonna chalk it up as bad hardware, but I certainly can say I won't be as eager to jump on a 1+ device again, because seeing that the 3t on the forums has had this issue since 2016, and now my 3 has hotspot issues, tells me that there is some sort of issue that needs to be addressed and fixed.

    This isn't a rom issue, as I've tried multiple roms and still have the issue, in fact I went back to 7.1.1 android that I had first thought was fine and worked, I found out it does not, because last night I flashed it and still had issues.

    I have also tested the 5x to others phones at the tmobile store and they all got good hotspot speeds, and when I tested the 1+3 those same phones got bad speeds.

    I hope this finding helps someone else out.
     
    Last edited: Jan 27, 2018

    #20