0
[Submitted] Wifi is turned ON automatically, connects (when in range) for few seconds and turns OFF on its own.

Thread Status:
Not open for further replies.
  1. Nimish Naik
    Gingerbread Mar 2, 2017

    Nimish Naik , Mar 2, 2017 :
    Hi Team,
    I am encountering a very unusual issue where the phone's wifi switches on automatically and connects (when in wifi range) for few seconds and switches off on its own when using few applications. I have also noticed this strange behavior when not using any application. This in-turn disrupts my sim's 4G data connection for few seconds as my phone ends up connecting to my home wifi for few seconds and then disconnects. I have noticed this only on 4.0.3 OOS.
     

    #1
  2. Nimish Naik
    Gingerbread Mar 3, 2017

    Nimish Naik , Mar 3, 2017 :
    More to this post:-

    The DEV team or the BUG HUNTERS can try to reproduce this issue/bug by downloading two of the applications which I feel has triggered this weird issue ( just my guess, not sure if they are the culprits ).

    Two major things needed in order to reproduce the bug:-

    1) Should be present in an area with good wifi range.
    2) Should not be connected to WIFI ( Assuming you have previously connected to the same wifi and are now currently on sim data ).

    The apps are "BookMyShow" and "Crownit" available on Google Play Store. Once launched, it will tell you to give the required permissions such as allow contacts, messaging, location, camera, etc. Once the app is configured, it will ask you to enable google's location services, go ahead by selecting "ok" and then just exit the app or kill the app from the "recents" button ). You will find "Scanning always available" enabled under WIFI settings and "WIFI scanning" enabled under location settings.Just go to WIFI settings and disable "Scanning always available".

    Now launch the same application (try not doing anything in the app) and quickly slide down the notification once so that you can see only quick notifications panel where you will be able to see the wifi switching on, connecting to your wifi, establishing a connection for few seconds and then turning off the wifi.

    You can quickly go to the WIFI settings and will be able to see that "Scanning always available" and "WIFI scanning" under location settings is disabled.

    After I have noticed this, It tries to switch on the wifi for most of the app which I launch and then turns off which causes a disruption in terms of internet data which creates app loading issues. It is quite annoying, to say the least.

    I initially searched the forums to see if this bug has been reported and I found 3 threads which support my claim. The links are mentioned below:-

    https://forums.oneplus.net/threads/wifi-really-annoying-in-op3.497930/
    https://forums.oneplus.net/threads/wifi-fluctuation-after-it-has-been-turned-off.499421/
    https://forums.oneplus.net/threads/wifi-enables-disables-automatically.496981/

    Here's what I have tried so far:-

    1)Clear cache of all apps followed by clearing system cache from recovery - No Luck.
    2)Reset system settings from recovery followed by clearing system cache followed by Hard Reset from recovery - No Luck.
    3)Disable IPv6 Support - No Luck.

    I understand you guys get a lot of threads in the form of bug reports which wouldn't be a bug in the first place but trust me on this as I have tried everything which an end user can try. I hope you guys look into this at the earliest and drive this towards a resolution.

    Never Settle !
     

    #2
    (_Dragonor_92) likes this.
  3. (_Dragonor_92)
    Gingerbread Dec 8, 2017

    (_Dragonor_92) , Dec 8, 2017 :
    E
    Even after 6 months post the bug reported they haven't fixed it. Tried all possible solutions posted globally on al forums. I still face the issue and waiting for an update.
     

    #3
    Nimish Naik likes this.
  4. Mich O.
    Ice Cream Sandwich Jul 3, 2018

    Mich O. , Jul 3, 2018 :
    Hello @Nimish Naik,

    This is from the OnePlus Bug Hunters.

    If this issue persists on the latest build, please raise a new bug report so that we will look into it again. This thread will now be closed.

    Thank you and have a great one.
     

    #4