10
Network/Connectivity WIFI Issues

  1. iajay
    Eclair Dec 23, 2016

    iajay , Dec 23, 2016 :
    Hi
    I received my 3T yesterday. I am having issues with WIFI
    WiFi network drops frequently. Even when moving between rooms of my house
    I have updated to OxygenOS 3.5.4 as soon as I received the mobile
    The signal strength of the 3T is also very low
    I have a 2 year old moto X 2014 and the moto beats the 3T at every place in my house
    The signal strength and the wifi speed both are better in moto X
    I have checked at various places
    I have wiped the cache. Tried changing 2.5GHz to 5GHz
    Changed Channels.. Tried all the things that I could find on the internet
    But still problems
    So is this a hardware problem and should I ask for a replacement? Or is this some Software bug which can be resolved
    My router is ASUS RTN66U and a lot of other devices work seamlessly on that router and hence pls dont suggest to change the router :)
    Awaiting replies
    Regards
    Ajjaykummar
     

    #1
  2. iajay
    Eclair Dec 23, 2016

    iajay , Dec 23, 2016 :
    see the screenshots with WiFi with exclamation mark.. the WiFi internet connection is lost and my mobile data is used.. this is at a place where I have good WiFi signal
    1482490606671.jpg

    1482490606802.jpg
     

    #2
    fairy_blue and G_Edwin_L._UZTf like this.
  3. iajay
    Eclair Dec 23, 2016

    iajay , Dec 23, 2016 :
    Anyone ? Any replies?
    Atleast I need to know if this is hardware issue or software issue.. If this is a faulty mobile I can ask for replacement
     

    #3
  4. Sitharthan
    Eclair Dec 23, 2016


    #4
  5. iajay
    Eclair Dec 23, 2016

    iajay , Dec 23, 2016 :
    thanks for the reply.. do you have the mobile without the wifi issues?
     

    #5
  6. iajay
    Eclair Dec 23, 2016

    iajay , Dec 23, 2016 :
    here is a screencap of the issue


    You can see in the screen cap that the mobile is connected to ASUS5 (5GHZ)
    Then as I move away from the router the signal weakens and then the wifi disconnects .. and then it connects to ASUS (2.4GHZ)
    Earlier it was connecting to ASUS but with a exclamation mark (without internet).. I waited for 15 minutes but it did not connect
    Then I would connect if I switch off and on the wifi toggle

    After that I did a factory reset and now you can see the screencap
    It connects after a minor delay.. So is this alright
    My other mobile - Moto X 2014 simply switches instantly from 5GHz to 2.4GHz and vice versa.. not even half of second is taken on moto x
     

    #6
    G_Edwin_L._UZTf likes this.
  7. G_Edwin_L._UZTf
    Cupcake Dec 31, 2016

    G_Edwin_L._UZTf , Dec 31, 2016 :
    hey friend, is your phone good now after a factory reset? I believe that I'm experiencing the exact same thing as you. Thanks in advance.
     

    #7
  8. iajay
    Eclair Dec 31, 2016

    iajay , Dec 31, 2016 :
    I thought it was resolved.. but now again I am facing the problems of continous disconnection and extremely slow speeds sometimes...
     

    #8
  9. joelmine
    Donut Jan 1, 2017

    joelmine , Jan 1, 2017 :
    i am having the same issue ever since the last update. i was waiting for the nougat update which i thought would fix the issue. last night when the update rolled out i updated it to nougat but the same issue.. my wifi signal strength is maximum but it keeps disconnecting every few seconds and then it connects back after a few seconds. i have other devices and laptops running on the same router and none of them havr this issue. i have raised complains with oneplus but they have done nothing so far. This is frustrating.
     

    #9
  10. joelmine
    Donut Jan 1, 2017


    #10
  11. iajay
    Eclair Jan 2, 2017

    iajay , Jan 2, 2017 :
    Ya same here... very frustrating.. I have asked for a replacement.. hope that the replacement device does not have this or any other problems...
     

    #11
  12. iajay
    Eclair Jan 2, 2017


    #12
  13. captalex002a
    Eclair Jan 2, 2017

    captalex002a , Jan 2, 2017 :
    hey guys I am also facing the same issue ... all my other phones are getting wifi signal and on OP3T even when standing next to the router cannot see the signal... very frustrating ... any one has any fix or need to replace this ?
     

    #13
  14. captalex002a
    Eclair Jan 2, 2017

    captalex002a , Jan 2, 2017 :
    hey I got the solution ...
    don't connect ur phone to any network and open Google dashboard on ur desktop
    select Android tablet and delete backup data
    log out of Google dashboard.
    restart ur phone and try again
     

    #14
  15. massel14
    Cupcake Jan 2, 2017

    massel14 , Jan 2, 2017 :

    Where did you get this solution? How should the error be fixed? I try it out. Thank you

    Same Problem with OOS 4.0.
    With the old Version (OOS 3.5.4) I had no Problems
    OnePlus 3T
     

    #15
  16. johnhauhnar
    Eclair Jan 2, 2017

    johnhauhnar , Jan 2, 2017 :
    i have slightly different wifi problem..
    office wifi doesn't work with CA Certificate installed..(it worked on oos354)..
    However, there is no problem with my home wifi which does not need CA Certificate installed.. i might consider downgrading..
     

    #16
  17. dexterouz
    Froyo Jan 2, 2017

    dexterouz , Jan 2, 2017 :
    I had Wifi issue out of the box. It was scanning the available networks slowly or was not able to find at all.
    It was not able to connect to my saved home wifi. This was happening every day since 4 days. Every day I was adding my wifi and the next day after powering on the phone, the same issues occurred.
    Not sudden;y on the 5th day, all the issues got solved. Still, don't know how?? But thankfully it got solved. Amazon and Oneplus doesn't have proper communication and you will have very hard time returning the product (If you are from India).
     

    #17
  18. captalex002a
    Eclair Jan 2, 2017

    captalex002a , Jan 2, 2017 :
    hi try changing it WiFi channel no see ..
     

    #18
  19. captalex002a
    Eclair Jan 2, 2017

    captalex002a , Jan 2, 2017 :
    hi try to change it WiFi channel from Ur router setting.. I found that some channels it's not able to detect ...
     

    #19
  20. captalex002a
    Eclair Jan 2, 2017

    captalex002a , Jan 2, 2017 :
    the solution was given by OnePlus support.
     

    #20