0
Wifi not connecting on 5G band [3.2.1 ]

  1. m_usmanayub
    Froyo Jul 12, 2016

    m_usmanayub , Jul 12, 2016 :
    To add to the misery I was using my wifi on 2.4 GHz band but when I tried to connect to 5GHz band it does not connect and the error shows wifi connection failure. All my other devices are connected successfully to this band even my 4 year old Nexus 4 but Oneplus 3 does not seem to connect for a single time

    This is really becoming disappointed for me bow after push notification and alert slider issues.

    The range of 2.4 GHz wifi is not even half of what my Nexus 4 used give me.

    I am using ASUR WRT 68u router.

    @Carl I wish I get my money back I spent on this device.

    Totally frustrated!!!
     

    #1
  2. MarkusRanz
    Ice Cream Sandwich Jul 12, 2016

    MarkusRanz , Jul 12, 2016 :
    5ghz works for me but range is weak.
    Range on 2.4g is sometimes also a bit low but due to a really powerful router I have no real props.

    Have you tried on another WiFi maybe it's only incompatible with your router?
     

    #2
  3. Bubba10
    Gingerbread Jul 12, 2016

    Bubba10 , Jul 12, 2016 :
    WiFi is working perfect here both 2.4 GHz and 5 GHz. Have you updated to 3.2.1 yet? WiFi issues usually tend to be software, so I'd check with another 5ghz router first. Also if you are not on 3.2.1 wait for the update as many there are a few bug fixes in that update.
     

    #3
  4. Karthik Raghavan
    Honeycomb Jul 12, 2016

    Karthik Raghavan , Jul 12, 2016 :
    Have you tried to reboot your router? In my experience, 99% of all wi-fi connectivity problems, where some devices connect and others do not, contrary to common sense, are solved by rebooting your router! There are many explanations for this, but they are all redundant if this doesn't solve your problem. So, first try this: turn off router, count to 10, turn router back on, wait at least 3 minutes for the router to do all the stuff it wants to do, then try connecting your phone again.
     

    #4
  5. lipe123
    Froyo Jul 12, 2016

    lipe123 , Jul 12, 2016 :
    Also make sure you have latest firmware on your router, I've seen some issues with asus devices recently because of FW or just because they were bad.

    Also make sure your authentication/encryption stuff is set standard wpa2-psk AES (not tkip)
     

    #5
  6. ian.philip
    Honeycomb Jul 12, 2016

    ian.philip , Jul 12, 2016 :
    5G should have smaller range then 2.4G on the same device. Also, you can't expect it to perform as good as iphone, which is $600+
     

    #6
  7. m_usmanayub
    Froyo Jul 12, 2016

    m_usmanayub , Jul 12, 2016 :
    My nexus 4 device was less than 400$ and it provides seamless connectvitiy so stop bluffing about the price difference!
     

    #7
  8. m_usmanayub
    Froyo Jul 12, 2016

    m_usmanayub , Jul 12, 2016 :
    The subject says that I am on 3.2.1!
     

    #8
  9. rswinney99
    Gingerbread Jul 12, 2016

    rswinney99 , Jul 12, 2016 :
    Check your encryption method as mentioned above. Many new devices and dropping support for tkip so make sure it's set to AES and the security protocol should be WPA2. Avoid using combination settings such as WPA + WPA2 as well. You should only be using WPA2 and AES.

    My OP3 connects to a Cisco enterprise ac wireless network no problem at all so I doubt your problem lies with the phone. Keep in mind that the 5ghz band is faster but is not a strong as 2.4ghz so your range will always be shorter on that band.
     

    #9
  10. m_usmanayub
    Froyo Jul 12, 2016

    m_usmanayub , Jul 12, 2016 :
    I
    Got latest firmware on router... the only option is WPA2-PSK AES.... I even tried without key as well no use..
     

    #10
  11. m_usmanayub
    Froyo Jul 12, 2016

    m_usmanayub , Jul 12, 2016 :
    Tried the method you mentioned didn't work
     

    #11
  12. m_usmanayub
    Froyo Jul 12, 2016

    m_usmanayub , Jul 12, 2016 :
    My router is configured for WPA2 AES and I even tried without key but it just refuses to connect
     

    #12
  13. m_usmanayub
    Froyo Jul 12, 2016

  14. Karthik Raghavan
    Honeycomb Jul 12, 2016

    Karthik Raghavan , Jul 12, 2016 :
    Hmm, too bad. If you want to confirm that its definitely your phone that is the problem, you may want to try connecting on 5Ghz on at least 2 or 3 other routers (other brands) in other buildings. If the phone fails everywhere, then its the phone. If it connects on some routers but not on others, there is scope for more investigation. I don't use 5GHz in my house because the signal degradation is too much (brick masonry is NOT wi-fi friendly). But, even on 2.4GHz, I have discovered that some phones are even fussy about the orientation of the antenna! This is ... Honestly, I wouldn't call this a serious idea, but hey, you never know, maybe try different orientations of the antennas? Also, at what height is your router placed? Is it near any other electronic equipment?
     

    #14
  15. Karthik Raghavan
    Honeycomb Jul 12, 2016

    Karthik Raghavan , Jul 12, 2016 :
    Oh wait, I faintly recall somebody commenting about changing the channel to make wifi work properly!!! Since I had no issues, I did not register that message fully, but I am sure they said the phone works better on some channel while not so well on others. You may want to try a bunch of different channels on your router before you do anything else.
     

    #15
  16. m_usmanayub
    Froyo Jul 12, 2016

    m_usmanayub , Jul 12, 2016 :
    I will try to connect it to other 5GHz routers once I find one!
    The router is placed at my work desk so it is 30 inches above floor and the only nearby device is the DSL modem. Tried disturbing antenna and lots of other stuff including changing SSIDs, passwords bands etc.
     

    #16
  17. Superbrowndude
    Ice Cream Sandwich Jul 12, 2016

    Attached Files:


    #17
  18. m_usmanayub
    Froyo Jul 12, 2016

    m_usmanayub , Jul 12, 2016 :
    Already tried that on different values of channel, mode and what not
     

    #18
  19. Karthik Raghavan
    Honeycomb Jul 12, 2016

    Karthik Raghavan , Jul 12, 2016 :
    I got nothing more! Id still investigage with at least 2 or 3 other routers elsewhere before I condemn the phone, since this seems to be a pretty rare problem.
     

    #19
  20. ian.philip
    Honeycomb Jul 12, 2016

    ian.philip , Jul 12, 2016 :
    This is how I understand this problem. I think the price difference is not reflected on individual devices. That is right. You single Nexus 4 could have a very good performance like my Oneplus 3. But overall, there could 10 devices of 100 have problems for cheaper phone while expensive phones would only have 4 out of 100. I am not going to argue it is not Oneplus problem and they need to fix it. I was saying that it is more likely to get a device with bugs. That is where the risk is.
     

    #20