1
Wifi not really working, apps keep losing connection

  1. M0riTzx33
    Donut Sep 27, 2021

    M0riTzx33 , Sep 27, 2021 :
    Hey,
    i got my OnePlus 9 Pro a few weeks ago and I dont really get fit with it. Battery was Shit the first 2 weeks, its now way better and acceptable.
    I still have problems with apps loosing connection. When im connected to Wifi and scrolling through Instagram for example, I have to close and open the app every 2 minutes because nothing is loading anymore. My Wifi is good, speed and connection is excellent. Happens with other Wifi sources too. It drives me crazy. I cant use any app correctly as it happens with every app.
    Imagine owning a nearly 1k€ phone and have to deal with stuff like this. For that price I expected something else. Something more worked on, without stupid Bugs like this. This comes from a former OP1 owner, so I know you were able to build and maintain excellent phones.
     

    #1
    BERSEY DINO CIBIN X M likes this.
  2. Tokolozi
    Most Original Avatar Sep 27, 2021

    Tokolozi , Sep 27, 2021 :
    can you disable the "intelligent wifi..." in the wifi settings. This feature is quite buggy depending on your wifi setup.
     

    #2
    Caomhin likes this.
  3. M0riTzx33
    Donut Sep 27, 2021

    M0riTzx33 , Sep 27, 2021 :
    Thanks for your answer. It was turned on, but I dont think it will change anything. I dont have any access to other WIFIs here, so it cant connect to others. But I try it.
     

    #3
    Tokolozi likes this.
  4. Tokolozi
    Most Original Avatar Sep 27, 2021

    Tokolozi , Sep 27, 2021 :
    Even if you have a router with both 2.4 and 5.0Ghz bands it likes to hop between the two.

    You could also try resetting your wifi adapter settings. That often helps too.

    Once I changed those on a device here it seemed to make everything better. And I have quite the complicated WiFi setup at home with mixed mesh and normal access points with a guest network.
     

    #4
    Caomhin likes this.
  5. M0riTzx33
    Donut Sep 27, 2021

    M0riTzx33 , Sep 27, 2021 :
    I tried it now for the last 2 hours. At first I thought that its better but its back to the old behaviour. I also disabled battery optimization for instagram, no change.
     

    #5
    Tokolozi likes this.
  6. Tokolozi
    Most Original Avatar Sep 27, 2021

    Tokolozi , Sep 27, 2021 :
    Can you try this as well then:
    Screenshot_20210927-111228.jpg
     

    #6
    Caomhin likes this.
  7. M0riTzx33
    Donut Sep 27, 2021

    M0riTzx33 , Sep 27, 2021 :
    Again was working fine for half an hour and went back to buffering after 1 or 2 mins
     

    #7
  8. Tokolozi
    Most Original Avatar Sep 27, 2021

    Tokolozi , Sep 27, 2021 :
    That's really strange. I suggest taking wifi logs via the community feedback option in the app and sharing them there.
     

    #8
    Caomhin likes this.
  9. eddyros
    Honeycomb Sep 27, 2021

    eddyros , Sep 27, 2021 :
    Does it happen with OnePlus 9 Pro only?? Have you tried using same Wifi with other device??
     

    #9
  10. M0riTzx33
    Donut Sep 27, 2021

    M0riTzx33 , Sep 27, 2021 :
    Only with my phone... My old P30 Pro works just fine. Its definetly device related
     

    #10
  11. Tokolozi
    Most Original Avatar Sep 27, 2021

    Tokolozi , Sep 27, 2021 :
    Does your router have both 2.4 and 5ghz?
    Do they have different network names too (just to rule out some stuff)

    Can you try for a short period using a guest network on the op9 to see if the issue persists?
     

    #11
    Caomhin and eddyros like this.
  12. eddyros
    Honeycomb Sep 27, 2021

    eddyros , via OnePlus 8T , Sep 27, 2021 :
    That's the point, sometimes the two wifi network have same try to enter into wifi router settings anche change one of them
     

    #12
  13. M0riTzx33
    Donut Sep 28, 2021

    M0riTzx33 , Sep 28, 2021 :
    Yes I have 2.4 and 5ghz and both have the same name. Why should I change the name of one of them? With every other device its working just fine.
     

    #13
  14. Tokolozi
    Most Original Avatar Sep 28, 2021

    Tokolozi , Sep 28, 2021 :
    If it's possible just to rule out that that's the cause.

    My home network has the same setup, but can't replicate the issue here. That's why I suggested it as a troubleshooting step for now
     

    #14
    Caomhin likes this.
  15. M0riTzx33
    Donut Sep 28, 2021

    M0riTzx33 , Sep 28, 2021 :
    Changed the settings in the router so that 2,4 and 5 have different names. Added both to my phone and tried it again with instagram reels. It connected to the 5ghz one, was good at frist but started buffering again.
     

    #15
    Tokolozi likes this.
  16. Tokolozi
    Most Original Avatar Sep 28, 2021

    Tokolozi , Sep 28, 2021 :
    So strange.... Really can't think of anything else from my side then.
     

    #16
  17. M0riTzx33
    Donut Sep 28, 2021

    M0riTzx33 , Sep 28, 2021 :
    I cant think of anything else either. My router is a good one (Fritzbox), other devices work like a charm. Software is up to date, connection is perfect. It happens with other WIFIs too, so my guess is that its either software or hardware related...
     

    #17
  18. Tokolozi
    Most Original Avatar Sep 28, 2021

    Tokolozi , Sep 28, 2021 :
    Must be. There the feedback option is our only way to reach the devs that can look into it.
     

    #18
  19. M0riTzx33
    Donut Sep 28, 2021

    M0riTzx33 , Sep 28, 2021 :
    Where can I find the Feedback option? Was already looking for it, but couldnt find it. Is it in the settings?
     

    #19
  20. Caomhin
    OnePlus 9 Series Expert Community Expert Sep 28, 2021

    Caomhin , Sep 28, 2021 :
    Yes Fritzbox is one of the better if not best you can get.

    I had an issue onetime on my old 6T where I had to move the channels on 2.4Ghz to below 11 and 5 Ghz to between channels 40 and 100, not sure what caused the issue, but the 6T seemed to work after that, routers been on that ever since so my 9 Pro just works, haven't tried it on higher channels.

    Check if this might help.
     

    #20