2
WiFi problems Android 9.0

  1. MikaSlot
    Cupcake Sep 27, 2018

    MikaSlot , Sep 27, 2018 :
    I have a lot of wifi problems since the 9.0 update on the 5 ghz hopefully there is something because he connects and disconnects ....
     

    #1
    yanncombes and rglanzer like this.
  2. the_o2
    User of the Year 2018 Sep 27, 2018

    the_o2 , Sep 27, 2018 :
    Settings > Backup & reset > Reset the Network settings (it will delete your saved Wi-Fi passwords and Bluetooth settings also so keep that in mind)

    And restart your phone.
    If still having problem report it here
    https://forums.oneplus.com/feedback
     

    #2
    DrJMun and shrutibhutda like this.
  3. _Loucif_Redjai_
    Gingerbread Sep 27, 2018

    _Loucif_Redjai_ , Sep 27, 2018 :
    hi, I think it's not a problem of WiFi, it's because the optimization of the battery and the battery adaptive problem,
    sometimes when I'm downloading something I should let the display lit otherwise if it sleeps the battery adaptive mode will interrupt the WiFi in the background,or in the sleeping mode , so I should deactivate and reactivate the WiFi to download ,
     

    #3
  4. SirLord96
    Cupcake Sep 27, 2018


    #4
  5. _Loucif_Redjai_
    Gingerbread Sep 27, 2018

    _Loucif_Redjai_ , Sep 27, 2018 :
    it's not the WiFi problem
    the problem is here
    1538080795358.jpg
    you should deactivate this
     

    #5
    DrJMun likes this.
  6. rglanzer
    Froyo Sep 28, 2018

    rglanzer , Sep 28, 2018 :
    I've the very same problem. Yesterday I got the OTA Pie Update. I didn't change anything to the ROM. So no root still on the OnePlus Stock ROM.
    But at home my WiFi connection is trying to connect -> connected (no internet) -> and then disconnected.
    BUT at the very same time my Sony TabletZ4 is connected to the very same WiFi and I verified that internet connection is established.
    It seems, that the OP6 with Pie is not recognizing that this WiFi has internet connection and is diconnecting.
    And then the procedure starts over and over again connecting->receiving ip address->connected (no internet)->disconnecting.
    I also deleted the stored WiFi settings and reentered the password again on the next loop but no success.
    Then I restarted the phone and the connection was established. But then I put away the phone and after a couple of hours I took it back on, and the very same problem appeared. The connection loop started again.

    I'll try to swith you mentioned setting off today when I'm back home. Hope it solves the problem.
    But OnePlus should address this issue, because also with this option "ON" the WiFi should work with an active used phone and WiFi enabled.
     

    #6
  7. rglanzer
    Froyo Sep 28, 2018

    rglanzer , Sep 28, 2018 :
    I think I'm stupid. I can't find the options shown above anymore. Can you please tell me the path in the settings to this screen?
     

    #7
  8. rglanzer
    Froyo Sep 28, 2018

    rglanzer , Sep 28, 2018 :
    OK, I'v found the setting.
    Unfortunately it doesn't solve my problem. After disabling the function WiFi connection still is stuck in the connecting disconnecting loop.

    My only workaround is to reboot the phone. After the reboot the first try to establish a connection succeed. But when I then disable WiFi and reenable it I'm back in the loop.
     

    #8
  9. rglanzer
    Froyo Sep 29, 2018

    rglanzer , Sep 29, 2018 :
    I've an update to this issue. The connecting disconnecting loop is no infinity loop. Today I activated WiFi and the loop started again. Then I started reading posts, try to find answers and so on. Then after approximately 10 Minutes the phone was connected to my WiFi
    I really hope, this is not the desired behavior when trying to connect to a WiFi. On Oreo and direct after a phone reboot on Pie it takes only a second till the connection is established.
     

    #9
  10. Kytharsis
    Nougat Sep 29, 2018

    Kytharsis , Sep 29, 2018 :
    Are you connecting to a 5GHz or 2.4GHz access point?
     

    #10
  11. rglanzer
    Froyo Sep 30, 2018

    rglanzer , Sep 30, 2018 :
    My WiFi router broadcasts both frequencies. The post above is regarding the 5Ghz frequency.
    This should not be a problem, or what do you think?
     

    #11
  12. rglanzer
    Froyo Sep 30, 2018

    rglanzer , Sep 30, 2018 :
    Update to this issue. My phone today was connecting for 25 minutes till it gets the connection to the 5 GHz WiFi.
    I hope some OnePlus guys are reading this to address this issue.
     

    #12
  13. Kytharsis
    Nougat Sep 30, 2018

    Kytharsis , Sep 30, 2018 :
    You're barking up the wrong forum, my guy. No one from OP reads these forums. You'll have to use the proper channel known as /feedback.
     

    #13
  14. rglanzer
    Froyo Oct 1, 2018


    #14
  15. rglanzer
    Froyo Oct 2, 2018

    rglanzer , Oct 2, 2018 :
    I only can hope, that enough people facing the same problem, so that OnePlus reacts on it.
     

    #15
    Jatin Madaan and saideepak02 like this.
  16. prasann
    Cupcake Oct 30, 2018

    prasann , Oct 30, 2018 :
    I don't see the thread anymore. I too have the same issues. Any update on this from someone?

    And also I don't see the "Sleep standby optimization" in 9.0. Is it the case for all?
     

    #16
  17. Erlanttz
    Gingerbread Dec 1, 2018

    Erlanttz , Dec 1, 2018 :
    i have also issues when i use wifi in 5ghz
    when the signal pass to excellent at good, i loose a connection. However, my phone is always connected to wifi or randomly disconnect also or no internet connection found by my 6t with my wifi.
    if i stop and restart wifi, the connection working again for few minutes...
    When the signal is excellent, i have no problem and wifi works perfectly.
    if i switch to 2,4 ghz for wifi, i have no problem.

    the issue is the same if i use ipv4 or IPv6

    I have no problem with wifi 5ghz for all my other devices (phone, tablet, ...)
     

    #17
  18. B satwik Rao
    Cupcake Dec 1, 2018

    B satwik Rao , Dec 1, 2018 :
    Screenshot_20181201-121039.jpg I tried to connect a wifi using AKA JIO4G sim card.
    The wifi is not stable at all. It keeps disconnecting for some time of usage. But some other phones are getting it quite smoothly without out disconnecting it. I've tried resetting the network settings , but it still doesn't work.
     
    Last edited: Dec 1, 2018

    #18
    Erlanttz likes this.
  19. Jatin Madaan
    Cupcake Jan 29, 2019

    Jatin Madaan , Jan 29, 2019 :
    Try this.
    Turn off the sleep standby optimization.
     

    #19
  20. pgrey
    Ice Cream Sandwich Jan 30, 2019

    pgrey , Jan 30, 2019 :
    Try disabling "Unscheduled Automatic Power Save Delivery", on your router/AP.
    Some router/AP manufacturers may use a slightly different term for this setting, but it should be relatively easy to find.

    If this is enabled (as is becoming the default on more, nowadays), most mobile devices will respond by going into power-saving mode(s), as is appropriate (the feature is designed so "always-on WiFi" is easier on your power/battery).

    I'm not sure if turning off "Sleep Standby Optimization" is going to do the trick here, part of it depends on your router (I have zero issues with my Unifi APs in this regard).
    Everyone wants
    - instant-WiFi, possibly in the background (of course only when they THINK it shouldn't be using battery)
    - crazy-long battery life
    - all of this on cheap, dime-store WiFi equipment, or WiFi equipment using very-low power when not "in use"​

    You can get by with one of these three, maybe two, depending on the equipment, but not all three, it's just not going to happen...
     

    #20