0
WIFI report no internet even though is connected and internet is working.

  1. cpour
    Eclair Nov 15, 2021

    cpour , Nov 15, 2021 :
    when successfully connected to any WIFI AP, phone is displaying "No internet" and an exclamation mark next to the WIFI icon on the task bar. Internet is working fine but some apps that depend on the report, do not.
    when disabling the WIFI and re-enabling it again it works for a few seconds only to return to "no internet" again.
    changed DNS settings, IP Settings etc. , nothing seems to fix the issue.

    phone : OnePlus 9 (oxygen os 11.2.9.9)
     

    #1
  2. Cervantes
    Moderator Moderator Nov 15, 2021

    Cervantes , Nov 15, 2021 :
    Hello
    Please, Use the search engine before opening a new thread: Search

    - You can reset networks:
    - settings, system, recovery options, recover wifi

    Read the forum rules: Rules
    Best regards, Cervantes, Forum Moderator
     

    #2
    Tokolozi and Caomhin like this.
  3. Swejuggalo
    OnePlus 9 Series Expert Community Expert Nov 15, 2021


    #3
    Tokolozi likes this.
  4. Sishvik , via OnePlus 9 Winter Mist , Nov 16, 2021 :
    The reasons could be:
    1. Either your data saver is on
    2. The internet provider has blocked you to view some sites.
    3. The wires may be loosely connected to the router. Or if its wireless, you are a little bit far from the range.

    You can also do a quick reset to the router if it has a reset button and then reconnect, that can also solve the problem.
     

    #4
  5. cpour
    Eclair Nov 20, 2021

    cpour , Nov 20, 2021 :
     

    #5
  6. cpour
    Eclair Nov 20, 2021

    cpour , Nov 20, 2021 :
    no data saver , no blockage from providers because internet is working . The phone is reporting faulty that there is no internet. This happens to all wifi access points and networks , mine and all public , work , etc.
     

    #6
  7. Swejuggalo
    OnePlus 9 Series Expert Community Expert Nov 20, 2021

    Swejuggalo , via OnePlus 9 Pro Morning Mist , Nov 20, 2021 :
    Weird. So basically the only thing not tried is a factory reset?
    Something is disturbing WiFi somehow.
    When you got the phone did you transfer a complete backup of some sort (including settings) or start from scratch?
    If you haven't done so you might want to report it via the feedback tool.
    Can't recall seeing this kind of issue reported before.

    If ideas run out the simpler way might be a full reset though. But report it and wait on next update might be a first step.
     

    #7
  8. cpour
    Eclair Nov 21, 2021

    cpour , via OnePlus 9 Arctic Sky , Nov 21, 2021 :
    A network reset will be my first step towards resolving this but I do not want to go there as this will lose all my previously known AP and Bluetooth devices. The phone is connected to my car alarm and re-pairing it is a pain.
    I will wait for the big Android 12 update. Hopefully this will bring things back to normal
     

    #8
  9. Swejuggalo
    OnePlus 9 Series Expert Community Expert Nov 21, 2021

    Swejuggalo , via OnePlus 9 Pro Morning Mist , Nov 21, 2021 :
    All WiFi connections was manually added to the phone or were they transfered through a backup or something?
     

    #9
  10. cpour
    Eclair Nov 21, 2021

    cpour , via OnePlus 9 Arctic Sky , Nov 21, 2021 :
    Some.from my previous backup after switching to 9 and some new ones. This is happening to all AP, old and new
     

    #10
  11. Swejuggalo
    OnePlus 9 Series Expert Community Expert Nov 21, 2021

    Swejuggalo , via OnePlus 9 Pro Morning Mist , Nov 21, 2021 :
    A test you could do is to see what happens in safe mode.
    Let's see what happens with 12. It might fix whatever it is that breaks Wi-Fi.
    If not a reset of connections may be necessary. In worst case the whole phone.
    I always avoid transferring settings and apps. Only media files and important things stored online is things that my end up back on the next phone.
     

    #11
  12. cpour
    Eclair Nov 21, 2021

    cpour , via OnePlus 9 Arctic Sky , Nov 21, 2021 :
    Safe mode sounds good. How do I boot in safe mode
     

    #12
  13. Swejuggalo
    OnePlus 9 Series Expert Community Expert Nov 21, 2021


    #13
  14. cpour
    Eclair Nov 21, 2021

    cpour , via OnePlus 9 Arctic Sky , Nov 21, 2021 :
    Got it. Thx

    Unfortunately still the same . Delete the SSID in safe mode , re connect and after a few seconds the no internet message is back .
    It's hopeless . I think only a network reset or a factory reset will resolve this.
     

    #14
    Swejuggalo likes this.
  15. cpour
    Eclair Dec 2, 2021

    cpour , Dec 2, 2021 :
    Update: today I performed a network reset. Unfortunately the issue is still here!!
     

    #15
  16. Swejuggalo
    OnePlus 9 Series Expert Community Expert Dec 2, 2021

    Swejuggalo , via OnePlus 9 Pro Morning Mist , Dec 2, 2021 :
    Maybe it's worth the time reporting it via the feedback tool. If it also happens on 12 it might save you time by already have shared info with them now.
    If happens on 12 too it might be a good time doing a full reset. Whatever that has happened on your phone is not very common.
     

    #16
  17. pgrey
    Ice Cream Sandwich Dec 3, 2021

    pgrey , Dec 3, 2021 :
    I'd report this, via feedback (as others mentioned), rather than "waiting/hoping to see if it gets rolled-up into 12", if it were me.

    Also, have you tried flushing the system cache yet? I don't recommend this very often, but sometimes there are odd DHCP issues and such, that this seems to resolve, or has resolved for me, when I "tried just about everything else", as per above.

    Viewing some router logs would be helpful here, too, as you can probably see what's going on, before it falls off a cliff...
     

    #17
  18. cpour
    Eclair Dec 3, 2021

    cpour , Dec 3, 2021 :
    update2: i have re-installed the firmware of Sept.21 and still the same.
    i will perform a factory reset after all.
     

    #18
  19. lockmunk
    Donut Dec 5, 2021


    #19
  20. cpour
    Eclair Dec 6, 2021

    cpour , via OnePlus 9 , Dec 6, 2021 :
    Update 3: I performed a complete factory reset and the wifi is now operating as it should be. So the solution is the painful factory reset!!
     

    #20
    lockmunk likes this.