10
[Submitted] Wifi roaming in meshed network with multiple access points not working

  1. eggi
    Eclair Jan 8, 2018

    eggi , Jan 8, 2018 :
    Connect the device to the wifi being close to one access point.
    Move the device to another access point to decrease the signal strength from the initial access point.
    Despite the decreased signal strength the device does not connect to the new closest wifi access point with the strongest signal.

    Edit:
    My Configuration:
    Google WiFi with 2 APs
    Oneplus 3T running latest stable OOS 5.0.1

    Edit (2018-02-03):
    Updated to Stable OOS 5.0.2 (O2OS 180126) but issue is still not resolved.

    Edit (2018-05-24):
    Updated to Stable OOS 5.0.3:
    Wifi roaming is working again. But when the device is switching to the new AP a faster 5GHz connection is not preferred over 2.4GHz as pointed out here:
    https://forums.oneplus.com/threads/...oints-not-working.743866/page-4#post-18477554
    This is also the case for me.
     
    Last edited: May 27, 2018

    #1
  2. Jigen90
    Donut Jan 8, 2018

    Jigen90 , Jan 8, 2018 :
    op3t here running Oreo Oxygen 5.0.1
    I have a setup that consists of three different AP on 5GHz, 802.11 ac same SSID and WPA2 key.

    With Oreo 5.0 wifi roaming was working correctly, now with 5.0.1 I experience the same issue as reported by op: the device switches to the closest and strongest wifi signal only if the WiFi is disabled and re-enabled through settings. Auto roaming to the closest AP is not carried out.
     

    #2
  3. sanderroelofs
    Cupcake Jan 8, 2018


    #3
  4. G_Gaston_in_t_Veld_teMZ
    Donut Jan 8, 2018

    G_Gaston_in_t_Veld_teMZ , Jan 8, 2018 :
    Same problem here. Have 2 routers with AP (2*2.4 and 1 5ghz) same and password. Before upgrading switching from different APs worked very well.
    Also at school device doesn't switch right.
    Please OP fix this bug.
    op3t here running Oreo Oxygen 5.0.1
    I have a setup that consists of three different AP on 5GHz, 802.11 ac same SSID and WPA2 key.

    With Oreo 5.0 wifi roaming was working correctly, now with 5.0.1 I experience the same issue as reported by op: the device switches to the closest and strongest wifi signal only if the WiFi is disabled and re-enabled through settings. Auto roa
     

    #4
    sanderroelofs likes this.
  5. frank.fonteijn
    Donut Jan 8, 2018

    frank.fonteijn , Jan 8, 2018 :
    I'm having the same issue with a OnePlus 3 on oxygen 5.0.1. my wife has the 5T without issues.
    having a ubiquiti AC lite system at home with multiple access points.
    iPad is working fine as well.
     

    #5
  6. Bogeyd
    Gingerbread Jan 9, 2018

  7. juss1
    Cupcake Jan 9, 2018

    juss1 , Jan 9, 2018 :
    Same issue for me with Google Wifi (3 pucks)

    I reverted back to OxygonOS 5.0 and it's working again.
     

    #7
  8. sanderroelofs
    Cupcake Jan 11, 2018

    sanderroelofs , Jan 11, 2018 :
    information for OnePlus

    I've installed OxygenOS v5.0.1 on my OP3 and I noticed that my phone is keeping a poor wireless connection alive meanwhile there is a better signal (same SSID other channel). Before it roams towards the better accesspoint but now only after disable and enable wifi it will take the better wireless signal.

    I've reverted my phone back towards OxygenOS v5.0 and now my phone roams between accesspoints with the strongest signal.

    For my wireless solution I'm using Ubiquiti Unify AC accesspoints with same SSID's other channels and using a controller for managing an reviewing my wireless settings.
     

    #8
    pendragon likes this.
  9. Midassi
    Donut Jan 11, 2018

    Midassi , Jan 11, 2018 :
    Same problem here.

    Starting with one of the last updates, my Oneplus 3 (OxygenOS 5.0.1) does no longer automatically switch between WiFi devices within a mesh. Even standing directly next to a repeater, the OP3 would not switch to it, although the connection to the base WiFi router is already down to one bar (repeater signal ca. -30dBm, router signal ca. -80dBm).

    Other devices (non-OnePlus, but also Android-Oreo) work absolutely fine and automatically switch to the strongest mesh member.


    ( also see https://forums.oneplus.net/threads/wifi-mesh-behavior-roaming-bad.738625/#post-17532000 )
     

    #9
  10. eggi
    Eclair Jan 16, 2018

  11. frank.fonteijn
    Donut Jan 16, 2018


    #11
  12. Bogeyd
    Gingerbread Jan 16, 2018


    #12
  13. frank.fonteijn
    Donut Jan 16, 2018


    #13
  14. eggi
    Eclair Jan 16, 2018

    eggi , Jan 16, 2018 :
    It was also my hope that it might be included there..
     

    #14
  15. frank.fonteijn
    Donut Jan 16, 2018

    frank.fonteijn , Jan 16, 2018 :
    I can't give it a go untill the weekend
     

    #15
  16. gavcity
    Eclair Jan 18, 2018


    #16
  17. HWAM
    Honeycomb Jan 20, 2018

    HWAM , Jan 20, 2018 :
    In my opinion Wi-Fi is not working great anymore. MyOnePlus 3T has problems with detection Wi-Fi access points. Other devices (old OnePlus One, cams) are continue noticing all the Wi-Fi access points but the OnePlus 3T not. If I want to connect to my own Wi-Fi access point it is not displayed all the time. Sometimes I have to wait for a long time before it is detected. Very strange. And when it is there it is not constantly there, it's dropped and gone again. Also watching the access points with Wi-Fi analyzer is not showing all the access points constantly, a lot are dropped and not displayed anymore. I did a full reset of my OnePlus 3T because of this and a scratch setup but it's not fixing the problem. Even a OnePlus One with Unofficial LineageOS Oreo is working fine. Constantly detecting all the access points. The 3T with Oreo 5.0.1 is simply losing access points even a short distance from the router.
     

    #17
  18. pendragon
    Gingerbread Jan 22, 2018

    pendragon , Jan 22, 2018 :
    I have the same issue. Hopefully it will be fixed. I use Ubiquity AP's. Other devices are roaming just fine.
     

    #18
  19. B4llistic
    Donut Jan 24, 2018

    B4llistic , Jan 24, 2018 :
    Same issue but also have it with Cisco accesspoints allthough it does seem to work a little faster on them.
     

    #19
  20. sas46
    Cupcake Jan 25, 2018

    sas46 , Jan 25, 2018 :
    Same issue here, 5.0.1, can't find a solution
    How can we submit a bug report?
     

    #20