10
[Submitted] Wifi roaming in meshed network with multiple access points not working

  1. Bogeyd
    Gingerbread May 24, 2018

    Bogeyd , May 24, 2018 :
    Downloading 5.0.3 stable, hopefully it fixes this.

    Edit: Quickly testing it seems to work like in latest beta. So roaming works but does not prefer 5GHz so it gets connected to strongest signal which is usually the slow 2.4GHz

    Edit2: Please OnePlus do not close this bug yet.
    Fix it how it was before, 5GHz should be preferred over 2.4GHz when enough RSSI
    For example if greater than -65dBm it should connect to 5GHz.

    E.g. if I have RSSI like

    2.4GHz -42dBm
    5GHz -65dBm

    It still should use 5GHz even signal is worse than on 2.4GHz.
    Because it is still good enough signal and the speed is still much better on 5GHz.

    Edit3: here how implemented on Apple mobile devices. I don't know if it is the best way to do it, but for Android I didn't find any documentation and it explains the roaming very well.
    https://support.apple.com/en-us/HT203068

    In Apple devices roaming works good.
    Also in Xiaomi MI A1 which is like stock android 8.0.0 roaming is working very well.
     
    Last edited: May 25, 2018

    #61
    eggi likes this.
  2. vincisevilla
    Cupcake May 31, 2018

    vincisevilla , May 31, 2018 :
    How do I revert back to Oxygen OS 5.0 after my phone already updated to the new Oreo 5.0.1 update? Help please!
     

    #62
  3. pgrey
    Honeycomb May 31, 2018

    pgrey , May 31, 2018 :
    Your RSSI values are too low, e.g., your APs are probably all set on transmit=HIGH, particularly the 2.4 radios.
    Use a WiFi tuning app, and walk around your location, and make sure your overlap is lower (you want a little, but not significant, somewhere around 65-70, there are lots of good guides out there).
    Often, changing to lower power transmit values will greatly increase your speed, due to removal of interference between the APs (particularly if they on the same channels, plus you may have neighbors, etc). Lower power transmit doesn't necessarily mean "lower speed", it just means a little less "reach", which can be a good thing, when you have multiple APs.
    A 65 dBm 5G signal is still pretty strong, unless you have a LOT of users on the AP.

    Also, if you want to consistently get 5G connections (when you have a 5G that's near the 2.4 signal strength), most AP setups will have a "band preference" setting, which will "steer" your devices this way.
    What the device does with the "steering" is up to it, most handle it pretty well, others tend to reject it, it depends on the stack driver usually.

    WiFi roaming really isn't a solid standard at this point (at least not that I've ever found, I keep an eye on the consortiuums), although it's morphing into one, a very "interesting" one.
     

    #63
    pedritopl likes this.
  4. Bogeyd
    Gingerbread May 31, 2018

    Bogeyd , May 31, 2018 :
    @pgrey those were just examples how roam should be preferring 5GHz.

    Did some quick tests with OP6.

    In of APs dBm is around -65dBm, and when moving more close to other AP, at around -70dBm OP6 reassociated to another AP with -60dBm on 5GHz, even 2.4GHz has -55dBm at that same spot.

    So OP 6 prefers 5GHz fine in my environment.

    OP3 not anymore :( not switching to 5GHz when close to AP with good signal on both 2.4 and 5GHz. Actually my wrt1900acs has better signal on 5GHz so normally it associates with that. But if already associated with 2.4GHz it sticks with that, then to switch back to 5GHz need to toggle wifi..

    Then speed tests with OP6 to show how 5GHz speed is much higher than 2.4G even signal is much lower.
    With -70dBm 5GHz speed is 260Mbps (80MHz). Iperf gives stable 250Mbit/s.

    When sitting next to AP at -42dBm on 2.4GHz(20MHz) speed is 144Mbps. Iperf gives only 80Mbit/s and not very stable.


    This wasn't any lab test just checking wifi analyzer and moving around to find a spot with above dBm and do quick tests.
    The speed on 5GHz probably increases when starting the data transfer, I didn't have other device on hand to check from AP.

    No neighbors and all AP on different channels.
    Using openwrt and 802.11r enabled on all APs for quick roaming. I want to keep high my 2.4GHz, need it for my yard for longer range.
     
    Last edited: May 31, 2018

    #64
  5. pgrey
    Honeycomb Jun 1, 2018

    pgrey , Jun 1, 2018 :
    @Bogeyd I got it now, I thought you were talking primarily about a 5, 5T, or 6.

    The 5T is my first OP phone, but I've had zero issues getting any device to "prefer" 5GHz SSIDs, using a triple-set of Unifi APs (their Pro Mesh version, but not meshed, hard-wired to CAT cable).
    I did have some issues, when I first moved to Unifi, a few years ago, but after analyzing/adjusting, my 5/2.4 co-exists, much like the way I think you're shooting for.
    I do have all my APs set to prefer 5G, but with a min-RSSI, so that I can still fall-back to 2.4, for longer range, same as you're looking at.
    If I'm far enough away (like a block or so), my 5T will switch to a 2.4 SSID, even though my 5G might be visible, but very low signal quality.

    No question though, a *somewhat* lower-signal 5G connection will beat a solid 2.4 for speed, every time.

    I think we're mostly in agreement on this whole deal, it sounds like mostly your 3T isn't doing what you'd expect?
     

    #65