0
[Submitted] Wifi upload speed very slow

  1. Bogeyd
    Gingerbread May 23, 2018

    Bogeyd , May 23, 2018 :
    Here steps to reproduce the issue 100%

    AP1 = Linksys WRT1900ACS, Openwrt r7020, mwlwifi 10.3.4.0-20180330
    AP2 = Archer C5 v1, Openwrt r7021
    Phone = OnePlus 6, OOS 5.1.5

    Have same SSID configured on both APs on 5GHz and place so that they overlap a bit.

    1. Connect Phone to AP1. Upload speed is OK.
    2. Walk near AP2 so it gets connected to it. Upload still OK.
    3. Walk back near to AP1 so it gets connected to it, upload speed is very bad.
    4. Switch phone wifi OFF ON to reconnect to AP1, upload speed is good again.
     
    Last edited: May 25, 2018

    #1
  2. Deactivated User
    May 23, 2018


    #2
    Bogeyd and torradeira like this.
  3. torradeira
    Cupcake May 24, 2018


    #3
    Bogeyd likes this.
  4. Bogeyd
    Gingerbread May 24, 2018

    Bogeyd , May 24, 2018 :

    Issue seems happen after roaming from one AP to another and only on 5GHz. I'll be testing more but looks like it happens only on my Linksys wrt1900acs with Openwrt and only with OP 6. OP 3 roaming is broken currently so can't test that, maybe I'll update latest stable where roaming is fixed and see...

    And yes I have submit my comments about that to mwlwifi driver maintainer also to investigate if the problem is with my router WiFi instead.

    https://github.com/kaloz/mwlwifi/issues/295#issuecomment-391610963
     
    Last edited: May 25, 2018

    #4
  5. Bogeyd
    Gingerbread May 24, 2018

    Bogeyd , May 24, 2018 :
    I think I'm at the latest OOS version is 5.1.5
     

    #5
  6. Bogeyd
    Gingerbread May 25, 2018

    Bogeyd , May 25, 2018 :
    Now when OnePlus 3 roaming was somewhat fixed, I could test with OP3 also. It does not have this issue.
     

    #6
  7. pendragon
    Gingerbread May 27, 2018

    pendragon , May 27, 2018 :
    I tried to reproduce your issue, but couldn't. The difference between you and me is that my AP's are from 1 brand, maybe that's an issue? I use Ubiquity Unifi AP-AC-Lite devices. Roaming on the OP6 also works fine. I get a speed between 200 and 300Mbit with speedtest.net.
     

    #7
    Bogeyd likes this.
  8. pendragon
    Gingerbread May 27, 2018

    pendragon , May 27, 2018 :
    I tried the same thing with my OP3 on Beta firmware and no issue there as well in my configuration.
     

    #8
  9. Bogeyd
    Gingerbread May 28, 2018

    Bogeyd , May 28, 2018 :
    Oneplus 6 WiFi capabilities gets changed after roaming, maybe that is causing it.
    Attached screenshot below

    assocreq_differences_op6.PNG
     
    Last edited: May 28, 2018

    #9
  10. Bogeyd
    Gingerbread May 28, 2018

    Bogeyd , May 28, 2018 :
    In OnePlus 3 what does not have this issue, the advertised capabilities are same in both association request and reassociation request...

    And one more point, this also happens with single WiFi Access Point also if 2,4GHz and 5GHz are having same SSID and phone jumps from 2.4GHz to 5GHz, the speed is very slow.
     
    Last edited: May 28, 2018

    #10
  11. Bogeyd
    Gingerbread May 29, 2018

    Bogeyd , May 29, 2018 :
    Tested with Linksys wrt1900acs stock firmware and it has the same issue with this phone.
    No issue with any other device than OnePlus 6.

    Flashed the latest firmware to WRT1900ACS
    FW_WRT1900ACS_1.0.3.187766

    Created WiFi on 5GHz with same SSID than my other APs

    Toggled Oneplus WiFi On Off

    Test the speed what is very good
    Code:
    Connecting to host 192.168.1.33, port 5201
    [ 4] local 192.168.1.91 port 42246 connected to 192.168.1.33 port 5201
    [ ID] Interval Transfer Bandwidth
    [ 4] 0.00-1.01 sec 72.2 MBytes 598 Mbits/sec
    [ 4] 1.01-2.02 sec 73.8 MBytes 612 Mbits/sec
    [ 4] 2.02-3.01 sec 71.2 MBytes 607 Mbits/sec
    [ 4] 3.01-4.00 sec 70.0 MBytes 591 Mbits/sec
    [ 4] 4.00-5.03 sec 68.8 MBytes 563 Mbits/sec
    [ 4] 5.03-6.02 sec 62.5 MBytes 528 Mbits/sec
    [ 4] 6.02-7.00 sec 60.0 MBytes 512 Mbits/sec
    [ 4] 7.00-8.01 sec 60.0 MBytes 499 Mbits/sec
    [ 4] 8.01-9.01 sec 60.0 MBytes 505 Mbits/sec
    [ 4] 9.01-10.02 sec 67.5 MBytes 560 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval Transfer Bandwidth
    [ 4] 0.00-10.02 sec 666 MBytes 558 Mbits/sec sender
    [ 4] 0.00-10.02 sec 663 MBytes 555 Mbits/sec receiver
    
    iperf Done.
    
    Roam to another AP with same SSID and then roam back to wrt1900acs
    speed is very bad

    Code:
    Connecting to host 192.168.1.33, port 5201
    [ 4] local 192.168.1.91 port 42264 connected to 192.168.1.33 port 5201
    [ ID] Interval Transfer Bandwidth
    [ 4] 0.00-1.04 sec 947 KBytes 7.45 Mbits/sec
    [ 4] 1.04-2.03 sec 0.00 Bytes 0.00 bits/sec
    [ 4] 2.03-3.04 sec 368 KBytes 2.99 Mbits/sec
    [ 4] 3.04-4.03 sec 382 KBytes 3.15 Mbits/sec
    [ 4] 4.03-5.03 sec 382 KBytes 3.12 Mbits/sec
    [ 4] 5.03-6.00 sec 0.00 Bytes 0.00 bits/sec
    [ 4] 6.00-7.04 sec 382 KBytes 3.02 Mbits/sec
    [ 4] 7.04-8.04 sec 0.00 Bytes 0.00 bits/sec
    [ 4] 8.04-9.01 sec 382 KBytes 3.21 Mbits/sec
    [ 4] 9.01-10.04 sec 382 KBytes 3.05 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval Transfer Bandwidth
    [ 4] 0.00-10.04 sec 3.15 MBytes 2.63 Mbits/sec sender
    [ 4] 0.00-10.04 sec 2.20 MBytes 1.84 Mbits/sec receiver
    
    iperf Done.
    
    
     

    #11
  12. Bogeyd
    Gingerbread May 29, 2018

    Bogeyd , May 29, 2018 :
    Tested with OnePlus 5 with OOS 5.0.4 it has the same issue...

    Edit: upgraded OP5 to OOS 5.1.2 and still the same
     
    Last edited: May 29, 2018

    #12
  13. Bogeyd
    Gingerbread Jun 8, 2018

    Bogeyd , Jun 8, 2018 :
    I have small update. Root cause seems to be with phone sending too large frames and AP can't catch that. I.e. phone not honoring the APs Max MPDU length.
    OnePlus has been very proactive on this case and I'm sure it will be fixed, waiting to see the fix in stable. Hopefully fix will helps also in other users as well who have had weird issue with WiFi on 5GHz with OP 5, 5t and 6.
     

    #13
  14. cbrettmiz
    Cupcake Jun 14, 2018

    cbrettmiz , Jun 14, 2018 :
    Same here. Upload only. Causing issues with wifi calling. People can't really hear me (very broken) but I can hear them just fine.
     

    #14
  15. sabbyjay
    Honeycomb Jun 16, 2018

    sabbyjay , Jun 16, 2018 :
    Same here, my internet speed is 100Mbps. On my OP3, speedtes shows 90+ Mbps on both download and upload.
    But on my OP6 the upload speed is 45-49 Mbps. Download is 90+ Mbps so that is fine. Upload is slow. I have a 5ghz router.
    I have another 5Ghz router, and the same issue arises with both the routers.
     

    #15
  16. pgrey
    Ice Cream Sandwich Jun 16, 2018

    pgrey , Jun 16, 2018 :
    I have Unifi APs (UAP-AC-M/M-Pro units, 2 Pro, 1 std), and I see the issue as well, on BOTH 5 and 2.4.
    As soon as I "roam back" though, it reestablishes correctly, which is "weird", something's getting cached, or similar, I bet.
    There's also the fact that WiFi "roaming" isn't a solid spec really, particularly if you are talking cross-manufacturer. It'd be nice if the consortium sorted this, and imposed a standard, one of these days...
     

    #16
  17. cbrettmiz
    Cupcake Jun 18, 2018


    #17
  18. cbrettmiz
    Cupcake Jul 20, 2018

    cbrettmiz , Jul 20, 2018 :
    anyone still having trouble with upload speed? my WiFi calling still sucks when I'm talking I can hear just fine. this phone is the only one in my household with this upload problem on WiFi. huge delay and slow speed when I test it. thanks
     

    #18
  19. cbrettmiz
    Cupcake Jul 20, 2018


    #19
  20. Bogeyd
    Gingerbread Jul 29, 2018

    Bogeyd , Jul 29, 2018 :
    5.1.9. fixed it for me. But I haven't had time to take the packet capture to check capabilities are correctly set in reassociation.

    Now after this update it often roams to 2.4GHz even good 5GHz signal is available. It should prefer speedier 5GHz instead of slow and growded 2.4GHz. Related bug report for the issue:
    https://forums.oneplus.com/posts/18836619/
     
    Last edited: Jul 29, 2018

    #20