2
[Answered] WiFi won't turn on after deep sleep

  1. Shagna
    Donut May 7, 2018

    Shagna , May 7, 2018 :
    I've always set WiFi to shutdown during deep sleep through WiFi advanced settings, it have always worked, but after update to openbeta 7 it does shut down during deep sleep, but it won't turn on again, sometimes I have to force it (tapping on wifi icon) but the whole system interface gets laggy and sometimes force close.
    I've clean flashed the stable version, but the issue persists.
     

    #1
    pillow35 and okEric like this.
  2. okEric
    Donut May 11, 2018

    okEric , May 11, 2018 :
    Been having the same issue here. I've basically been finding my WiFi is disabled after the phone has been off for a bit and when I try to enable wifi, there is no response. The only way I've found to restore wifi is to restart the phone.

    I have for now disabled the feature that turns off WiFi when sleeping.
     

    #2
    ToliyMed likes this.
  3. butterbeanmash
    Cupcake May 12, 2018


    #3
  4. Peshkoff
    Cupcake May 12, 2018


    #4
  5. pgrey
    Honeycomb May 13, 2018

    pgrey , May 13, 2018 :
    The same, except even *if* I disable the WiFi option to sleep, it *still* fails to turn back on, AND I'm unable to turn it back on (basically a hung settings screen), without a reboot.
     

    #5
  6. djreaper
    Cupcake May 13, 2018

    djreaper , May 13, 2018 :
    Same happend to me i am glad to hear that i am not facing this problem alone and it is not because of my phone (oneplus 5) is because of oneplus. please help us
    LE: i have done network reset, clear cache, downgrade of software , total factory reset and nothing works.
     

    #6
  7. G_Stephen_Rogoff_mkVs
    Cupcake May 15, 2018

    G_Stephen_Rogoff_mkVs , May 15, 2018 :
    Try this.

    Go into Location click the 3 dots at the top. Set both wifi and Bluetooth scanning active.

    Reboot into recovery. Wipe cache and dalvic. reboot.

    Go back to Location and set wifi and bluetooth scanning off.

    Reboot.

    See if it works now.

    Regards

    Stephen
     

    #7
  8. okEric
    Donut May 16, 2018

    okEric , May 16, 2018 :
    I upgraded to open beta 8 today and after some initial testing it looks like this bug might be fixed.
     

    #8
  9. Shagna
    Donut May 16, 2018

    Shagna , May 16, 2018 :
    Tried that and sadly it didn't work :(
     

    #9
  10. Shagna
    Donut May 16, 2018

    Shagna , May 16, 2018 :
    Really? I'm on beta 8 and I still have this issue. Did you clean flash?
     

    #10
  11. Shagna
    Donut May 17, 2018

    Shagna , May 17, 2018 :
    I've been following the threads here and it looks like a lot of people are facing this issue. It would be cool to have at least some feedback on the progress.

    I will try to send email do Android authority and XDA to see if they can post on their pages this issue to see if this is really widespread
     

    #11
  12. Jeroen1000
    Cupcake May 19, 2018

    Jeroen1000 , May 19, 2018 :
    I'm also facing this issue. Wifi activates very slowly after waking from deep sleep. Sometimes not at all and in such case a reboot is required. The Wifi toggle in the settings menu is unresponsive during the entire event and some apps hang until the Wifi pulls through and activates.

    The cure is either waiting a (relatively speaking) long time (> 25 seconds up to one minute) for the Wifi to turn on or rebooting. I have a session with a L2 tech tomorrow but I think there are just going to factory flash the phone using the qualcomm tool...
     

    #12