223

[WIP] Ubuntu touch for OnePlus One

  1. CasperTFG KitKat May 9, 2016


    luxuskamel likes this.
  2. CBpbxEcmecmBeH Jelly Bean May 9, 2016


  3. CasperTFG KitKat May 10, 2016


    luxuskamel likes this.
  4. VeryMilan Honeycomb May 19, 2016


    luxuskamel likes this.
  5. dmooney7291 Eclair May 25, 2016


  6. saagar241290 Donut May 27, 2016

    saagar241290, May 27, 2016 :
    I have OP2, are they giving ubuntu touch for OP2. Also i want to know review of OPO ubuntu touch
     

  7. luxuskamel Lollipop May 27, 2016


  8. luxuskamel Lollipop Jun 1, 2016


  9. CasperTFG KitKat Jun 1, 2016


  10. deyvidpi Cupcake Jun 2, 2016

    deyvidpi, Jun 2, 2016 :
    Hi everyone !
    And thanks Chloe and Mario for porting Ubuntu on oneplus one :)
    I must say I haven't read the whole 106 pages of the thread, so maybe my question will have been answered already. So what happens is that after a correct installation, when I try to boot on ubuntu, I've got the +1 icon twice, and then it just goes back to the boot rom selector.
    Any idea ? :)


    If that can be of any use: I'm running sultanxda with private kernel from derromtester as a primary ROM. Furthermore on the multirom home screen I have "kernel has kexec-hardboot patch", but when I tried to boot another ROM they said the opposite. So I enabled the "no-kexec workaround" and it worked fine on my secondary stock ROM. However I've still got that issue with Ubuntu.

    Thanks ;)
     

  11. IvanMuse Ice Cream Sandwich Jun 2, 2016


  12. debojyoti_op Eclair Jun 2, 2016

  13. ChloeWolfieGirl Gingerbread Jun 5, 2016

    Last edited: Jun 6, 2016

    krishnants and batterio like this.
  14. luxuskamel Lollipop Jun 6, 2016

    luxuskamel, Jun 6, 2016 :
    If there were some for the OP3 already, that would be funny :p
     

  15. ChloeWolfieGirl Gingerbread Jun 6, 2016

    ChloeWolfieGirl, Jun 6, 2016 :
    obviously we can't do anything for the OP3 currently as we don't have a device, but we also aren't confirming any support for the device as we have withe the OPx and soon OP2.

    Anyways, for some exciting updates.
    http://news.softpedia.com/news/wire...-5-and-oneplus-one-ubuntu-phones-504915.shtml

    Yes thats right, we're adding wireless display support to the OnePlus One which means if you have a miracast device you can use your phone as a convergence device, and yes you can test this out along with calling and earphone/headphone support by switching to devel_rc-propsed
     

    msri3here and luxuskamel like this.
  16. nanonerd Cupcake Jun 7, 2016

    nanonerd, Jun 7, 2016 :
    Hey Chloe,

    Thanks for all of your great work!!

    I switched to "devel_rc-proposed" BUT still not able to make a call nor is the miracast feature available as far as I can tell. FTA, it mentioned something about OPO getting the miracast feature "as soon as next week".

    I did notice that things seem more fluid and snappy.

    I'm new to Ubuntu Touch on OPO. Do I need to update via my Ubuntu laptop in the future or is everything now OTA since I already have it on my phone?

    Thanks
     

  17. ChloeWolfieGirl Gingerbread Jun 7, 2016

    ChloeWolfieGirl, Jun 7, 2016 :
    Hmm thats strange it should work...

    If you go to system settings -> About -> OS
    Look at device build then it should say 5.1 where as on rc-proposed says 4.4.2, if you can confirm that it says 5.1 then you defiantly should be getting calls, headphones and miracast options.

    For the next week thing, thats when should be coming to stable and rc-proposed, devel_rc-propsed SHOULD have it now.

    Glad to see things are more fluid and snappy though :)

    If you want to stay on devel_rc-proposed then you wont need your computer, but I wouldn't recommend staying on that long term, stable or rc-proposed I'd recommend for long term or daily use, but OTA works on the OnePlusOne.
     

    msri3here likes this.
  18. bagadesh Cupcake Jun 8, 2016

    bagadesh, Jun 8, 2016 :
    Guys,iam in need of help.
    yesterday i tried to install ubuntu touch rc proposed lastest version using multirom manager.After downloading couple of file and it said reboot to finish installation.I did reboot now twrp opens it said system image upgrader failed and it pushed me back into twrp menu.Though installation failed i can see ubuntu touch icons in multirom but it doesn't boot.

    So any one please help me (i do even tried the stable version )
     

  19. bluxnj Cupcake Jun 8, 2016

    bluxnj, Jun 8, 2016 :
    How is the app support spread, do they support all of the Ubuntu apps on the phone or is there something left to be desired?
     

  20. samuk190 Honeycomb Jun 8, 2016

    samuk190, Jun 8, 2016 :
    Hey @mariogrip Very nice work! Hope you release in xda!
    Awesome! When you fix everything i will use it as daily driver, battery seems very snappy!! XD

    #OF
    can you give me tips for compiling android kernels?
    i tried one and it gives net/netfilter problem