223

[WIP] Ubuntu touch for OnePlus One

  1. ChloeWolfieGirl Gingerbread Jul 1, 2016

    ChloeWolfieGirl, Jul 1, 2016 :
    I'm on the latest devel_rc-propsed, currently r25.

    Issues so far
    No celular, no sound, no ability to change brightness, no gps or camera.

    You can now share things using the media-hub and bluetooth is an option, if/how well that works I couldn't comment on right now, but I 'm being open with how we are.

    It should be noted, Marius told me that all of this should work minus gps and camera, so there was an error somewhere which didn't affect his debug but does affect devices updating via OTA.

    This is one reason we have devel, it's both very exciting and frustrating, and I imagine it is for you guys also, but as I said I will be keeping you all in formed as we go down this street, there may be more issues I haven't stumbled on I've only used this build for about half an hour.
     

    luxuskamel likes this.
  2. ChloeWolfieGirl Gingerbread Jul 3, 2016

    ChloeWolfieGirl, Jul 3, 2016 :
    devel_rc-proposed r28

    Issues so far

    Most boots wifi, bluetooth, sound doesn't work

    brightness doesn't work, no camera

    Earphones work if they dont have a mic, calls don’t work.

    among some others
     

  3. krishnants Eclair Jul 6, 2016

    krishnants, Jul 6, 2016 :
    The UB ports page shows that most functions are working on oneplus stable build. Thats fantastic news. I'm running the stock cyanogen os marshmallow 6.0.1. How do i root my phone to install and use mutirom? Super su sends the phone into a never ending boot loop. Its not cyanogenmod so there is no root for apps in developer options in settings menu before you ask. Would love to test this port ASAP :)
     

  4. gwie Jelly Bean Jul 6, 2016

    gwie, Jul 6, 2016 :
    There are a ton of tutorials on how to do that on this forum and outside of it. Just use the forum's search function or google and you will find a dedicated post with a better explanation than you will ever get here.

    Good luck!
     

  5. nanonerd Cupcake Jul 7, 2016

    nanonerd, Jul 7, 2016 :
    CHLOE: Sorry to ask but I must say that I'm confused. As Krishnants states, the UBPorts page now has the device listed as "release". It even says that calls work BUT in your previous post you stated that calls don't work. Can you please advise? Thanks !!
     

    CasperTFG likes this.
  6. jansvanda Ice Cream Sandwich Jul 9, 2016

    jansvanda, Jul 9, 2016 :
    whaaaat? Where is the ubuntu for oneplus 2? you said op2 is getting ubuntu, but where is it?
     

  7. msri3here Ice Cream Sandwich Jul 10, 2016

    msri3here, Jul 10, 2016 :
    Recently, I have been getting "Failed to download and parse Ubuntu Touch metadata" when opening Multirom Manager app.
    Tried clearing the data for the app, but still not working

    anyone has the same issue?

    I am on latest COS 13.1 - ZNH2KAS254
     

  8. prerakr Donut Jul 10, 2016

    prerakr, Jul 10, 2016 :
    Happened to me as well. It is the app's fault. I've tried compiling a version with some edits and the error is gone. Sadly, even after successfully installing ubuntu touch, it doesn't boot.
     

    msri3here likes this.
  9. jervan01 Cupcake Jul 10, 2016

    jervan01, Jul 10, 2016 :
    Big problem for me, after downloading ubuntu with multirom my opo reboots to recovery but the image does not install (system-image-upgrade failed). This happens with every availble download. Anyone an idea?
    Thx.
     

  10. baddea14 Gingerbread Jul 11, 2016

    baddea14, Jul 11, 2016 :
    i boot successfully to stable image ch13 with recovery but i mean that all user ask mariogrip and teams about these problem i prepare the solution with attachment soon
    i am happy with new updates . Thank you
     

  11. msri3here Ice Cream Sandwich Jul 11, 2016

    msri3here, Jul 11, 2016 :
    On TWRP TWRP_multirom_bacon_20160417, this happens.
    flash TWRP_multirom_bacon_20160221-01 and you'll be fine.
     

  12. preetnoor Cupcake Jul 12, 2016

    preetnoor, Jul 12, 2016 :
    Hello bro I'm installing Ubuntu touch with TWRP_multirom_bacon_20160221-01... It installed but when i try to boot... It doesn't boot I have tried multirom v33a, v33b, v32j,v32k nothing worked.... is its keyring problem.... Please friends i will be very thankful I'f you help me....
     

  13. dhairyarc1 Ice Cream Sandwich Jul 12, 2016


  14. jansvanda Ice Cream Sandwich Jul 12, 2016


  15. jervan01 Cupcake Jul 13, 2016


  16. 7778800 Cupcake Jul 14, 2016

    7778800, Jul 14, 2016 :
    I installed multirom v33b through multirom manager app and flashed Ubuntu touch stable v13 on it ...on reboot I select Ubuntu touch stable but it shows a white screen and boot back to internal ROM...one person suggested to try multirom v33a ...can anyone please help me....I don't know how to uninstall it and flash v33a....please help .....
     

  17. jervan01 Cupcake Jul 19, 2016


  18. nrik_1584 Cupcake Jul 29, 2016

    nrik_1584, Jul 29, 2016 :
    Same here. I've been keeping an eye on this project for some time now and it would be great to know exactly what's the situation.
     

    dhairyarc1 likes this.
  19. krishnants Eclair Jul 29, 2016

    krishnants, Jul 29, 2016 :
    Well.. Calls are actually a hit and miss.. I'm on stable 14.. Sometimes they work but the network in my area is really poor even on android (kitkat onwards as far as i can remember) so the other party can't hear my voice though i can hear theirs.. I'm pretty sure it's my network problem and not Ubuntu's fault though i can't be sure.. Also with the latest update my 3g/4g stopped working.. I can't toggle it on or off.. Also my Ubuntu one login does not persist on reboot.. Am running multirom and cyanogen os 6.0.1 :)

    EDIT: calls don't work anymore. Getting calls failed. Something wrong with cellular radio. I'm able to send messages but calls and cellular don't work anymore. Ubuntu one login issue still present.
     
    Last edited: Jul 30, 2016

  20. bormasina Gingerbread Jul 31, 2016

    bormasina, Jul 31, 2016 :
    I want to report that i couldn't install version 14. I didn't use multirom, went straight to:
    Code:
    sudo ubuntu-device-flash --server=http://system-image.ubports.com touch --channel=ubuntu-touch/stable --device=bacon --bootstrap
    and the phone was stuck at "POWERED BY ANDROID". I was hoping that this release is really good, but it doesn't seem like it. No error messages while executing the "ubuntu-flash-device" command. I'm on bone stock recovery and bone stock OS.
     

    jonasdemoor likes this.