223

[WIP] Ubuntu touch for OnePlus One

  1. nrik_1584 Cupcake Aug 1, 2016

    nrik_1584, Aug 1, 2016 :
    Thanks for those informations. Seems like it's not that stable yet (at least for calls).
    What about global stability and battery life ? Does it crash every now and then or is it generally usable (except for calls [at least in your case] and the 2 elements tagged as not working on ubports) ?
     

  2. jonasdemoor Cupcake Aug 1, 2016

    jonasdemoor, Aug 1, 2016 :
    I can confirm this, although mine does spit out an error message. I can't quote the exact error message but I'll describe the behaviour of my phone:

    1. After running the command , it downloads the .tar files and extracts them to my /home directory.
    2. Then, it reboots my phone. When the ADB service comes online, it starts copying files to various partitions on my phone.
    3. Then it fails when it's trying to copy files to my recovery cache partition, complaining it is too small.
    I had some other issues , but these had to do with the fact that I was running Ubuntu from a live USB and that I didn't turn USB Debugging on.

    I'll think I'll open up an issue on GitHub or UBports, if this is possible. But I hope someone of the dev team will see this :)
     

    bormasina likes this.
  3. bormasina Gingerbread Aug 1, 2016

    bormasina, Aug 1, 2016 :
    Right, exactly as you describe it, but i didn't see any error message in Ubuntu's terminal nor any error while at the recovery. So, apparently, while in fastboot, the "ubuntu-device-flash" sends the images without any error, then it issues command to boot the device in recovery, the device enters recovery properly it seems, but not sure why it hangs there. I let the device sit there for a while and nothing happens. If i type "adb devices" it returns proper response and i can reboot it with "adb reboot" or boot it in fastboot with "adb reboot-bootloader". Not sure how to disable the "Powered By Android" screen, so i can see where it fails in the recovery ...

    I'll monitor GitHub and will chime in on the issue. I was looking forward testing the cell/modem ...
     

  4. ET0 Eclair Aug 3, 2016

    ET0, Aug 3, 2016 :
    2016/08/03 07:55:21 error pushing: failed to copy '/home/horse/.cache/ubuntuimages/pool/keyring-***b.tar.xz' to '/cache/recovery/': Permission denied


    that is my error, would anyone know how I fail to have rights.
     

  5. chandra1.jd Gingerbread Aug 3, 2016

    chandra1.jd, Aug 3, 2016 :
    i am using Cynogen13.1. how to install Ubuntu touch OS and which version of twrp will support..
     

    CasperTFG likes this.
  6. nik012003 Cupcake Aug 8, 2016

    nik012003, Aug 8, 2016 :
    Hi,I've installed ubuntu touch on my oneplus one using multirom and I want update it to OTA 12 but i don't know how to do this.I've tried with apt-get update but it fails.
     

  7. sopis Eclair Aug 8, 2016

    sopis, Aug 8, 2016 :
    hey guys - can somebody please help me here?
    I installed MultiROM manager from playstore on OnePlus one CM13, did all the necessary updates per MultiROM notifications and clicked install ubuntu touch...
    all files downloaded and started installing, then it went to TWRP and stopped with a log saying system-upgrader-failed

    I followed the instructions (well there were only one: click the install ubuntu [​IMG] ) any ideas what to do in this case?

    thanks!

    Log file:
     

  8. msri3here Ice Cream Sandwich Aug 8, 2016

    msri3here, Aug 8, 2016 :
    Install Multirom recovery from 20160221 instead of 20160417

    That is, install recovery build from 21st Feb 2016 instead of 17th April 2016
     

    sopis likes this.
  9. krishnants Eclair Aug 8, 2016

    krishnants, Aug 8, 2016 :
    It seems stable enough though at times it does not accept my ubuntu one login. No error also, just takes me back to the login page. I havent had any crashes till now though my phone does heat up a lot and the battery life is not that great(atleast not to the level of marshmallow). Also, found that headphones dont seem to work. Music still plays through the speaker even when headphones are connected, there seems to be no setting to switch to headphones in the system settings as well.
     

  10. sopis Eclair Aug 8, 2016

    sopis, Aug 8, 2016 :
    THANKS!!! worked like a charm..wow
     

  11. DannyM93 Ice Cream Sandwich Aug 8, 2016

    DannyM93, Aug 8, 2016 :
    I could neither get Multirom nor Ubuntu device flash to work on mine until I downloaded and flashed an old version of COS (CM11S to be exact). It appears the partition sizes (specifically for recovery) may have changed with the bootloader for COS 12 or newer.
    Apparently utouch must be installed with the CM11S bootloader.
     

  12. anubhavberry1996 Cupcake Aug 14, 2016

    anubhavberry1996, Aug 14, 2016 :
    Noob here..!
    Can anyone tell me the commands or how to get the rom to read the internal storage (photos, music and other stuff) cannot play music nor access the internal storage rn. Help would be appreciated, thanks. :)
     

  13. giaur500 Jelly Bean Aug 17, 2016

    giaur500, Aug 17, 2016 :
    Can I make a call using Ubuntu Touch? Or still not supported after 1.5 year of hard work.
     

  14. ChloeWolfieGirl Gingerbread Aug 18, 2016

    ChloeWolfieGirl, Aug 18, 2016 :
    OK, bit of an update, I haven't been on much due to lack of internet for the last couple of weeks.

    The phone is not stable, the stable builds aren't ready for daily as theres still no ability to call, or share media, among some other key things not being available.

    RC-Proposed isn't a good choice right now as it refuses to open applications.

    Devel_rc-proposed isn't good either as it doesn't boot, Marius will be pushing a new update to devel in the not to distant future, but he wants to fix bugs he's found first before pushing it out, theres a few big ones.

    Marius said theres about 10 bugs left that he's found that he wants to fix before he sends out the update to Devel_rc-Proposed after he's sent out the update, I'll grab it and test it out, and if it works and then I'll update you all here.

    Rc-proposed my hit some other bugs and issues though as there is a new mir update coming out soon which may introduce more bugs for our port, just know that Marius is working hard to get it out of the gate.



    Also, just to inform you, we have our own forum options.

    I can see this forum is getting quite difficult to look through with multiple topics including booting issues, multi-boot, what works and what doesn't, etc.
    I don't want people to feel pushed into making an account and using our service, but its an option if you would like to and it'd make it easier and make it more likely for your voice to be heard on certain problems, it also means we're less likely to get the same or similar questions asked if its already been answered.

    https://forums.ubports.com/category/13/one
     

    msri3here and AbhasJain like this.
  15. ChloeWolfieGirl Gingerbread Aug 29, 2016

    ChloeWolfieGirl, Aug 29, 2016 :
    There maybe an update from canonical in the not to distant future (OTA13)
    We don't recommend updating until further notice due to the bug in rc-proposed which prevents apps from working.

    We may update before Canonical pushes out OTA13, but this is a warning just in case we can't release before canonical.
     

  16. kryshnakishore Ice Cream Sandwich Aug 29, 2016

    kryshnakishore, Aug 29, 2016 :
    @ChloeWolfieGirl @msri3here i am using opo with RR rom + boeffla-kernel. I used multirom app to flash devl-proposed version. Its not booting into ubuntu..

    I tried this: Install Multirom recovery from 20160221 instead of 20160417

    But even that it didn't help. When i select ubuntu rom it shows up 1+ logo until i reboot. Which version works irrespective of stability
     

  17. ChloeWolfieGirl Gingerbread Aug 29, 2016

    ChloeWolfieGirl, Aug 29, 2016 :
    I cant say anything about multi-rom, but can say that Devel_rc-proposed doesn't bot at the moment.
     

    msri3here and kryshnakishore like this.
  18. VeryMilan Honeycomb Sep 22, 2016


  19. Aditya.Me Donut Sep 23, 2016

    Aditya.Me, Sep 23, 2016 :
    The project seems quite dead, Ubuntu on phone also seems quite dead as its not really getting the popular application support from developers. Canonical should probably move its focus from Ubuntu Phones to Ubuntu Tablets that can support desktop applications natively.
     

  20. CasperTFG Jelly Bean Sep 23, 2016

    CasperTFG, Sep 23, 2016 :
    Sada. We came real close to having all aspects, e.g. Bluetooth, working. And then nothing. Even OnePlus started a thread on this. What's the point now, this device is over two years old now.