223
[WIP] Ubuntu touch for OnePlus One

  1. aquila
    Honeycomb Feb 26, 2015


    adlibitum likes this.
  2. Rodav
    Honeycomb Feb 26, 2015

    Rodav , Feb 26, 2015 :
    Kudos for trying something new. You should post this on XDA too.
     

    adlibitum and mydroid like this.
  3. azp3
    Jelly Bean Feb 26, 2015

    azp3 , Feb 26, 2015 :
    I posted a link to this thread on xda. You are right, @mariogrip needs to start I thread under the development section.
     

  4. aarondvargas
    Ice Cream Sandwich Feb 26, 2015


  5. Pekeltje
    Gingerbread Feb 26, 2015


  6. deuse
    Jelly Bean Feb 26, 2015

    deuse , Feb 26, 2015 :

    If only CM and 1+ was as fast as you :)
    Can't wait to get my hands on this puppy :)
     

    adlibitum and ChloeWolfieGirl like this.
  7. go for.android13
    Jelly Bean Feb 26, 2015


    ChloeWolfieGirl likes this.
  8. ChloeWolfieGirl
    Gingerbread Feb 26, 2015

    ChloeWolfieGirl , Feb 26, 2015 :
    Data is really important for me, more so then wi-fi, also may I ask what cera is?
     

  9. Android the Greek
    Jelly Bean Feb 26, 2015

    Android the Greek , Feb 26, 2015 :
    Probably camera
     

  10. ChloeWolfieGirl
    Gingerbread Feb 26, 2015

    ChloeWolfieGirl , Feb 26, 2015 :
    That makes sense, I was just a bit confused, on page 1 it says that wi-fi and camera don't work, which confused me because I hadn't seen anyone say data didn't work for sure, so I wasn't even thinking about camera, I was scared cera was something that I didn't know that was actually super important for daily use, but couldn't find it out!

    Camera makes sense though I take quite alot of photos with my phone so I think its important as well! :3
     

  11. dansou901
    Froyo Feb 26, 2015

    dansou901 , Feb 26, 2015 :
    I can't install with rootstock-ng installer. Problem is, whenever I try to, I get :
    transfering rootfs tarball ... [done]
    preparing system-image on device ... [done]
    unpacking rootfs tarball to system-image ... [done]
    adding android system image to installation ... computed crc32 of 0x1bacf508, expected 0x00000000
    I also can't install manually, am stuck at bootanimation. Any hints?
    To clarify: I'm not using Ubuntu for installing, but Arch Linux.
     

    Nyan_ likes this.
  12. ChloeWolfieGirl
    Gingerbread Feb 26, 2015

    ChloeWolfieGirl , Feb 26, 2015 :
    I haven't had that android system image error, but when trying to install I've also been stuck at the bootanimation, I've tried installing it with rootstock a few times, then tried install it manually 3 times and I haven't been successful so I reinstalled CM-12 for the time being.
     

  13. dansou901
    Froyo Feb 26, 2015

    dansou901 , Feb 26, 2015 :
    I guess my problem is that I need to do it on Ubuntu because of simg2img and make_ext4fs commands which I need in the ubuntu version. So I'll try again with an Ubuntu Live CD and hope that it works then.
     

  14. ChloeWolfieGirl
    Gingerbread Feb 26, 2015

    ChloeWolfieGirl , Feb 26, 2015 :
    I'm on ubuntu, as I said I don't get that specific issue, but it still stays looping on the boot image
     

  15. yo6489218
    Cupcake Feb 26, 2015


  16. mariogrip
    Gingerbread Feb 26, 2015

    mariogrip , Feb 26, 2015 :
    I see that there is a lot of people having trouble installing using the rootstock! I will make a quick video on how to install this, and how to fix some errors that may popup
     

  17. Zeero1778
    Froyo Feb 27, 2015


  18. mariogrip
    Gingerbread Feb 27, 2015

    mariogrip , Feb 27, 2015 :
    Here is the new guide! The video is down bellow

    1. Download UbuntuTouch-opo-installer.zip, boot.img, system.img and vivid-preinstalled-touch-armhf.tar.gz

    2. Reboot the device into fastboot mode

    3. Flash boot.img using fastboot
    Code:
    fastboot flash boot boot.img
    4. Boot the device back to recovery (I recommend twrp, but anything should work!)

    5. Wait until adb has started (use "adb devices" to check if it has started)

    6. Extract UbuntuTouch-opo-installer.zip, remember to have the configs folder in the same folder as the script.

    7. Flash ubuntu root system and system.img using rootstock installer
    Code:
    ./OnePlusOne-rootstock-installer vivid-preinstalled-touch-armhf.tar.gz system.img
    8. After that it should boot ubuntu :)
     
    Last edited: Feb 27, 2015

  19. Majinferno
    Ice Cream Sandwich Feb 27, 2015

    Majinferno , Feb 27, 2015 :
    Thanks man. I'll try to test it tomorrow on multiboot.I may or may not have a way to get wifi working. Going to have to play around a bit.
     

  20. mariogrip
    Gingerbread Feb 27, 2015

    Last edited: Feb 27, 2015