0
Your Phone Companion App Not Connecting.

  1. Jonk84
    Cupcake May 16, 2020

    Jonk84 , May 16, 2020 :
    Hi All,

    Hoping someone can help with this.

    Basically I'm having issues connecting my oneplus 7T to my Surface through the Your Phone Companion app. I've tried all that is suggested on Microsofts site - unlinking, relinking etc.

    At first I could only get to 40% - I read online someone tried clearing the cache and resetting the network settings on their phone. After doing this it got me to 90% (screen attached).

    Now I'm stuck on this screen, I press the resend notification but nothing happens. On the app on my phone it just tells me to check my pc and press the send notification button. The latest thing I tried was to turn on Notification access for the Your Phone Companion app, still doesn't work.

    I'm guessing it's some setting within my oneplus 7t but not sure what else it could be.

    Any help appreciated, thank you!

    upload_2020-5-16_12-6-32.png
     

    #1
  2. K1564489291572
    Cupcake May 23, 2020

    K1564489291572 , May 23, 2020 :
    the same thing happening with my one plus 7 and windows 10 PC. I'm also stuck at the same screen. on my phone I try to link PC on my phone after finding PCs name under Bluetooth > Pair New Device option it showing connecting for 5-7 seconds and the PCs' blutooth also shows phone name then drops in both phone and PC
     

    #2
  3. F1591179149783
    Cupcake Jun 7, 2020

    F1591179149783 , Jun 7, 2020 :
    I'm having exactly the same problem with OnePlus 7Pro and Windows 10 PC and Laptop. All used to connect perfectly until a few weeks ago. I have been through every fix on Microsoft support and community but nothing works.
     

    #3
  4. F1591179149783
    Cupcake Jul 28, 2020

    F1591179149783 , Jul 28, 2020 :
    After months of frustration stuck at ".... Checking one more thing..."

    Finally fixed it by going into my router settings and changing my DNS servers to Google's public DNS - 8.8.8.8 and 8.8.4.4

    On my router this was under Internet Connectivity / IPv4 , where I changed from "Obtain DNS Automatically" to Manually Specify DNS" and added 8.8.8.8 and 8.8.4.4

    The Microsoft Troubleshooter guide only mentions Wireless Isolation, i.e.

    "Many routers have a Wireless isolation feature that allow you to lock down the network. If this Wireless Isolation (or AP Isolation) is enabled, then all devices connected to the Wi-Fi network will be blocked from communicating with other".

    My router had nothing about wireless isolation or AP Isolation - Microsoft should add some troubleshooting advice on DNS settings for Your Phone.
     

    #4
  5. vexorg
    Cupcake Aug 4, 2020

    vexorg , via OnePlus 6T , Aug 4, 2020 :
    This used to work perfectly up until about 1 month ago. Still haven't figured this out

    During the initial set up I receive the notification on my phone that the app needs permissions to sms, call logs, contacts, etc. but I can't get past 'Get started' or the spinning/loading icon.
     

    #5
  6. RJMartin
    Cupcake Sep 11, 2020

    RJMartin , Sep 11, 2020 :
    My OnePlus 7 Pro isn't connecting either. It hangs at "We're almost done." It seems that I can't get the final notification. My phone says "Check your PC: From the Your Phone app on your PC, select Send notification. This will send the final permission to your phone." On my PC, it hangs between "We're almost done" and the "Check Your Phone" screen above. Anybody have any ideas?
     

    #6
  7. cotching
    Cupcake Dec 6, 2020

    cotching , Dec 6, 2020 :

    Did you ever find a fix for this? I seem to be having the same issue with my 6T.
     

    #7
  8. RJMartin
    Cupcake Dec 7, 2020


    #8
  9. Bhaveee
    Honeycomb Dec 7, 2020


    #9
  10. rafid1
    Donut Jan 17, 2021


    #10
  11. Gabbarsingh95
    Honeycomb Jan 17, 2021


    #11
    MRTLima likes this.
  12. L1614103501932
    Cupcake Feb 23, 2021 at 6:08 PM


    #12